YAFLogo

bhatasif17
  • bhatasif17
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
6 years ago
Hi

I tried to run YAF project in my VS2013. I did the necessary changes but the project failed to run throwing the below exception.

An error occurred during the activation of a particular registration. See the inner exception for details. Registration: Activator = YafContext (DelegateActivator), Services = [YAF.Core.YafContext], Lifetime = Autofac.Core.Lifetime.CurrentScopeLifetime, Sharing = None, Ownership = ExternallyOwned ---> Object reference not set to an instance of an object. (See inner exception for details.)

Please help.

Thanks

Sponsor
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 4.0.0 rc 2
6 years ago

Hi

I tried to run YAF project in my VS2013. I did the necessary changes but the project failed to run throwing the below exception.

An error occurred during the activation of a particular registration. See the inner exception for details. Registration: Activator = YafContext (DelegateActivator), Services = [YAF.Core.YafContext], Lifetime = Autofac.Core.Lifetime.CurrentScopeLifetime, Sharing = None, Ownership = ExternallyOwned ---> Object reference not set to an instance of an object. (See inner exception for details.)

Please help.

Thanks

Originally Posted by: bhatasif17 

You need atleast VS 2015

bhatasif17
  • bhatasif17
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
6 years ago

Hi

I tried to run YAF project in my VS2013. I did the necessary changes but the project failed to run throwing the below exception.

An error occurred during the activation of a particular registration. See the inner exception for details. Registration: Activator = YafContext (DelegateActivator), Services = [YAF.Core.YafContext], Lifetime = Autofac.Core.Lifetime.CurrentScopeLifetime, Sharing = None, Ownership = ExternallyOwned ---> Object reference not set to an instance of an object. (See inner exception for details.)

Please help.

Thanks

Originally Posted by: tha_watcha 

You need atleast VS 2015

Originally Posted by: bhatasif17 

But I can run the sample application.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 4.0.0 rc 2
6 years ago
Yes the sample application run because the included YAF is already compiled. What changes did you make to compile in VS 2013?