YAFLogo

dprevatt
  • dprevatt
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
11 years ago
I would like to use YAF on a test project within visual studio to try and figure it out better befor I use it within my live site. Is this possible? If so, how do I get started? My goal is to use this within VS2010 and then view it in localhost. Can anyone please provide any instructions or assistance?
Sponsor
januszjasinski
11 years ago
Good luck with that
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 4.0.0 rc 2
11 years ago

I would like to use YAF on a test project within visual studio to try and figure it out better befor I use it within my live site. Is this possible? If so, how do I get started? My goal is to use this within VS2010 and then view it in localhost. Can anyone please provide any instructions or assistance?

Originally Posted by: dprevatt 

The latest Version of yaf needs Visual Studio 2012. But with VS its quite easy to test yaf.

You only need to download the Source Version and load it in to VS and Run the Solution in DEBUG Mode.

Or you use your local IIS which is included in Windows (or use IIS Express with SQL Express).

Coleen
  • Coleen
  • 89.2% (Honored)
  • YAF Commander
11 years ago
http://forum.yetanotherforum.net/yaf_postst15000_DB-Connection-Failure.aspx 

Both of these threads deal with setting up Yaf.net into a .Net Visual studio environment. I am able to run mine with no problems related to it being installed in VS 2010 (although I'm running into some user/password errors but that is unrelated to VS installation)

http://yafnet.codeplex.com/wikipage?title=Installation&referringTitle=Documentation  and if you run into trouble, check both of the other links I posted, and if you still have trouble, post your exact error messages here.

One thing to remember - you MUST have a SQL database setup first in order for the VS installation to work, and be aware that the SQL server that comes with VS is not compatible with yaf.net, you have to download SQL Server Express 2008, and do a complete uninstall FIRST of the one that comes "Standard" with VS 2010. Please read all the posts in my thread, I had a lot of trouble at first because I didn't have the SQL database set up correctly. Once I did, and once I copied the web.config file over correctly, it works!

Good Luck!

Coleen