YAFLogo

dcb1101
  • dcb1101
  • 55% (Neutral)
  • YAF Camper Topic Starter
11 years ago
Hello,

I am trying to fresh install of BlogEngine.net & YetAnotherForum. Everything has been completed using these instructions :

However when I first load the page to install YAF, I get the following error:

Server Error in '/newrs' Application.

Could not find stored procedure 'dbo.yaf_prov_role_exists'.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.SqlClient.SqlException: Could not find stored procedure 'dbo.yaf_prov_role_exists'.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[SqlException (0x80131904): Could not find stored procedure 'dbo.yaf_prov_role_exists'.]

System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection) +2072894

System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection) +5061932

System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning() +234

System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj) +2275

System.Data.SqlClient.SqlDataReader.ConsumeMetaData() +33

System.Data.SqlClient.SqlDataReader.get_MetaData() +86

System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString) +311

System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async) +987

System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result) +162

System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method) +32

System.Data.SqlClient.SqlCommand.ExecuteScalar() +139

YAF.Classes.Data.MsSqlDbAccess.ExecuteScalar(IDbCommand cmd, Boolean transaction) +236

YAF.Types.Interfaces.IDbAccessExtensions.ExecuteScalar(IDbAccess dbAccess, IDbCommand cmd) +56

YAF.Providers.Roles.DB.GetRoleExists(Object appName, Object roleName) +143

YAF.Providers.Roles.YafRoleProvider.RoleExists(String roleName) +45

System.Web.Security.Roles.RoleExists(String roleName) +56

BlogEngine.Core.Right.InitRightForBlogInstance() in J:\Projects\BlogEngine_2_6_0_5\Source\BlogEngine\BlogEngine.Core\Security\Right.cs:607

BlogEngine.Core.Right.get_RightsByRole() in J:\Projects\BlogEngine_2_6_0_5\Source\BlogEngine\BlogEngine.Core\Security\Right.cs:595

BlogEngine.Core.Right.EnsureBlogInstanceDataLoaded() in J:\Projects\BlogEngine_2_6_0_5\Source\BlogEngine\BlogEngine.Core\Security\Right.cs:561

BlogEngine.Core.Right..cctor() in J:\Projects\BlogEngine_2_6_0_5\Source\BlogEngine\BlogEngine.Core\Security\Right.cs:111

[TypeInitializationException: The type initializer for 'BlogEngine.Core.Right' threw an exception.]

BlogEngine.Core.Right..ctor() in J:\Projects\BlogEngine_2_6_0_5\Source\BlogEngine\BlogEngine.Core\Security\Right.cs:534

[TargetInvocationException: Exception has been thrown by the target of an invocation.]

System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck) +0

System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache) +98

System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean skipCheckThis, Boolean fillCache) +241

System.Activator.CreateInstance(Type type, Boolean nonPublic) +69

System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +1136

System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +111

System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture) +23

System.Web.HttpRuntime.CreateNonPublicInstance(Type type, Object[] args) +60

System.Web.HttpApplication.BuildIntegratedModuleCollection(List`1 moduleList) +231

System.Web.HttpApplication.GetModuleCollection(IntPtr appContext) +1365

Microsoft.Web.Infrastructure.DynamicModuleHelper.DynamicModuleReflectionUtil.GetIntegratedModuleCollection(HttpApplication target, IntPtr appContext) +33

Microsoft.Web.Infrastructure.DynamicModuleHelper.CriticalStatics.Init(HttpApplication context) +179

Microsoft.Web.Infrastructure.DynamicModuleHelper.IntegratedDynamicModule.Init(HttpApplication context) +6

System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +517

System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +194

System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +339

System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +253

[HttpException (0x80004005): Exception has been thrown by the target of an invocation.]

System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +9090876

System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +97

System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +256

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272


Sponsor
squirrel
11 years ago
That error means there was an issue with YAF completing the DB install portion of it's setup. I would check the database and see if any stored procedures exist and that tables and indices were created properly --


If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
dcb1101
  • dcb1101
  • 55% (Neutral)
  • YAF Camper Topic Starter
11 years ago
That was using a fresh/empty SQL db.

I also tried to manually run the script from ~/install/mssql/procedures.sql

That code completes and creates the db tables and SP's however I still get the same error


squirrel
11 years ago
If you're getting the proper procedures in your database -- might need to double check YAFs connection data to make sure it is connecting to the right database. It almost sounds like a situation I had recently where we found out that the database we were upgrading was not the same one that the forum was running on --

It almost sounds like your SSMS is talking to the right db, but YAF might be talking to a different one for some reason --

I am going to go through the process you followed on a development server and see if I can un-earth anything odd that would cause that problem... I know inside the YAF install folder, there are two sets of SQL scripts - bbobb specializes in all that - but I can give it a dry run on one of my servers and see what I find --


If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
dcb1101
  • dcb1101
  • 55% (Neutral)
  • YAF Camper Topic Starter
11 years ago
I dumped everything, re-downloaded the install packages for both application and went through the steps again. Not sure if I did something wrong the first time or if something didn't download properly but it worked perfectly this time!

Thanks for your help!