YAFLogo

Davey Ravey
  • Davey Ravey
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
12 years ago
How do I get the option to upload an image when posting? The user is allowed to upload in their role, I have an uploads directory within the website structure, I've tried the bundled CKEditor and still don't see an upload facility, is there another setting in the depths of the configuration I need to set?

This a fresh install not an upgrade.

Thanks in advance,

Dave.

Sponsor
Thantis
  • Thantis
  • 81.8% (Honored)
  • YAF Commander
12 years ago
I believe in CKeditor there is a button near the top to insert images, as for actually upload them as an attachment, near the bottom there should be an option to attach files. Write your post, once you are done with the body, click post, and it should bring up a secondary screen for uploading files attached to the post.
squirrel
12 years ago
Thantis is right -- if you have all your roles setup correctly, at the bottom of the posting screen (regardless of editor) there will be a checkbox to attach files to the post.

If you have checked all your roles, you may need to flush the yaf_ActiveAccess table to get the roles to accept new permissions.


If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
Davey Ravey
  • Davey Ravey
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
12 years ago

Thantis is right -- if you have all your roles setup correctly, at the bottom of the posting screen (regardless of editor) there will be a checkbox to attach files to the post.

If you have checked all your roles, you may need to flush the yaf_ActiveAccess table to get the roles to accept new permissions.

Originally Posted by: squirrel 

Cheers buddy, it's not often DELETE * FROM... fixes problems!

squirrel
12 years ago

Thantis is right -- if you have all your roles setup correctly, at the bottom of the posting screen (regardless of editor) there will be a checkbox to attach files to the post.

If you have checked all your roles, you may need to flush the yaf_ActiveAccess table to get the roles to accept new permissions.

Originally Posted by: Davey Ravey 

Cheers buddy, it's not often DELETE * FROM... fixes problems!

Originally Posted by: squirrel 

It's a known bug in the release version of 1.9.5.5 (the ActiveAccess table reset) - it's been fixed in the SVN but is not in any official releases yet.


If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend