YAFLogo

Underground
13 years ago
I check on a regular base the SVN, because we have the email problem on our side. The emails are send with a huge delay (digest is off) and will then get a burst of emails.

Problem is, that password recovery (reset) won't work, because users don't get an email.

Frustrating, so I am waiting for the next release.

BUT, now I see that you have converted it to .NET 4. Oeps, I am running IIS6 on WK2003, so .NET 4 is not an option for me.

My questions are:

- Are you still providing binaries for .NET 3.5, or is .NET 4 the minimum supported version as of 1.9.5.6

- Is it possible to publish the intermediate builds? So, I can install them on my (test) site. If found OK, I can publish it on the site itself.

- Robert

edit:

Bummer! Just saw the twitter message that it will become .NET 4 only.

This means the end of yaf for me I am afraid. Looks like I have to branche.

Thanks for the work so far, but this is the end of the line for me.


My site containing the YAF forum: Globalcaching.eu 
Dimi
  • Dimi
  • 100% (Exalted)
  • YAF All-the-Time
13 years ago

Bummer! Just saw the twitter message that it will become .NET 4 only.

This means the end of yaf for me I am afraid. Looks like I have to branche.

Thanks for the work so far, but this is the end of the line for me.

Originally Posted by: Underground 

Are you serious? Why don't you install .NET 4.0 on your server? What's the real reason? You can create a useful setup. We're still using 1.1 for some old apps, don't ask why, we still have to. But the same 64-bit server supports 1.1, 3.5 and 4.0 at the same time. I saw couple publications on the Internet explaining why IIS doesn't simultaneously work with 1.1 and 4.0. Well, it works just fine in our setup for 7 or more months so far.


Dimi

UserPostedImage

bbobb
  • bbobb
  • 100% (Exalted)
  • YAF Developer
13 years ago

Originally Posted by: Dimi 

How about licence fee? Wanna be a sponsor?:?

If you ran it at a hosting provider in a shared environment you're having it. But it's not the case with a dedicated server.

Dimi
  • Dimi
  • 100% (Exalted)
  • YAF All-the-Time
13 years ago

Originally Posted by: bbobb 

How about licence fee? Wanna be a sponsor?:?

If you ran it at a hosting provider in a shared environment you're having it. But it's not the case with a dedicated server.

Originally Posted by: Dimi 

Did you mean teh license for IIS? Why can't you install .NET 4.0 on what you're using now? Some unresolvable limitations?


Dimi

UserPostedImage

bbobb
  • bbobb
  • 100% (Exalted)
  • YAF Developer
13 years ago

Did you mean teh license for IIS? Why can't you install .NET 4.0 on what you're using now? Some unresolvable limitations?

Originally Posted by: Dimi 

No, I mean a licence for the whole bunch of compatible code.

I personally use 4.0 + IIS7.5, but I never add a code which can be 3.5 incompatible for this branch.

I personally think that an application should support current framework version - 1 at a release date.

Underground
13 years ago
@Demi:

Yes, I am serious, deadly serious.

I have also developed .NET application that people can download. And for sure, I won't force the users to go to .NET 4, because it too fresh to force them. Also, my code doesn't need the .NET 4 stack.

But things are even more, far more, critical for servers. Large amount of users use the website. Yaf is not the only thing running on the server. I have a dedicated server running in a data center. Upgrading the server involves huge amount of time and risks. Yes, at home on my PC, I just upgrade. But a remote server is something else.

Note that I need to go to IIS7+ in order to use .NET 4. This is not standard on W2K3. Meaning I have to upgrade all sites etc.

For sure, I need to move to another server in a year maybe. Then I can install everything on the new server preparing it in the background and I can move within minutes/hours. But for now, I cannot take the risk of crashing the system.

I did revert to the version in the repository to just before the .NET4 conversion. I will try to go from there, to see if I can fix the email problem.

Too bad, I liked to follow YAF and be up to date. But the developers have made their choise.


My site containing the YAF forum: Globalcaching.eu 
JP
  • JP
  • 100% (Exalted)
  • YAF Leader
13 years ago
I notice that this support forum is now running 1.9.5.6 - Will it be released to us YAF lovers in the near future? 😉
He who asks a question is a fool for five minutes. He who does not ask a question remains a fool forever. [Old Chinese Proverb]
SilhouetteBS
13 years ago
Jaben, any word on when 1.9.5.6 will be available?
naphong
  • naphong
  • 52.4% (Neutral)
  • YAF Forumling
antspiteri
12 years ago
Hi guys ive recently tried upgrading from 1.9.5 RC 1 to the latest release but ran into a couple of errors. Is this even possible? Or should I try upgrading from each individual version till i get to the latest.

P.S I read the readme with the build but still had multiple errors.

squirrel
12 years ago
Generally upgrading from a 'beta' version is not supported. Part of the reason beta and RC versions are not recommended for production servers. What is the nature of your errors (please start a new thread in either the Installation forum or Bugs/Issues forum) for possible help.
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
bbobb
  • bbobb
  • 100% (Exalted)
  • YAF Developer
12 years ago
Upgrading should be supported by YAF code from all versions. At least if you use 1.9.5.x there should not be any problems - beta or not beta - no matter.
BWG
  • BWG
  • 100% (Exalted)
  • YAF Lover
12 years ago

@Demi:

Note that I need to go to IIS7+ in order to use .NET 4. This is not standard on W2K3. Meaning I have to upgrade all sites etc.

.

Originally Posted by: Underground 

.NET 4 runs on IIS 6 / Win 2003.