YAFLogo

Kai2
  • Kai2
  • 60.2% (Friendly)
  • YAF Camper Topic Starter
13 years ago
Hi all,

I'm migrating my board with 14.000 users from 1.91 to 1.94. For about 30 minutes the installation wizard saysw

Migrating Users...

Please do not navigate away from this page while the migration is in progress. It can take a very long time to perform the migration.

Migrating Roles and Users...

So how much is "a very long time"? It would be helpful to have some minutes added here... Is there any chance to see some progress anywhere?

Thanks!

Sponsor
Jaben
  • Jaben
  • 100% (Exalted)
  • YAF Developer
13 years ago
I was thinking about adding progress. Would just be a user counter. I mean, it's a bit of work for just one section of the app and it doesn't get used very much. In my view, better to put that time into something that people use a lot.

Of course, if anyone feels like taking this on...

Kai2
  • Kai2
  • 60.2% (Friendly)
  • YAF Camper Topic Starter
13 years ago
Not necessarily a counter in the web frontend, but I also searched in the Backend DB whether there is some flag or else where I could see how many accounts are already migrated. This will already be helpful to find out whether it's still working. Or just add a rough guess how many users are migrated per minute. 'Very long time' might be 5 minutes or 5 hours. I always remember these annoying windows progress bars that restarted as soon as they reached 100% ... :twisted:
Kai2
  • Kai2
  • 60.2% (Friendly)
  • YAF Camper Topic Starter
13 years ago
Webpage says it's still migrating.... :| Now it's 12 hours ago. Is there any chance that this really will finish somewhen? I've found another posting here which refers to some logs. Is there anything I could check?
Kai2
  • Kai2
  • 60.2% (Friendly)
  • YAF Camper Topic Starter
13 years ago
Hm, still migrating...?? Waiting around 19 hours.... What should I do now?
Jaben
  • Jaben
  • 100% (Exalted)
  • YAF Developer
13 years ago
Shouldn't take 19 hours. Sorry to inform, it's not working anymore. You backed up your database before attempting this upgrade, correct?
Kai2
  • Kai2
  • 60.2% (Friendly)
  • YAF Camper Topic Starter
13 years ago
Yes, sure. But I'll probably not go back to 1.9.18. I wanted to upgrade because I need the unread-marks, and in 1.9.18 this does not work correct. Additionally I spent the whole night to get it running yesterday, no success. So currently I think I'll check whether I really need a forum. Anyway, YAF is great, thanks for your work!! 👍
Jaben
  • Jaben
  • 100% (Exalted)
  • YAF Developer
13 years ago
Make sure that you have your httpRequestTimeout set very high if you try it again.