SCFlabbergaster
  • Posts: 6
  • Joined: 09/12/2009
I have installed YAF 1.9.3 and 1.9.4 and used the GoDaddy install and have the same issue each time. I run through the install and database setup and then get the following error:

The server tag 'asp:UpdatePanel' is ambiguous. Please modify the associated registration that is causing ambiguity and pick a new tag prefix.

I'm using IIS 7.0 and ASP 3.5 (supposedly)

Both 1.9.3 and 1.9.4 run fine locally when I install it as an app on my system under IIS 7.0 and ASP 3.5. But once it is put on GoDaddy, the ambiguous error pops up. I've finally just left it in the 1.9.3 install (I had tried that after I couldn't get 1.9.4 to work). You can find it at http://www.thegridirongamer.com/tggforums/  if you wish to view the error for yourselves.

I don't know what else to do. GoDaddy says that it is in the Web.Config file, but I wouldn't think so. It shouldn't work locally if that were the case. Does anybody have any suggestions? I'm at my wit's end (short though that alley may be).

Any help would be appreciated.

Thanks,
Wayne
Sponsor
kainthedragoonx
  • Posts: 42
  • Joined: 23/04/2007

you probably have two frameworks registered on your site.

Check the <system.web><pages><controls> section and see if you have the same namespace listed there twice. Probably the System.Web.UI and/or the System.Web.UI.Controls




SCFlabbergaster
  • Posts: 6
  • Joined: 09/12/2009
I do have System.Web.UI and System.Web.UI.Webcontrols. So I commented out the System.Web.UI.Webcontrols and it still ran fine locally (with limited testing of the functionality). So I applied it to Godaddy and still no joy. Same ambigous error. So I then tried (knowing it likely would break it) to comment out System.Web.UI and it quit working locally. So I've set everything back to normal. Is the intent from your suggestion to remove one entirely? I would have thought that if this were the mistake, it would not have worked locally as well.
kainthedragoonx
  • Posts: 42
  • Joined: 23/04/2007


Any chance you could post your web.config life? Just hide your passwords as I don't want to see them 😊
SCFlabbergaster
  • Posts: 6
  • Joined: 09/12/2009
No problem, the passwords are in the db.config and app.config files anyway, so there's no editing necessary on my part...

Here it is. I've been banging my head against a wall on this thing forever now, so a fresh set of eyes will be very much appreciated.

<?xml version="1.0" encoding="utf-8"?>
<configuration>

	<configSections>
		<sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
			<sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
				<section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
				<sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
					<section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere" />
					<section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
					<section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
					<section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
				</sectionGroup>
			</sectionGroup>
		</sectionGroup>
		<section name="rewriter" type="Intelligencia.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, Intelligencia.UrlRewriter" requirePermission="false" />
	</configSections> 	

	<connectionStrings configSource="db.config" />
	<appSettings configSource="app.config" />
	<rewriter configSource="URLRewriter.config" />

	<system.net>
		<mailSettings>
			<smtp configSource="mail.config" />
		</mailSettings>
	</system.net>

	<system.web>

		<trace enabled="false" />
		<xhtmlConformance mode="Transitional" />
		<customErrors defaultRedirect="Error.aspx" mode="Off" />

		<globalization requestEncoding="utf-8" responseEncoding="utf-8" />

		<authentication mode="Forms">
			<forms name=".YAFNET_Authentication" protection="All" timeout="43200" cookieless="UseCookies" />
		</authentication>

		<!-- Set debug to "true" to test out the system in development -->
		<compilation defaultLanguage="c#" debug="false">
			<assemblies>
        <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
        <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
        <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
        <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
        <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
        <add assembly="System.Data.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
			</assemblies>
		</compilation>

		<httpHandlers>
			<remove verb="*" path="*.asmx" />
			<add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
			<add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
			<add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" />
		</httpHandlers>

		<httpModules>
			<add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
			<add name="YafInitModule" type="YAF.Classes.Base.YafInitModule, YAF.Classes.Base" />
			<add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter" />
		</httpModules>

		<pages validateRequest="false" smartNavigation="false">
			<controls>
				<add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
				<add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
				<add tagPrefix="ajaxToolkit" namespace="AjaxControlToolkit" assembly="AjaxControlToolkit" />

				<!-- Default: use non-dynamic (compiled classes) in YAF -->
				<add tagPrefix="YAF" namespace="YAF.Classes.UI" assembly="YAF.Classes.UI" />
				<add tagPrefix="YAF" namespace="YAF.Classes.Utils" assembly="YAF.Classes.Utils" />
				<add tagPrefix="YAF" namespace="YAF.Classes.Data" assembly="YAF.Classes.Data" />
				<add tagPrefix="YAF" namespace="YAF.Controls" assembly="YAF.Controls" />
				<add tagPrefix="YAF" namespace="YAF.Controls.Statistics" assembly="YAF.Controls" />

				<!-- Optional: use dynamic classes in YAF by moving all the YAF.x directories (YAF.Classes.*, YAF.Providers)
						into the App_Code\YAF directory. Delete the associated .dll files from the \bin directory. Comment out the above 
						"non-dynamic" namespaces above and enable these: 
				-->

				<!--add tagPrefix="YAF" namespace="YAF.Classes.UI" />
				<add tagPrefix="YAF" namespace="YAF.Classes.Utils" />
				<add tagPrefix="YAF" namespace="YAF.Classes.Data" />
				<add tagPrefix="YAF" namespace="YAF.Controls" />
				<add tagPrefix="YAF" namespace="YAF.Controls.Statistics" /-->

				<add tagPrefix="YAF" namespace="YAF.Classes" />
				<add tagPrefix="YAF" namespace="YAF" />
				<add tagPrefix="editor" namespace="YAF.Editor" />

			</controls>
			<namespaces>
				<add namespace="YAF" />
				<add namespace="YAF.Classes.UI" />
				<add namespace="YAF.Classes.Utils" />
				<add namespace="YAF.Controls" />
				<add namespace="YAF.Classes.Data" />
			</namespaces>
		</pages>

		<roleManager enabled="true" defaultProvider="YafRoleProvider">
			<providers>
				<clear />
					<add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafRoleProvider" type="YAF.Providers.Roles.YafRoleProvider" />
			</providers>
		</roleManager>
		<membership defaultProvider="YafMembershipProvider" hashAlgorithmType="SHA1">
			<providers>
				<clear />
				<add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="true" useSalt="true" type="YAF.Providers.Membership.YafMembershipProvider" />
			</providers>
		</membership>
		<profile enabled="true" defaultProvider="YafProfileProvider" inherits="YAF.Classes.Utils.YafUserProfile">
			<providers>
				<clear />
        		<add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafProfileProvider" type="YAF.Providers.Profile.YafProfileProvider" />
			</providers>
		</profile>
        <trust level="Full" />

	</system.web>

	<system.web.extensions>
		<scripting>
			<!-- 
      		<scriptResourceHandler enableCompression="true" enableCaching="true" />
      		-->
		</scripting>
	</system.web.extensions>

	<system.webServer>
		<validation validateIntegratedModeConfiguration="false" />
		<modules>
			<remove name="ScriptModule" />
			<remove name="YafInitModule" />
			<remove name="UrlRewriter" />
			<add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
			<add name="YafInitModule" type="YAF.Classes.Base.YafInitModule, YAF.Classes.Base" />
			<add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter" preCondition="managedHandler" />
		</modules>
		<handlers>
			<remove name="WebServiceHandlerFactory-Integrated" />
			<remove name="ScriptHandlerFactory" />
			<remove name="ScriptHandlerFactoryAppServices" />
			<remove name="ScriptResource" />
			<add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
			<add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
			<add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
		</handlers>
	</system.webServer>

	<system.codedom>
		<compilers>
			<compiler language="c#;cs;csharp" extension=".cs" warningLevel="4" type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
				<providerOption name="CompilerVersion" value="v3.5" />
				<providerOption name="WarnAsError" value="false" />
			</compiler>
			<compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" warningLevel="4" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
				<providerOption name="CompilerVersion" value="v3.5" />
				<providerOption name="OptionInfer" value="true" />
				<providerOption name="WarnAsError" value="false" />
			</compiler>
		</compilers>
	</system.codedom>

</configuration>
kainthedragoonx
  • Posts: 42
  • Joined: 23/04/2007


ok your web.config looks ok...


when you get a chance, open your web site in VS 2008...right click on your website, click properties page, and see what is listed there. I still think you have duplicate references.

See what is listed there...
SCFlabbergaster
  • Posts: 6
  • Joined: 09/12/2009
As long as having them once in the References section and once in the web.config file is okay, then I'm good. There are no dupe ref's in the properties page, though I noticed that all seven of the System assemblies in the compilation section were in the Reference list, along with several other ref's (such as The YAF namespaces).
kainthedragoonx
  • Posts: 42
  • Joined: 23/04/2007
SCFlabbergaster wrote:

As long as having them once in the References section and once in the web.config file is okay, then I'm good. There are no dupe ref's in the properties page, though I noticed that all seven of the System assemblies in the compilation section were in the Reference list, along with several other ref's (such as The YAF namespaces).





All that should be there. What I was concerned with was having the 2.xx framework dlls and the 3.5.xx framework dlls references as well.


Let me review your web.config again...


EDIT: Have you tried running the site locally? You might have better luck debugging the issues if you where local.
SCFlabbergaster
  • Posts: 6
  • Joined: 09/12/2009
kainthedragoonx wrote:

EDIT: Have you tried running the site locally? You might have better luck debugging the issues if you where local.



Yeah. I can run it fine locally, either debugging in VS 2008 or under IIS 7.0 (using .NET 3.5). No problems whatsoever. That's what really confounds me.

To be honest, I even started to wonder if my web.config file for my other app on that website was getting in the way somehow. But I'm pretty sure that's not the case. However, just to be sure, I may drop the other app and load this in its place just to see if the error persists. I can't imagine how another application on the same website could/would conflict, but I don't claim to be any kind of expert either.

Also, I really do appreciate the help on this. I want to make it work but there's only so much expertise that I can bring to the table.
SCFlabbergaster
  • Posts: 6
  • Joined: 09/12/2009
Found the problem!

The applications were nested. So the Web.config file in the original application was effectively in the root even though I had YAF set up as another application. So I created a new application virtual directory for the original application and put it in there, redirecting from the root to that folder. Now that web.config file is in a parallel directory to the YAF web.config file and it is now successfully installed. Thank you for the help. I'll now get to setting it all up like I need it.
Forum Jump  
  • You cannot post new topics in this forum.
  • You cannot reply to topics in this forum.
  • You cannot delete your posts in this forum.
  • You cannot edit your posts in this forum.
  • You cannot create polls in this forum.
  • You cannot vote in polls in this forum.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved