lucauwf76
  •  lucauwf76
  • 65% (Friendly)
  • YAF Forumling Topic Starter
2009-07-23T18:29:11Z
Hi guys,

Just upgraded from 1.9.3 beta2 to the 1.9.3 Final release and when I try to edit a profile or go to admin I receive various errors, e.g:

Quote:


Null Reference at:
<td class="post">
<%# BBCode.EncodeHTML( PageContext.GetProfile( Eval("UserName").ToString() ).Location ) %>
</td>
in admin.ascx



From searching, I noticed that Jaben suggests the problem to be related to the profile provider, however I didn't change the profile provider in the webconfig (in fact I only changed the app.config to add YAF. as per the instructions and copied across all the new files - then ran the install to update the database).

My profile provider is as such:


Quote:

<profile enabled="true" defaultProvider="YafProfileProvider" inherits="YAF.Classes.Utils.YafUserProfile">
<providers>
<clear/>
<add connectionStringName="yafnet" applicationName="/WebSite2" name="YafProfileProvider" type="YAF.Providers.Profile.YafProfileProvider"/>
</providers>

</profile>



and appears no different to the web-recommended.config that's packaged with it.

Can anyone please help? :(
Thanks.


Sponsor
lucauwf76
  •  lucauwf76
  • 65% (Friendly)
  • YAF Forumling Topic Starter
2009-07-23T18:35:33Z
Hate to say this... but the problem seems to have vanished, and I didn't change anything (except log in as another user, logout, and then back in as admin). :/
The software is that good, that it has become self aware. \o/
:)

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved