wesohaire
  •  wesohaire
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
2008-07-11T13:05:33Z
I've upgraded and now I'm getting a Compilation Error on my site. I've attached a screenshot of the error and believe i upgraded correctly.

-Upgraded from 1.0.0 to 1.9.1.8
-Downloaded 1.9.1.8 BIN and uploaded the files over the current files (but didn't overwrite "Web.config")
-Went to /forumdirectory/install/default.aspx and it said the forum was ready and installed.
-visited the forum homepage and saw the error on the screenshot:


Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0117: 'ASP.forum_ascx' does not contain a definition for 'categoryList_ItemCommand'

Source Error:

Line 12: </div>
Line 13: <br />
Line 14: <asp:Repeater ID="CategoryList" runat="server" OnItemCommand="categoryList_ItemCommand"
Line 15:     OnItemDataBound="CategoryList_ItemDataBound">
Line 16:     <HeaderTemplate>

wesohaire attached the following image(s):
Sponsor
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2008-07-12T11:44:21Z
You upgraded the .ascx files -- but you didn't overwrite the yaf.dll in the \bin directory with the new version.

Also note that as soon as you upgrade, you will get an error. v1.9.1.8 of YAF will not run on .NET v1.1 -- which you are running.
wesohaire
  •  wesohaire
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
2008-07-14T05:11:57Z
awesome, thanks!
Users browsing this topic

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved