Kaan1983
  • Posts: 65
  • Joined: 26/07/2007
Hi,
I'm still trying to integrate YAF into my application.

My current problem is a bit weirdo. Here is the error I'm getting:
Object reference not set to an instance of an object.
Satır 126:
Satır 127: // render the forum
Satır 128: base.Render( writer );
Satır 129:
Satır 130: writer.WriteLine( "</div></div>" );

Source File: c:\Documents and Settings\Kaan\Belgelerim\Visual Studio 2005\WebSites\EMYAF\App_Code\YAF\Forum.cs Satır: 128

Yığın İzleme:

[NullReferenceException: Object reference not set to an instance of an object.]
YAF.Classes.Data.DB.user_guest(Object boardID) +126
YAF.Classes.Utils.UserMembershipHelper.IsGuestUser(Int32 userID) +143
YAF.Controls.UserLink.Render(HtmlTextWriter output) +91
System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25
System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121
.
.
.

and the weird thing is even though I'm manually inserting data into UserGroup table, it inserted line gets deleted when the error occurs.

I'm not into YAF.Classes.Data.DB codes; what should I do?

Thanks.
Sponsor
Kaan1983
  • Posts: 65
  • Joined: 26/07/2007
?

Damn, why does it have to be so hard :|

One more question, I have my own profile management. Do I still need to configure <profile> in web.config?
Forum Jump  
  • You cannot post new topics in this forum.
  • You cannot reply to topics in this forum.
  • You cannot delete your posts in this forum.
  • You cannot edit your posts in this forum.
  • You cannot create polls in this forum.
  • You cannot vote in polls in this forum.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved