tha_watcha
  • Posts: 4133
  • Joined: 06/03/2010
Yes of course this cannot work. change the Banned Name entry

|sTd|, BUZZ


to

\|sTd\|, BUZZ


then it will work! the Banned Name feature uses Regular Expressions.
UserPostedImage
Mnauman
  • Posts: 14
  • Joined: 16/08/2019
Originally Posted by: tha_watcha 

Yes of course this cannot work. change the Banned Name entry

|sTd|, BUZZ


to

\|sTd\|, BUZZ


then it will work! the Banned Name feature uses Regular Expressions.



Kindly guide me how to add regular expressions? how regular expressions works?
tha_watcha
  • Posts: 4133
  • Joined: 06/03/2010
https://docs.microsoft.c...language-quick-reference .

In your case the | is an or opertator which means that it would bann all users that matches

"" or (|) "sTd" or (|) ", BUZZ"

UserPostedImage
Mnauman
  • Posts: 14
  • Joined: 16/08/2019
Originally Posted by: tha_watcha 

https://docs.microsoft.com/en-us/dotnet/standard/base-types/regular-expression-language-quick-reference.

In your case the | is an or opertator which means that it would bann all users that matches

"" or (|) "sTd" or (|) ", BUZZ"



Thanks for the information.
Mnauman
  • Posts: 14
  • Joined: 16/08/2019
Originally Posted by: Mnauman 

when I try to delete some message from forum, although the message is actually deleted but I receive error messages, as you can see in the image below

https://drive.google.com...U9KOf6qlEvRiqw6C-wls8qdY 

what should i do?



Kindly give me some solution about this issue.
tha_watcha
  • Posts: 4133
  • Joined: 06/03/2010
Can you turn off custom errors, and post the full error message the next time this error occurs.
UserPostedImage
Mnauman
  • Posts: 14
  • Joined: 16/08/2019
Originally Posted by: tha_watcha 

Can you turn off custom errors, and post the full error message the next time this error occurs.



how to turn off custom error?
tha_watcha
  • Posts: 4133
  • Joined: 06/03/2010
  1. Open your web.config file.
  2. Inside the <system.web> section, change the <customErrors> tag and change the attribute mode to Off
  3. Save and close the web.config .


UserPostedImage
Mnauman
  • Posts: 14
  • Joined: 16/08/2019
Kindly check the attached image. After deleting message, i got this error now. i disable the custom error.

https://drive.google.com...6ff0Le0l2u7sbp5u_pk1iom7 
tha_watcha
  • Posts: 4133
  • Joined: 06/03/2010
Originally Posted by: Mnauman 

Kindly check the attached image. After deleting message, i got this error now. i disable the custom error.

https://drive.google.com...6ff0Le0l2u7sbp5u_pk1iom7 



Which settings did you use when deleting the message?

Erase message from the database (irreversible) Was this setting checked? also did you check the option delete linked posts?
UserPostedImage
Users browsing this topic
    Forum Jump  
    • You cannot post new topics in this forum.
    • You cannot reply to topics in this forum.
    • You cannot delete your posts in this forum.
    • You cannot edit your posts in this forum.
    • You cannot create polls in this forum.
    • You cannot vote in polls in this forum.

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved