#1
Hi,

Since upgrading to YAF 2.2.4.15 the TinyMCE html editor no longer works. It is selected in the host settings but the bbcode editor appears to be loading instead. CKEditor (html) is working ok.

Can't see any obvious reason for this. I've tried copying across the Tinymce folder from the previous version of YAF but it still does not work.

Ideas?

Thanks

BWG
Topic Starter
  • BWG
  • Rank: YAF Lover
  • Reputation:
    Exalted
    99.4%
  • Joined: 19/01/2010
  • Posts: 72
  • Thanks: 7 times
  • Was thanked: 2 time(s) in 2 post(s)
#2
Originally Posted by: BWG

Hi,

Since upgrading to YAF 2.2.4.15 the TinyMCE html editor no longer works. It is selected in the host settings but the bbcode editor appears to be loading instead. CKEditor (html) is working ok.

Can't see any obvious reason for this. I've tried copying across the Tinymce folder from the previous version of YAF but it still does not work.

Ideas?

Thanks

BWG



YAF reverts back to the Standard editor if the tinymce is not found. It looks for the file tinymce.min.js in the tiny_mce folder Scripts/tinymce/
UserPostedImage
  • tha_watcha
  • Rank: YAF.NET Project Lead
  • Reputation:
    Exalted
    100%
  • Medals:
    Medal of Honor: Portal Puzzle Master: Portal Puzzle Master for DNNMedal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.DNN Master: DNN Module ManBug Killer Medal of Honor: Medal for being a kick-ass bug killer!Medal of Honor for the Support King: Support King! Amazing asset to the YAF.NET Community.
  • Joined: 06/03/2010
  • Posts: 4,003
  •  Germany
  • Thanks: 73 times
  • Was thanked: 1203 time(s) in 1029 post(s)
#3
Originally Posted by: tha_watcha

Originally Posted by: BWG

Hi,

Since upgrading to YAF 2.2.4.15 the TinyMCE html editor no longer works. It is selected in the host settings but the bbcode editor appears to be loading instead. CKEditor (html) is working ok.

Can't see any obvious reason for this. I've tried copying across the Tinymce folder from the previous version of YAF but it still does not work.

Ideas?

Thanks

BWG



YAF reverts back to the Standard editor if the tinymce is not found. It looks for the file tinymce.min.js in the tiny_mce folder Scripts/tinymce/


The tinymce.min.js is in the correct folder. I am running YAF as a virtual application under the root website in IIS. Is it possible that is the reason why it can't resolve the path to the tiny_mce folder?

Edit: I've had chance to do some local debugging and can replicate on my dev machine.

1) In host set the editor to CKEditor (HTML)
2) Post a message

This causes the RegisterCKEditorCustomJS() method to fire

1) In host set the editor to TinyMCE (HTML)
2) Post a message

This does NOT cause the RegisterTinyMceCustomJS() to fire and so the editor is not setting

I don't yet know why this is happening.
Topic Starter
  • BWG
  • Rank: YAF Lover
  • Reputation:
    Exalted
    99.4%
  • Joined: 19/01/2010
  • Posts: 72
  • Thanks: 7 times
  • Was thanked: 2 time(s) in 2 post(s)
#4
Got it!

I upgraded from an older version and the app.config was missing a YAF.FileRoot entry. Not sure why CKEditor (HTML) was working - perhaps the code uses YAF.AppRoot instead.
Topic Starter
  • BWG
  • Rank: YAF Lover
  • Reputation:
    Exalted
    99.4%
  • Joined: 19/01/2010
  • Posts: 72
  • Thanks: 7 times
  • Was thanked: 2 time(s) in 2 post(s)
Forum Jump  
  • You cannot post new topics in this forum.
  • You cannot reply to topics in this forum.
  • You cannot delete your posts in this forum.
  • You cannot edit your posts in this forum.
  • You cannot create polls in this forum.
  • You cannot vote in polls in this forum.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved