vcsharp
  • Posts: 77
  • Joined: 03/10/2017
I am trying to post as a non-admin user on my localhost YAF and every time I post in the forum it says "Since you posted to a moderated forum, a forum moderator must approve your post before it will become visible...".
The forum is not moderated as per settings and also SPAM service is disabled for User and Content checking under Host Settings.

Why would I be getting such a message always? But, if I post as an admin then the post goes through. This is strange and very confusing.
vcsharp
  • Posts: 77
  • Joined: 03/10/2017
The reason I was getting this message for forum being moderated was because I had some custom logic in the stored procedure yaf_message_save that was causing a message id of 0 being returned and the message not being saved.

This had nothing to do with the forum being moderated or messages being checked for spam, which anyhow were not enabled in my case.
Forum Jump  
  • You cannot post new topics in this forum.
  • You cannot reply to topics in this forum.
  • You cannot delete your posts in this forum.
  • You cannot edit your posts in this forum.
  • You cannot create polls in this forum.
  • You cannot vote in polls in this forum.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved