moorehojer
2015-08-06T13:26:08Z
Hi

I am new to yaf and just tryed installing it for the first time (version 2.2.2), but had a little trouble getting the database and web.config to match up.
The website is hosted on our own server but due to licens and prices we have our database hosted in Azure and THAT gave the trouble installing yaf.

Because the website is NOT azure I used recommended.web.config but then the wizard failed in the last step, because it tried using the SP yaf_prov_getuserbyemail.
I traced the problem to the installer using the database to determing if it is azure and therefor installed a database without this SP.

I cleared the website and db and used the recommended-azure.web.config and now the installation completed without any problems.


So my questions are:
1) What is the diffence between the azure setup and the non-azure setup? Since the databases are not the same there mut be som difference.

2) Why is it autodetected by code up against the database and not a setting in the web.config?

3) Are there any problems with hosting YAF on non-azure when the database is Azure?
Sponsor
tha_watcha
2015-08-08T19:27:50Z
1) YAF installs different Provider Scripts, the ones for Azure are newer and optimized for Azure. also the web.configs uses different membership providers. For a non azure setup the recommend providers are the Custom YAF Providers, and for Azure there are the old Standard ASP.NET Membership Providers.

2) Because it needs to check if the environment is azure to install the correct sp's and tables.

3) There shouldn't be any problems.
UserPostedImage

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved