ransems
  • Posts: 11
  • Joined: 16/07/2014
I have a forum page (custom asp.net page) that sets a cookie if the query string passes a proper email and GUID for the user. So when the page gets hit and is validated to the DB all works well and I se the cookie:
Quote:


FormsAuthentication.SetAuthCookie(e, True)
Dim ticket As New FormsAuthenticationTicket(1, e, DateTime.Now, DateTime.Now.AddMinutes(30), False, "", "/" )
Dim strEncTicket As String = FormsAuthentication.Encrypt(ticket)
Dim authCookie As New HttpCookie(".YAFNET_Authentication", strEncTicket)
authCookie.Path = "/"



When I set e as the email address of any user it does not work, go to the forum and they are not logged in. When I set e to the host/super admin it works great.

What's up? any thoughts? Anyone?

RA
Sponsor
ransems
  • Posts: 11
  • Joined: 16/07/2014
I think I figured it our:

there are two data tables:

  1. yaf_User
  2. yaf_prov_Role


I was not making the username change to the second one, so the user was always incorrect...not matching so they had no rights.

Hmmm...funny.
Users browsing this topic
    Forum Jump  
    • You cannot post new topics in this forum.
    • You cannot reply to topics in this forum.
    • You cannot delete your posts in this forum.
    • You cannot edit your posts in this forum.
    • You cannot create polls in this forum.
    • You cannot vote in polls in this forum.

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved