azarbara
  •  azarbara
  • 79.4% (Friendly)
  • YAF Lover Topic Starter
2014-02-04T14:05:30Z
Hello Guys,
Recently i attempt to upgrade YAF like other modules in DNN, so download YAF.net V2.1 from Github and install it from Host>Extensions; during the install accord no problem but after click Return" button" in the last install step receive an error.
also i go to this url http://yourWebsite.com/D...therForumDotNet/install/  but module doesn't upgrade.
current version in my portal is 2, and i want to upgrade to latest version
Please help to upgrade YAF in DNN
Thanks, Mohammad 🙂
Mathematics site in Persian language: http://rayeshmand.ir 
Sponsor
tha_watcha
2014-02-04T14:08:42Z
Can you post the error message you get?
UserPostedImage
azarbara
  •  azarbara
  • 79.4% (Friendly)
  • YAF Lover Topic Starter
2014-02-04T14:16:10Z
Server Error in '/' Application.

Could not load file or assembly 'YAF.Core, Version=2.0.0.0, Culture=neutral, PublicKeyToken=8b49dc47f4701f66' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.IO.FileLoadException: Could not load file or assembly 'YAF.Core, Version=2.0.0.0, Culture=neutral, PublicKeyToken=8b49dc47f4701f66' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
Mathematics site in Persian language: http://rayeshmand.ir 
Zero2Cool
2014-02-04T19:17:38Z
Add the YAF.Core DLL assembly to your /bin directory.
azarbara
  •  azarbara
  • 79.4% (Friendly)
  • YAF Lover Topic Starter
2014-02-04T19:28:42Z
Originally Posted by: Zero2Cool 

Add the YAF.Core DLL assembly to your /bin directory.


the YAF.Core dll Exist in bin directory. (this file added with YAF install in DNN)

Mathematics site in Persian language: http://rayeshmand.ir 
Zero2Cool
2014-02-04T19:29:54Z
Does your web.config reference the same version your error is showing?
azarbara
  •  azarbara
  • 79.4% (Friendly)
  • YAF Lover Topic Starter
2014-02-04T19:40:21Z
i have the following code in web.config
      <add name="YafTaskModule" type="YAF.Core.YafTaskModule, YAF.Core" preCondition="managedHandler" />

Mathematics site in Persian language: http://rayeshmand.ir 
tha_watcha
2014-02-04T21:27:30Z
I guess dnn didn't copy the dlls on installing, because the version numbers are the same as in the previous version. Try to extract all dlls from the install zip and copy them over to your bin folder.
UserPostedImage
azarbara
  •  azarbara
  • 79.4% (Friendly)
  • YAF Lover Topic Starter
2014-02-07T20:51:02Z
please fix this problem.
Mathematics site in Persian language: http://rayeshmand.ir 
Zero2Cool
2014-02-07T21:49:51Z
tha watcha is the best one for this, but he's also extremely busy.


I'll see if I can figure anything out if you can share two links please.

A link to the version of DNN that I can download and install.
A link to the version of YAF that I can download and install.

Both links that you yourself used please.
azarbara
  •  azarbara
  • 79.4% (Friendly)
  • YAF Lover Topic Starter
2014-02-08T04:55:57Z
Originally Posted by: Zero2Cool 

tha watcha is the best one for this, but he's also extremely busy.


I'll see if I can figure anything out if you can share two links please.

A link to the version of DNN that I can download and install.
A link to the version of YAF that I can download and install.

Both links that you yourself used please.


YAF 
DNN 


Mathematics site in Persian language: http://rayeshmand.ir 
tha_watcha
2014-02-08T13:49:32Z
sorry but i can't help you, all dlls in the Install Package are referencing the 2.1.0.0 Assembly. So there must be at least one old dll in your bin folder, or you have optimizeCompilations enabled in the web.config. and the Assemblies are not correctly updated in the runtime.

You can check that by deleting all YAF.... dlls in the bin folder try to run your application then copy the new ones over to the bin folder.
UserPostedImage
tha_watcha
2014-02-09T09:02:08Z
Originally Posted by: azarbara 

Originally Posted by: tha_watcha 

sorry but i can't help you, all dlls in the Install Package are referencing the 2.1.0.0 Assembly. So there must be at least one old dll in your bin folder, or you have optimizeCompilations enabled in the web.config. and the Assemblies are not correctly updated in the runtime.

You can check that by deleting all YAF.... dlls in the bin folder try to run your application then copy the new ones over to the bin folder.


i do this but this version of YAF doesn't install in new installed DNN.



And what is the problem, still the same error as above? Sorry but Telling that something doesn't work or don't install will not help to solve the problem. On install there is always an install reported with error messages in case something went wrong.

UserPostedImage

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved