Zero2Cool
2013-03-13T18:51:38Z
When sending an email to All Users, an email is sent until one is rejected, then the email service starts to send emails from the lowest mailID. This continues to happen over and over again.



  1. Good email
  2. Good email
  3. Good email
  4. Good email
  5. Good email
  6. Bad email


After it attempts to send an email to item 6, it starts back over at item 1 and continues to repeat this.
Sponsor
dcytkimminh
2013-04-21T07:51:26Z
So very usefuly topic to everyboy, hey.
Zero2Cool
2013-04-22T19:01:46Z
I'm using the latest source build and tried sending out an email to "All Users". It seems that it keeps sending an email over and over and over again. I stopped the process after getting my 6th email.


I think it sends an email off to each good email, but if it fails, it starts sending emails from the top of the list again.
Zero2Cool
2013-04-23T15:11:24Z
Tried it again today. The emailer sends an email until it comes to a bad email address, then it starts from the top again.

Any idea why this is happening? Shouldn't the email be removed from yaf_Mail once it is sent so it is not sent again?
JP
  •  JP
  • 100% (Exalted)
  • YAF Leader
2013-04-23T20:07:11Z
Dunno if this is related, but I get these errors for digest email in my error log...

JP attached the following image(s):

He who asks a question is a fool for five minutes. He who does not ask a question remains a fool forever. [Old Chinese Proverb]
Zero2Cool
2013-04-25T01:35:00Z
Tried sending mass email to all users again ... all it does keep sending it over and over to me until I clear out the yaf_Mail table. No errors to report.
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2013-05-05T19:06:16Z
Originally Posted by: Zero2Cool 

Tried it again today. The emailer sends an email until it comes to a bad email address, then it starts from the top again.

Any idea why this is happening? Shouldn't the email be removed from yaf_Mail once it is sent so it is not sent again?


Of course, that's how its designed, yes. I'll take a look.
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2013-05-05T22:19:16Z
Originally Posted by: JP 

Dunno if this is related, but I get these errors for digest email in my error log...


yeah, this is something different. Which version are you running? I think this has been updated in the latest code because that Repository<Board>().ListTyped() doesn't use that Typed<> function anymore that is showing up in your call stack.

Still, I'll be testing, anyway.
JP
  •  JP
  • 100% (Exalted)
  • YAF Leader
2013-05-06T17:54:55Z
Can tell that the digest sending errors do not appear any more with the latest code I compiled (from May 4th ID-8a5621fffab1).

My last compile was from the first half of April.

He who asks a question is a fool for five minutes. He who does not ask a question remains a fool forever. [Old Chinese Proverb]

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved