ankit
  • Posts: 14
  • Joined: 18/01/2013
Hi,
I am integrating YAF into my existing website using Microsoft Visual Studio 2010 and .Net 4.0 framework. I am having problem of "Object reference not set to an instance of an object" when I am implementing YAF using steps given on your website by maing "forum" folder in our existing website. My error is as under when I am trying to add another page in forum folder using my own master page.


=======================================

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[NullReferenceException: Object reference not set to an instance of an object.]
YAF.Modules.PagePopupForumModule.InitAfterPage() +76
YAF.Modules.SimpleBaseForumModule.ForumControl_AfterForumPageLoad(Object sender, YafAfterForumPageLoad e) +36
System.EventHandler`1.Invoke(Object sender, TEventArgs e) +0
YAF.Forum.OnLoad(EventArgs e) +1809
System.Web.UI.Control.LoadRecursive() +54
System.Web.UI.Control.LoadRecursive() +145
System.Web.UI.Control.LoadRecursive() +145
System.Web.UI.Control.LoadRecursive() +145
System.Web.UI.Control.LoadRecursive() +145
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +772

=======================================


Please help me as soon as possible.

Thanks
-Ankit Chhelavda
[M] +91-9909894939
Sponsor
tha_watcha
  • Posts: 4080
  • Joined: 06/03/2010
This is a bug in that Version. If you know how to compile yaf yourself you could grab the latest source code from the CodePlex Repository and compile the fixed version yourself.

Or you download the YAF.SampleWebApplication - C# Version  from the Documentation Page 

And extract the updated dlls (excluding the YAF.SampleWebApplication.dll which you don't need) from that Version (it the 1.9.6.2 Version including this fix for the bug above).
UserPostedImage
ankit
  • Posts: 14
  • Joined: 18/01/2013
Hi, tha_watcha

Thanks for the reply.

I have downloaded the sample webapplication prepared by you but still in that also I am getting same error in that application while integrating master page.

How should I implement it, is there any other way?

Thanks in advance.
Forum Jump  
  • You cannot post new topics in this forum.
  • You cannot reply to topics in this forum.
  • You cannot delete your posts in this forum.
  • You cannot edit your posts in this forum.
  • You cannot create polls in this forum.
  • You cannot vote in polls in this forum.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved