Stegothedump
  • Posts: 28
  • Joined: 15/06/2012
Looking to add some fields to the profile, if i have the source code and I'm assuming i need to change the following

Database
Stored Procedure
User controls

Although have problems tracking down the parts involved, anyone done this?

Stephen
Sponsor
tha_watcha
  • Posts: 4110
  • Joined: 06/03/2010
I wrote a guide a couple month back how to add additionally profile fields, which also could show up on the Register Page.

http://forum.yetanotherf...tion-page.aspx#post54025 
UserPostedImage
The_Ryan
  • Posts: 4
  • Joined: 26/07/2012
Thanks for the reply, i was searching to find to customization of profile.
Stegothedump
  • Posts: 28
  • Joined: 15/06/2012
thanks watcha...I've ran through your post (fantastic) and all the new stuff is compiling without errors..but I now have 63 errors relating to existing code which i have not changed?

An example of one is shown below..


Error 248 'YAF.Pages.register' does not contain a definition for 'PageLinks' and no extension method 'PageLinks' accepting a first argument of type 'YAF.Pages.register' could be found (are you missing a using directive or an assembly reference?) C:\websites\CloudWiseForum\YetAnotherForum.NET\pages\register.ascx.cs 472 14 YAF


Any idea what this would be?

S
tha_watcha
  • Posts: 4110
  • Joined: 06/03/2010
Originally Posted by: Stegothedump

thanks watcha...I've ran through your post (fantastic) and all the new stuff is compiling without errors..but I now have 63 errors relating to existing code which i have not changed?

An example of one is shown below..


Error 248 'YAF.Pages.register' does not contain a definition for 'PageLinks' and no extension method 'PageLinks' accepting a first argument of type 'YAF.Pages.register' could be found (are you missing a using directive or an assembly reference?) C:\websites\CloudWiseForum\YetAnotherForum.NET\pages\register.ascx.cs 472 14 YAF


Any idea what this would be?

S



This happens because Visual Studio messed up the register.ascx.designer.cs file. You need to manually fix the designer files

it should look like this

protected global::YAF.Controls.PageLinks PageLinks;

and

protected global::YAF.Controls.SmartScroller SmartScroller1;



This happens when you dont have a web.config in your solution file. You can avoid that by adding the default yaf web.config (from the webconfigs folder rename the recommended-NET-web to web.config and copy it to the root) to the main YAF Project in VS

UserPostedImage
Stegothedump
  • Posts: 28
  • Joined: 15/06/2012
hmm all i have in that page is the following...can i get a copy from codeplex?

//------------------------------------------------------------------------------
// <auto-generated>
// This code was generated by a tool.
//
// Changes to this file may cause incorrect behavior and will be lost if
// the code is regenerated.
// </auto-generated>
//------------------------------------------------------------------------------

namespace YAF.Pages {


public partial class register {

/// <summary>
/// CreateUserWizard1 control.
/// </summary>
/// <remarks>
/// Auto-generated field.
/// To modify move field declaration from designer file to code-behind file.
/// </remarks>
protected global::System.Web.UI.WebControls.CreateUserWizard CreateUserWizard1;

/// <summary>
/// profile control.
/// </summary>
/// <remarks>
/// Auto-generated field.
/// To modify move field declaration from designer file to code-behind file.
/// </remarks>
protected global::System.Web.UI.WebControls.TemplatedWizardStep profile;
}
}
Stegothedump
  • Posts: 28
  • Joined: 15/06/2012
ok sorted that page but now have an error on the profile page...


Error 205 'YAF.Pages.profile' does not contain a definition for 'YIM' and no extension method 'YIM' accepting a first argument of type 'YAF.Pages.profile' could be found (are you missing a using directive or an assembly reference?) C:\websites\CloudWiseForum\YetAnotherForum.NET\pages\profile.ascx.cs 522 18 YAF


S
Stegothedump
  • Posts: 28
  • Joined: 15/06/2012
ok seems like all my designer files got messed up but they are now all fixed. Final error of the day is


Error 175 Generated serialization assembly is not signed: YAF.XmlSerializers, Version=1.9.6.0, Culture=neutral, PublicKeyToken=null. Please specify strong name key file via /compiler:/keyfile:<file> switch. C:\websites\CloudWiseForum\YetAnotherForum.NET\SGEN YAF


tha_watcha
  • Posts: 4110
  • Joined: 06/03/2010
Originally Posted by: Stegothedump

ok seems like all my designer files got messed up but they are now all fixed. Final error of the day is


Error 175 Generated serialization assembly is not signed: YAF.XmlSerializers, Version=1.9.6.0, Culture=neutral, PublicKeyToken=null. Please specify strong name key file via /compiler:/keyfile:<file> switch. C:\websites\CloudWiseForum\YetAnotherForum.NET\SGEN YAF





You need to disable "Generate serialization assembly" in the Ouput settings of the Yaf project settings in vs.
UserPostedImage
Stegothedump
  • Posts: 28
  • Joined: 15/06/2012
All works perfectly now! Many thanks,

Stephen
Forum Jump  
  • You cannot post new topics in this forum.
  • You cannot reply to topics in this forum.
  • You cannot delete your posts in this forum.
  • You cannot edit your posts in this forum.
  • You cannot create polls in this forum.
  • You cannot vote in polls in this forum.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved