#1
We have YAF version 1.9.301 installed and everything is working properly with the exception of email notifications. I can use the email button within YAF to send an email successfully to a co-worker but when either a new topic is created in a forum I am watching or I post a reply to an existing topic the notification email is not being received.

I am testing this with co-worker since I have seen other posts that indicate this could be an issue with replying to your own topic.

Here are is our mail.config info:

<smtp deliveryMethod="Network" from="zandra.katauskas@mcgladrey.com">
<network host="our SMTP IPAddress" />
</smtp>

<!-- Use this setting for development: pickup directory must be exact path >
<smtp deliveryMethod="SpecifiedPickupDirectory">
<specifiedPickupDirectory pickupDirectoryLocation="C:\Inetpub\wwwroot\email" />
</smtp-->

Our internal Hosting Group indicated that I don't need a user ID or password for SMTP on our local server.

Does anyone have any insight about why this is not working? This is the final and one of the most crucial pieces of our implementation.

Thanks
Topic Starter
  • gpetta
  • Rank: YAF Forumling
  • Reputation:
    Neutral
    50.2%
  • Joined: 25/08/2010
  • Posts: 2
#2
Originally Posted by: gpetta

We have YAF version 1.9.301 installed and everything is working properly with the exception of email notifications. I can use the email button within YAF to send an email successfully to a co-worker but when either a new topic is created in a forum I am watching or I post a reply to an existing topic the notification email is not being received.

I am testing this with co-worker since I have seen other posts that indicate this could be an issue with replying to your own topic.

Here are is our mail.config info:


<smtp deliveryMethod="Network" from="zandra.katauskas@mcgladrey.com">
<network host="our SMTP IPAddress"   />
</smtp>

<!-- Use this setting for development: pickup directory must be exact path >
<smtp deliveryMethod="SpecifiedPickupDirectory">
<specifiedPickupDirectory pickupDirectoryLocation="C:\Inetpub\wwwroot\email" />
</smtp-->

Our internal Hosting Group indicated that I don't need a user ID or password for SMTP on our local server.

Does anyone have any insight about why this is not working? This is the final and one of the most crucial pieces of our implementation.

Thanks


Any errors in the event log? Did notifications ever work? Need to check the yaf_mail table in the database - see if there are messages with many send attempts?
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
  • squirrel
  • Rank: YAF Leader
  • Reputation:
    Exalted
    100%
  • Medals:
    YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports the YAF.NET project with a contribution.YAF.NET Purple Supporter: Purple heart for being an Asset to the YAF.NET Community.YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: A huge help to the YAF.NET community!
  • Joined: 14/01/2010
  • Posts: 925
  • Thanks: 249 times
  • Was thanked: 169 time(s) in 160 post(s)
#3
Hello,
The notifications have never worked and up till now it wasn't really that important but now we are getting pressure to make them work.

There are notification items in the yaf_mail DB but they have no send attempts.

The event log from within the YAF Forum module only shows the following:
ASP.yaf_pages_im_email_ascx

When I click Show I get nothing.

When I check the yaf_eventlog in SQL I get this:
System.Threading.ThreadAbortException: Thread was being aborted. at System.Threading.Thread.AbortInternal() at System.Threading.Thread.Abort(Object stateInfo) at System.Web.HttpResponse.End() at System.Web.HttpResponse.Redirect(String url, Boolean endResponse) at System.Web.HttpResponse.Redirect(String url) at YAF.Classes.Utils.YafBuildLink.Redirect(ForumPages page, String format, Object[] args) in C:\TEMP\YAF\YAFIntegration\YAF.Classes\YAF.Classes.Utils\BuildLink.cs:line 107 at YAF.Pages.im_email.Send_Click(Object sender, EventArgs e) in c:\Inetpub\wwwroot\AIEUPortal\WebSite\yaf\pages\im_email.ascx.cs:line 89

Thank you for your help so far.
Topic Starter
  • gpetta
  • Rank: YAF Forumling
  • Reputation:
    Neutral
    50.2%
  • Joined: 25/08/2010
  • Posts: 2
#4
Thread being aborted usually is an error associated with timeouts and / or the application pool recycling in the middle of a request.

You might try checking the server logs for app pool restarts but I don't think this is the root of your problem. If they never worked, it sounds more like the task to send mail is not running properly.

1.9.3 is a very old version of YAF and significant improvements have been made in the mail routines since that version...

YAF_pages_im_email_ascx is the page that allows a user to directly send an email to another user... I would investigate if notifications are properly configured, and check a user profile to see where the notification level is set to... Above that might require someone more familiar with that older version..

I just moved a 1.9.1.8 YAF to one of my servers to cure mail issues and their site now has properly functioning email service, but they had serious issues related to server mis-configuration. I would investigate options for your mail configuration, maybe trying an outside host to send mail through to see if that changes anything...


If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
  • squirrel
  • Rank: YAF Leader
  • Reputation:
    Exalted
    100%
  • Medals:
    YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports the YAF.NET project with a contribution.YAF.NET Purple Supporter: Purple heart for being an Asset to the YAF.NET Community.YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: A huge help to the YAF.NET community!
  • Joined: 14/01/2010
  • Posts: 925
  • Thanks: 249 times
  • Was thanked: 169 time(s) in 160 post(s)
Forum Jump  
  • You cannot post new topics in this forum.
  • You cannot reply to topics in this forum.
  • You cannot delete your posts in this forum.
  • You cannot edit your posts in this forum.
  • You cannot create polls in this forum.
  • You cannot vote in polls in this forum.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved