johans
  • Posts: 42
  • Joined: 05/06/2012
Hi.

I've (almost) successfully integrated Yaf in my asp.net site, and users can log in and access the forum. I've disabled creating accounts in Yaf, instead i have it using my custom Membership implementation.

I've read a 2 year old post in your forum (sorry, lost url to it) where someone stated my membership classes must inherit from the Yaf membership classes - that must be old information right?

So, my issue is that despite user being able to log in and access the forum, their roles aren't correctly mapped or rather - when the user logs in there is no rows created in table yaf_UserGroup (table yaf_User is filled just fine).

What am i missing?

Board info:
.Net 4.0
Sql Server 2008R2
YAF.NET Version: 1.9.6.1 (Date: 3/18/2012).
Sponsor
johans
  • Posts: 42
  • Joined: 05/06/2012
Ignore me please, i'm an idiot (not exactly, but... ). *Johan learns to code correct next time*
Users browsing this topic
    Forum Jump  
    • You cannot post new topics in this forum.
    • You cannot reply to topics in this forum.
    • You cannot delete your posts in this forum.
    • You cannot edit your posts in this forum.
    • You cannot create polls in this forum.
    • You cannot vote in polls in this forum.

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved