Jaben
  • Posts: 2544
  • Joined: 09/10/2004
KNOWN ISSUES WITH THIS RELEASE: ON INSTALL PLEASE DON'T CHECK "Upgrade BBCode Extensions...". -- Will release another final that just fixes this issue. Very sorry for the problems.


View v1.9.6.1 on CodePlex 

Final!

v1.9.6.1 is .NET v4 ONLY!

Changes and Features in v1.9.6.1:



YAF.NET Community Love

 tha_watcha and  bbobb really made this release happen.

Thank you both for your huge contribution to YAF.NET.


Thanks to squirrel for really stepping up to support the community!

Project Moved
YAF.NET is now on codeplex! http://yafnet.codeplex.com/ 

Official Twitter and Facebook
YAF.NET Twitter is here: http://twitter.com/yafnet  and Facebook is here: http://www.facebook.com/...mNET-YAF/156302224384947 

Languages
Languages may be out of date to the latest in english.xml. Now there is a new language file editor in the admin to make localization much simpler.

Support the YAF.NET Project
Please donate to the project: Donate 

Bug/Issue Tracking
YAF now has proper bug tracking thanks to another excellent open source .NET project: BugNET . Please use the tracker to for issues: http://tracker.yetanotherforum.net/ 
If you want to discuss a possible issue, please post the discussion in this forum: http://forum.yetanotherf...2_Bugs-and-Problems.aspx 

DNN Module
 tha_watcha is managing the release of the Official YAF DNN module and can be downloaded here: http://dnnyafnet.codeplex.com/ 

Compiling
Compiling YAF.NET from source now requires Visual Studio 2010. If you don't have 2010, you can build YAF.NET using the freely available url=http://www.microsoft.com/express/]Visual Studio 2010 Express[/url].

SRC: Includes the compiled forum and forum page files with full source and binaries. Requires .NET v4 or greater.
BIN: Includes the compiled forum and forum page files without the source. Requires .NET v4 or greater.

Download Link to v1.9.6.1 RTW Binary 
Sponsor
tha_watcha
  • Posts: 4108
  • Joined: 06/03/2010
YAF-DNN-Module 1.9.6.1

Download 
UserPostedImage
thienvc
  • Posts: 3
  • Joined: 23/02/2011
can i downgrade to 3.5 framework?
squirrel
  • Posts: 925
  • Joined: 14/01/2010
Originally Posted by: thienvc

can i downgrade to 3.5 framework?



V1.9.6.1 requires .NET 4...

If you want to run this version, you cannot downgrade...
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
thienvc
  • Posts: 3
  • Joined: 23/02/2011
a problem on previous version: can't not run multi forum with multi portals
Zero2Cool
  • Posts: 1082
  • Joined: 26/04/2011
The huge red letters that preface this post, I did not obey.

I'm running 1.9.6.1 under the DNN version in my sig. I've been able to post and haven't had any problems yet, but since I didn't pay attention to the easily readable warning ... I'm thankful I took a full back up before upgrading. 🙂
tha_watcha
  • Posts: 4108
  • Joined: 06/03/2010
Originally Posted by: Zero2Cool

The huge red letters that preface this post, I did not obey.

I'm running 1.9.6.1 under the DNN version in my sig. I've been able to post and haven't had any problems yet, but since I didn't pay attention to the easily readable warning ... I'm thankful I took a full back up before upgrading. :-)



The DNN Version didn't suffer from that Problem the Problem is already fixed there.

Also as side note the Error only occurs on a New Installation on an Upgrade it works without a Problem.
UserPostedImage
bbobb
  • Posts: 1558
  • Joined: 21/10/2008
Data layers for MySQL, PostgreSQL and Firebird for YAF 1.9.6.1 are available in my repository by link in the signature.
Sources with YAF 1.9.6.1 slightly patched (bug fixes) version for MySQL data layer are available in Downloads section. They intended as a last resort for those who can't cope with simple replacements and YAF compiling and as a demo.

The data layers are not supported and are a third-party code from me, but if you can explain what happens in details I will fix it when I have time.Anyway you can negotiate a commersial support if you really need one of the data layers.


All data layers are distributed as a source code only.You can make your own distribution if you like it.

When to use various data layers?

MySQL data layer fits for relatively small sites.To check if it fits for your needs use YAF test data generator.
The datalayer should be upgradable from any earlier versions of my MySQL data layer.
Read manual before using it.

Firebird data layer should be checked in similar manner.

PostgreSQL data layer fits for sites with large workloads I make it for my needs so it's more cared of.

You will find a Manual folder in repository which will hopefully help you to tune it up.

Keep in mind that I use my own custom providers with UUIDs as UserKeys so use your own ASP.NET providers with integer keys - they will be faster for some data layers. YAF allows to use any provider.

Enjoy!
tha_watcha
  • Posts: 4108
  • Joined: 06/03/2010
Originally Posted by: thienvc

Originally Posted by: tha_watcha

YAF-DNN-Module 1.9.6.1

Download 



FILE:
mssql/procedures.sql

ERROR:
Subqueries are not allowed in this context. Only scalar expressions are allowed.

STATEMENT:
CREATE PROCEDURE [dbo].[yaf_message_save](
@TopicID int,
@UserID int,
@Message ntext,
@UserName nvarchar(255)=null,
....

im upgrade from 1.9.5 to 1.9.6.1-5113
How can i fix it?


I Reuploaded the Files now the procedures should be SQL 2005 compatible, please download the Package again

http://dnnyafnet.codeplex.com/releases/view/84988 

UserPostedImage
mika_soukhov
  • Posts: 70
  • Joined: 28/07/2006
Originally Posted by: Jaben

KNOWN ISSUES WITH THIS RELEASE: ON INSTALL PLEASE DON'T CHECK "Upgrade BBCode Extensions...". -- Will release another final that just fixes this issue. Very sorry for the problems.



Sorry for question, but when you planning to re-upload new package?
chromebuster
  • Posts: 42
  • Joined: 05/11/2010
I think he just uploaded, so try again.
Katherine Moss,
Technologist and lover of Boston
Zero2Cool
  • Posts: 1082
  • Joined: 26/04/2011
mtbvfr
  • Posts: 22
  • Joined: 21/05/2012
Has the issue, noted in the first post, been resolved?

If not, this should also be noted on the Download page (http://yetanotherforum.net/download.aspx).

This information should also be added to the ReadMe files of this release.

Whilst, you're modifying the Download page, you should remove the text that says "It's simple to install and ready to run." because it's certainly not Simple.

Thank you, Michael
Thantis
  • Posts: 86
  • Joined: 04/08/2011
Pretty simple, actually. Easy? Not always, but simple yes.
mtbvfr
  • Posts: 22
  • Joined: 21/05/2012
Originally Posted by: Thantis

Pretty simple, actually. Easy? Not always, but simple yes.



If it was Simple then it would also be Easy.
Forum Jump  
  • You cannot post new topics in this forum.
  • You cannot reply to topics in this forum.
  • You cannot delete your posts in this forum.
  • You cannot edit your posts in this forum.
  • You cannot create polls in this forum.
  • You cannot vote in polls in this forum.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved