#1
ok i know its been asked over and over.. and i fixed this after the last upgrade. but someone help... here' s my webconfig.. i put in my username\pw and it tells me its incorrect.

<?xml version="1.0" encoding="utf-8"?>
<configuration>
<configSections>
<section name="rewriter" type="Intelligencia.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, Intelligencia.UrlRewriter" requirePermission="false"/>
</configSections>

<connectionStrings configSource="db.config"/>

<appSettings configSource="app.config"/>

<rewriter configSource="URLRewriter.config"/>

<system.net>
<mailSettings>
<smtp configSource="mail.config"/>
</mailSettings>
</system.net>

<system.web>
<httpRuntime requestValidationMode="2.0"/>

<xhtmlConformance mode="Strict"/>

<customErrors defaultRedirect="Error.aspx" mode="On"/>

<!-- GLOBALIZATION
This section sets the globalization settings of the application.
Utf-8 is not supported on Netscape 4.x
If you need netscape compatiblity leave iso-8859-1.
UTF-8 is recommended for complex languages
-->
<globalization culture="en-US" uiCulture="en" requestEncoding="UTF-8" responseEncoding="UTF-8" fileEncoding="UTF-8" />
<!--<globalization culture="en-US" uiCulture="en" fileEncoding="iso-8859-1" requestEncoding="iso-8859-1" responseEncoding="iso-8859-1"/>-->

<authentication mode="Forms">
<forms name=".YAFNET_Authentication" protection="All" timeout="43200" cookieless="UseCookies"/>
</authentication>

<!-- Set debug to "true" to test out the system in development -->
<compilation debug="false" targetFramework="4.0">
<assemblies>
<add assembly="System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add assembly="System.Data.DataSetExtensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Xml.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Data.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
<add assembly="System.ServiceModel.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
<add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
</assemblies>
</compilation>

<httpHandlers>
<add verb="GET" path="Resource.ashx" type="YAF.YafResourceHandler, YAF" />
</httpHandlers>

<httpModules>
<add name="YafTaskModule" type="YAF.Core.YafTaskModule, YAF.Core"/>
<add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter"/>
</httpModules>

<pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID" enableEventValidation="false" validateRequest="false">
<controls>
<!-- Default: use non-dynamic (compiled classes) in YAF -->
<add tagPrefix="YAF" namespace="YAF.Controls" assembly="YAF.Controls"/>
<add tagPrefix="YAF" namespace="YAF.Controls.Statistics" assembly="YAF.Controls"/>
<add tagPrefix="YAF" namespace="YAF.Classes"/>
<add tagPrefix="YAF" namespace="YAF"/>
</controls>
<namespaces>
<add namespace="YAF.Core"/>
<add namespace="YAF.Controls"/>
<add namespace="YAF.Utils"/>
<add namespace="YAF.Types.Interfaces"/>
<add namespace="YAF.Types"/>
</namespaces>
</pages>

<membership defaultProvider="YafMembershipProvider" hashAlgorithmType="MD5">
<providers>
<clear />
<!-- YAF's ASP.NET Membership Provider is designed to work a bit better with YAF.NET options, but is by no means required.
But, you will not be able to switch providers after installing your forum. -->
<add name="YafMembershipProvider" applicationName="YetAnotherForum" connectionStringName="yafnet" requiresUniqueEmail="true" useSalt="true" type="YAF.Providers.Membership.YafMembershipProvider"/>
<!-- Set as default if you want to use use the built-in ASP.NET membership provider. Password Type of "Encrypted" requires a machine key. -->
<add name="AspNetSqlMembershipProvider" applicationName="YetAnotherForum" connectionStringName="yafnet" enablePasswordReset="false" enablePasswordRetrieval="true" maxInvalidPasswordAttempts="5" minRequiredNonalphanumericCharacters="0" minRequiredPasswordLength="5" passwordAttemptWindow="15" passwordFormat="Encrypted" requiresQuestionAndAnswer="false" requiresUniqueEmail="true" type="System.Web.Security.SqlMembershipProvider" />
</providers>
</membership>

<roleManager enabled="true" defaultProvider="YafRoleProvider">
<providers>
<clear />
<!-- YAF's ASP.NET Role Provider is designed to work a bit better with YAF.NET options, but is by no means required.
But, you will not be able to switch providers after installing your forum. -->
<add name="YafRoleProvider" applicationName="YetAnotherForum" connectionStringName="yafnet" type="YAF.Providers.Roles.YafRoleProvider"/>
<!-- Set as default if you want to use use the built-in ASP.NET role provider. -->
<add name="AspNetSqlRoleProvider" applicationName="YetAnotherForum" connectionStringName="yafnet" type="System.Web.Security.SqlRoleProvider" />
</providers>
</roleManager>

<profile enabled="true" defaultProvider="YafProfileProvider" inherits="YAF.Utils.YafUserProfile">
<providers>
<clear/>
<!-- YAF's ASP.NET Profile Provider is designed to work a bit better with YAF.NET options, but is by no means required.
But, you will not be able to switch providers after installing your forum. -->
<add name="YafProfileProvider" applicationName="YetAnotherForum" connectionStringName="yafnet" type="YAF.Providers.Profile.YafProfileProvider"/>
<!-- Set as default if you want to use use the built-in ASP.NET profile provider. -->
<add name="AspNetSqlProfileProvider" applicationName="YetAnotherForum" connectionStringName="yafnet" type="System.Web.Profile.SqlProfileProvider"/>
</providers>
</profile>

<!-- Enable it if your application is hosted in a web farm or cluster (e.g. GoDaddy hosting) or you are using standard ASP.NET providers and encryption.
IMPORTANT: DO NOT USE THIS KEY! You need to generate your own machine key (google it).
-->
<machineKey
validationKey="60B113ECB6806BD3DD0694572AB828BC4E773CB1E4499750315E439E16C6DC3A65CD49B7FC3DE47FF7BF760B6A23CD50E3BBEE88D212E1442E432D43A0B4DFD3"
decryptionKey="6C49FF782D5EE9F4A5EB0DB7B08A488CAC8827636DABEC87DEA4BEB83332872D"
validation="SHA1" decryption="AES"
/>



</system.web>

<system.webServer>
<validation validateIntegratedModeConfiguration="false"/>
<modules>
<remove name="YafTaskModule"/>
<remove name="UrlRewriter"/>
<add name="YafTaskModule" type="YAF.Core.YafTaskModule, YAF.Core" preCondition="managedHandler"/>
<add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter" preCondition="managedHandler"/>
</modules>
<handlers>
<add name="YafHandler" preCondition="integratedMode" verb="GET" path="Resource.ashx" type="YAF.YafResourceHandler, YAF" />
</handlers>
</system.webServer>
</configuration>



Topic Starter
  • midwestSS
  • Rank: YAF MVP
  • Reputation:
    Exalted
    100%
  • Medals:
    Medal of Honor for Bug Finder: Given for kick-assery at finding bugs by being excellent at QA.Medal of Open Source Contributer: Given to someone who gets open source and gives back to the community.
  • Joined: 17/08/2008
  • Posts: 357
  • Thanks: 6 times
  • Was thanked: 9 time(s) in 8 post(s)
#2
Is your database from a pre-1.9.3 installation originally? If so, your membership provider settings will need to be changed. I understand you might have just upgraded from 1.9.5 or a version more recent than 1.9.1.x but if your database was from 1.9.1.x or earlier, you will need to adapt the membership settings for the older hashing of passwords.
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
  • squirrel
  • Rank: YAF Leader
  • Reputation:
    Exalted
    100%
  • Medals:
    YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports the YAF.NET project with a contribution.YAF.NET Purple Supporter: Purple heart for being an Asset to the YAF.NET Community.YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: A huge help to the YAF.NET community!
  • Joined: 14/01/2010
  • Posts: 925
  • Thanks: 249 times
  • Was thanked: 169 time(s) in 160 post(s)
#3
I don't understand this: "you will need to adapt the membership settings for the older hashing of passwords" How can I do to solve this problem? Thanks you!
  • binhchau
  • Rank: YAF Camper
  • Reputation:
    Friendly
    61.4%
  • Joined: 15/12/2008
  • Posts: 19
  • Thanks: 3 times
#4
Originally Posted by: binhchau

I don't understand this: "you will need to adapt the membership settings for the older hashing of passwords" How can I do to solve this problem? Thanks you!



First step is to read the documentation in the YAF package.

In short:

These are the membership settings in web.config for a YAF database that is version 1.9.1.x --
<membership defaultProvider="YafMembershipProvider" hashAlgorithmType="MD5">
      <providers>
        <clear/>
        <add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="false" type="YAF.Providers.Membership.YafMembershipProvider" hashHex="true" hashCase="upper" />
      </providers>
    </membership>


These are the ones in a web.config for YAF database that is version 1.9.3 or newer --
<membership defaultProvider="YafMembershipProvider" hashAlgorithmType="SHA1">
      <providers>
        <clear/>
        <add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="true" useSalt="true" type="YAF.Providers.Membership.YafMembershipProvider"/>
      </providers>
    </membership>


Since the version you upgraded from is 1.9.1 then you have to merge the settings that were in the "v191-upgrade-web.config" file, which changes the way the membership provider encrypts the passwords.
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
  • squirrel
  • Rank: YAF Leader
  • Reputation:
    Exalted
    100%
  • Medals:
    YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports the YAF.NET project with a contribution.YAF.NET Purple Supporter: Purple heart for being an Asset to the YAF.NET Community.YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: A huge help to the YAF.NET community!
  • Joined: 14/01/2010
  • Posts: 925
  • Thanks: 249 times
  • Was thanked: 169 time(s) in 160 post(s)
#5
After I correct the file web.config. It happens the error:

"šŸ˜‰escription: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off"."
  • binhchau
  • Rank: YAF Camper
  • Reputation:
    Friendly
    61.4%
  • Joined: 15/12/2008
  • Posts: 19
  • Thanks: 3 times
#6
Originally Posted by: binhchau

After I correct the file web.config. It happens the error:

"šŸ˜‰escription: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off"."



You made an error in your web.config, and the server doesn't like it. Can you post the contents of your web.config here?
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
  • squirrel
  • Rank: YAF Leader
  • Reputation:
    Exalted
    100%
  • Medals:
    YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports the YAF.NET project with a contribution.YAF.NET Purple Supporter: Purple heart for being an Asset to the YAF.NET Community.YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: A huge help to the YAF.NET community!
  • Joined: 14/01/2010
  • Posts: 925
  • Thanks: 249 times
  • Was thanked: 169 time(s) in 160 post(s)
#7
Here is my web.config:

<?xml version="1.0"?>
<configuration>
<configSections>
<section name="rewriter" type="Intelligencia.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, Intelligencia.UrlRewriter" requirePermission="false"/>
</configSections>
<connectionStrings configSource="db.config"/>
<appSettings configSource="app.config"/>
<rewriter configSource="URLRewriter.config"/>
<system.net>
<mailSettings>
<smtp configSource="mail.config"/>
</mailSettings>
</system.net>
<system.web>
<trace enabled="false"/>
<xhtmlConformance mode="Transitional"/>
<customErrors defaultRedirect="Error.aspx" mode="On"/>
<globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
<authentication mode="Forms">
<forms name=".YAFNET_Authentication" protection="All" timeout="43200" cookieless="UseCookies"/>
</authentication>
<!-- Set debug to "true" to test out the system in development -->
<compilation defaultLanguage="c#" debug="true">
<assemblies>
<add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Data.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
<add assembly="System.ServiceModel.Web, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
</assemblies>
</compilation>
<httpHandlers>
<remove verb="*" path="*.asmx"/>
<add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/>
<add verb="POST,GET,HEAD" path="ajaxpro/*.ashx" type="AjaxPro.AjaxHandlerFactory, AjaxPro.2"/>
</httpHandlers>
<httpModules>
<add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="YafTaskModule" type="YAF.Classes.Core.YafTaskModule, YAF.Classes.Core"/>
<add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter"/>
</httpModules>
<pages validateRequest="false" smartNavigation="false">
<controls>
<add tagPrefix="šŸ˜‰otNetAge" namespace="šŸ˜‰NA.UI.JQuery" assembly="šŸ˜‰NA.UI.JQuery"/>
<add tagPrefix="šŸ˜‰otNetAge" namespace="šŸ˜‰NA.UI" assembly="šŸ˜‰NA"/>
<add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<!-- Default: use non-dynamic (compiled classes) in YAF -->
<add tagPrefix="YAF" namespace="YAF.Classes.UI" assembly="YAF.Classes.UI"/>
<add tagPrefix="YAF" namespace="YAF.Classes.Utils" assembly="YAF.Classes.Utils"/>
<add tagPrefix="YAF" namespace="YAF.Classes.Core" assembly="YAF.Classes.Core"/>
<add tagPrefix="YAF" namespace="YAF.Classes.Data" assembly="YAF.Classes.Data"/>
<add tagPrefix="YAF" namespace="YAF.Controls" assembly="YAF.Controls"/>
<add tagPrefix="YAF" namespace="YAF.Controls.Statistics" assembly="YAF.Controls"/>
<!-- Optional: use dynamic classes in YAF by moving all the YAF.x directories (YAF.Classes.*, YAF.Providers)
into the App_Code\YAF directory. Delete the associated .dll files from the \bin directory. Comment out the above
"non-dynamic" namespaces above and enable these:
-->
<!--add tagPrefix="YAF" namespace="YAF.Classes.UI" />
<add tagPrefix="YAF" namespace="YAF.Classes.Utils" />
<add tagPrefix="YAF" namespace="YAF.Classes.Data" />
<add tagPrefix="YAF" namespace="YAF.Controls" />
<add tagPrefix="YAF" namespace="YAF.Classes.Core" />
<add tagPrefix="YAF" namespace="YAF.Controls.Statistics" /-->
<add tagPrefix="YAF" namespace="YAF.Classes"/>
<add tagPrefix="YAF" namespace="YAF"/>
</controls>
<namespaces>
<add namespace="YAF"/>
<add namespace="YAF.Classes.UI"/>
<add namespace="YAF.Classes.Utils"/>
<add namespace="YAF.Classes.Core"/>
<add namespace="YAF.Controls"/>
<add namespace="YAF.Classes.Data"/>
</namespaces>
</pages>
<roleManager enabled="true" defaultProvider="YafRoleProvider">
<providers>
<clear/>
<add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafRoleProvider" type="YAF.Providers.Roles.YafRoleProvider"/>
</providers>
</roleManager>
<membership defaultProvider="YafMembershipProvider" hashAlgorithmType="SHA1">
<providers>
<clear/>
<add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="true" useSalt="true" type="YAF.Providers.Membership.YafMembershipProvider"/>
</providers>
</membership>
<profile enabled="true" defaultProvider="YafProfileProvider" inherits="YAF.Classes.Utils.YafUserProfile">
<providers>
<clear/>
<add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafProfileProvider" type="YAF.Providers.Profile.YafProfileProvider"/>
</providers>
</profile>
</system.web>
<system.webServer>
<validation validateIntegratedModeConfiguration="false"/>
<modules>
<remove name="ScriptModule"/>
<remove name="YafTaskModule"/>
<remove name="UrlRewriter"/>
<add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="YafTaskModule" type="YAF.Classes.Core.YafTaskModule, YAF.Classes.Core" preCondition="managedHandler"/>
<add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter" preCondition="managedHandler"/>
</modules>
<handlers>
<remove name="WebServiceHandlerFactory-Integrated"/>
<remove name="ScriptHandlerFactory"/>
<remove name="ScriptHandlerFactoryAppServices"/>
<remove name="ScriptResource"/>
<add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="AjaxPro" verb="POST,GET,HEAD" path="ajaxpro/*.ashx" type="AjaxPro.AjaxHandlerFactory, AjaxPro.2"/>
</handlers>
</system.webServer>
<system.codedom>
<compilers>
<compiler language="c#;cs;csharp" extension=".cs" warningLevel="4" type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
<providerOption name="CompilerVersion" value="v3.5"/>
<providerOption name="WarnAsError" value="false"/>
</compiler>
<compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" warningLevel="4" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
<providerOption name="CompilerVersion" value="v3.5"/>
<providerOption name="OptionInfer" value="true"/>
<providerOption name="WarnAsError" value="false"/>
</compiler>
</compilers>
</system.codedom>
</configuration>

  • binhchau
  • Rank: YAF Camper
  • Reputation:
    Friendly
    61.4%
  • Joined: 15/12/2008
  • Posts: 19
  • Thanks: 3 times
#8
And this is my forum: http://diendan.thpt-chuyenhungvuong-gialai.edu.vn/ 

Moreover,, I can't register the forum.
  • binhchau
  • Rank: YAF Camper
  • Reputation:
    Friendly
    61.4%
  • Joined: 15/12/2008
  • Posts: 19
  • Thanks: 3 times
#9
The first thing you need to to us change the following line:

<customErrors defaultRedirect="Error.aspx" mode="On"/>


to

<customErrors defaultRedirect="Error.aspx" mode="Off"/>


This will tell the server to give us the true error. The web.config you posted does not have the membership provider settings changed, either.

Replace this section:
    <membership defaultProvider="YafMembershipProvider" hashAlgorithmType="SHA1">
      <providers>
        <clear/>
        <add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="true" useSalt="true" type="YAF.Providers.Membership.YafMembershipProvider"/>
      </providers>
    </membership>


with this section:

    <membership defaultProvider="YafMembershipProvider" hashAlgorithmType="MD5">
      <providers>
        <clear/>
        <add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="false" type="YAF.Providers.Membership.YafMembershipProvider" hashHex="true" hashCase="upper" />
      </providers>
    </membership>



If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
  • squirrel
  • Rank: YAF Leader
  • Reputation:
    Exalted
    100%
  • Medals:
    YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports the YAF.NET project with a contribution.YAF.NET Purple Supporter: Purple heart for being an Asset to the YAF.NET Community.YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: A huge help to the YAF.NET community!
  • Joined: 14/01/2010
  • Posts: 925
  • Thanks: 249 times
  • Was thanked: 169 time(s) in 160 post(s)
#10
I've finished it, but I can't login. I can't register the forum. And I can't restore my password.
Would you please give me a hand to solve this? Thanks so much!
  • binhchau
  • Rank: YAF Camper
  • Reputation:
    Friendly
    61.4%
  • Joined: 15/12/2008
  • Posts: 19
  • Thanks: 3 times
#11
Originally Posted by: binhchau

I've finished it, but I can't login. I can't register the forum. And I can't restore my password.
Would you please give me a hand to solve this? Thanks so much!



Repost the current web.config from the forums. You're not getting an error anymore.

Also, you told us you had YAF 1.9.1 and upgraded to 1.9.3. Your forums state they are running YAF 1.9.5 RC1 which is an OLD beta release and not supported.

You have to be ACCURATE on which version of YAF "CREATED" your database -- if your first version of YAF was not 1.9.1 or older, then the upgrade settings do not apply to you.


If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
  • squirrel
  • Rank: YAF Leader
  • Reputation:
    Exalted
    100%
  • Medals:
    YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports the YAF.NET project with a contribution.YAF.NET Purple Supporter: Purple heart for being an Asset to the YAF.NET Community.YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: A huge help to the YAF.NET community!
  • Joined: 14/01/2010
  • Posts: 925
  • Thanks: 249 times
  • Was thanked: 169 time(s) in 160 post(s)
#12
Oh Sorry. I upgraded YAF 1.9.3 to YAF 1.9.5 RC1 but I want to use old database 1.9.3. And now I don't have an error but I Can't still login. For example: IšŸ˜Ø binhchau. Pass: 123456. Or I can't restore my password and can't also register a new user.
Here is my web.config:
<?xml version="1.0"?>
<configuration>
<configSections>
<section name="rewriter" type="Intelligencia.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, Intelligencia.UrlRewriter" requirePermission="false"/>
</configSections>
<connectionStrings configSource="db.config"/>
<appSettings configSource="app.config"/>
<rewriter configSource="URLRewriter.config"/>
<system.net>
<mailSettings>
<smtp configSource="mail.config"/>
</mailSettings>
</system.net>
<system.web>
<trace enabled="false"/>
<xhtmlConformance mode="Transitional"/>
<customErrors defaultRedirect="Error.aspx" mode="Off"/>
<globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
<authentication mode="Forms">
<forms name=".YAFNET_Authentication" protection="All" timeout="43200" cookieless="UseCookies"/>
</authentication>
<!-- Set debug to "true" to test out the system in development -->
<compilation defaultLanguage="c#" debug="true">
<assemblies>
<add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Data.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
<add assembly="System.ServiceModel.Web, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
</assemblies>
</compilation>
<httpHandlers>
<remove verb="*" path="*.asmx"/>
<add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/>
<add verb="POST,GET,HEAD" path="ajaxpro/*.ashx" type="AjaxPro.AjaxHandlerFactory, AjaxPro.2"/>
</httpHandlers>
<httpModules>
<add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="YafTaskModule" type="YAF.Classes.Core.YafTaskModule, YAF.Classes.Core"/>
<add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter"/>
</httpModules>
<pages validateRequest="false" smartNavigation="false">
<controls>
<add tagPrefix="šŸ˜‰otNetAge" namespace="šŸ˜‰NA.UI.JQuery" assembly="šŸ˜‰NA.UI.JQuery"/>
<add tagPrefix="šŸ˜‰otNetAge" namespace="šŸ˜‰NA.UI" assembly="šŸ˜‰NA"/>
<add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<!-- Default: use non-dynamic (compiled classes) in YAF -->
<add tagPrefix="YAF" namespace="YAF.Classes.UI" assembly="YAF.Classes.UI"/>
<add tagPrefix="YAF" namespace="YAF.Classes.Utils" assembly="YAF.Classes.Utils"/>
<add tagPrefix="YAF" namespace="YAF.Classes.Core" assembly="YAF.Classes.Core"/>
<add tagPrefix="YAF" namespace="YAF.Classes.Data" assembly="YAF.Classes.Data"/>
<add tagPrefix="YAF" namespace="YAF.Controls" assembly="YAF.Controls"/>
<add tagPrefix="YAF" namespace="YAF.Controls.Statistics" assembly="YAF.Controls"/>
<!-- Optional: use dynamic classes in YAF by moving all the YAF.x directories (YAF.Classes.*, YAF.Providers)
into the App_Code\YAF directory. Delete the associated .dll files from the \bin directory. Comment out the above
"non-dynamic" namespaces above and enable these:
-->
<!--add tagPrefix="YAF" namespace="YAF.Classes.UI" />
<add tagPrefix="YAF" namespace="YAF.Classes.Utils" />
<add tagPrefix="YAF" namespace="YAF.Classes.Data" />
<add tagPrefix="YAF" namespace="YAF.Controls" />
<add tagPrefix="YAF" namespace="YAF.Classes.Core" />
<add tagPrefix="YAF" namespace="YAF.Controls.Statistics" /-->
<add tagPrefix="YAF" namespace="YAF.Classes"/>
<add tagPrefix="YAF" namespace="YAF"/>
</controls>
<namespaces>
<add namespace="YAF"/>
<add namespace="YAF.Classes.UI"/>
<add namespace="YAF.Classes.Utils"/>
<add namespace="YAF.Classes.Core"/>
<add namespace="YAF.Controls"/>
<add namespace="YAF.Classes.Data"/>
</namespaces>
</pages>
<roleManager enabled="true" defaultProvider="YafRoleProvider">
<providers>
<clear/>
<add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafRoleProvider" type="YAF.Providers.Roles.YafRoleProvider"/>
</providers>
</roleManager>
<membership defaultProvider="YafMembershipProvider" hashAlgorithmType="MD5">
<providers>
<clear/>
<add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="false" type="YAF.Providers.Membership.YafMembershipProvider" hashHex="true" hashCase="upper" />
</providers>
</membership>
<profile enabled="true" defaultProvider="YafProfileProvider" inherits="YAF.Classes.Utils.YafUserProfile">
<providers>
<clear/>
<add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafProfileProvider" type="YAF.Providers.Profile.YafProfileProvider"/>
</providers>
</profile>
</system.web>
<system.webServer>
<validation validateIntegratedModeConfiguration="false"/>
<modules>
<remove name="ScriptModule"/>
<remove name="YafTaskModule"/>
<remove name="UrlRewriter"/>
<add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="YafTaskModule" type="YAF.Classes.Core.YafTaskModule, YAF.Classes.Core" preCondition="managedHandler"/>
<add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter" preCondition="managedHandler"/>
</modules>
<handlers>
<remove name="WebServiceHandlerFactory-Integrated"/>
<remove name="ScriptHandlerFactory"/>
<remove name="ScriptHandlerFactoryAppServices"/>
<remove name="ScriptResource"/>
<add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="AjaxPro" verb="POST,GET,HEAD" path="ajaxpro/*.ashx" type="AjaxPro.AjaxHandlerFactory, AjaxPro.2"/>
</handlers>
</system.webServer>
<system.codedom>
<compilers>
<compiler language="c#;cs;csharp" extension=".cs" warningLevel="4" type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
<providerOption name="CompilerVersion" value="v3.5"/>
<providerOption name="WarnAsError" value="false"/>
</compiler>
<compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" warningLevel="4" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
<providerOption name="CompilerVersion" value="v3.5"/>
<providerOption name="OptionInfer" value="true"/>
<providerOption name="WarnAsError" value="false"/>
</compiler>
</compilers>
</system.codedom>
</configuration>
  • binhchau
  • Rank: YAF Camper
  • Reputation:
    Friendly
    61.4%
  • Joined: 15/12/2008
  • Posts: 19
  • Thanks: 3 times
#13
What version of YAF did you have when you first started your forums?
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
  • squirrel
  • Rank: YAF Leader
  • Reputation:
    Exalted
    100%
  • Medals:
    YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports the YAF.NET project with a contribution.YAF.NET Purple Supporter: Purple heart for being an Asset to the YAF.NET Community.YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: A huge help to the YAF.NET community!
  • Joined: 14/01/2010
  • Posts: 925
  • Thanks: 249 times
  • Was thanked: 169 time(s) in 160 post(s)
#14
I had YAF 1.9.3
  • binhchau
  • Rank: YAF Camper
  • Reputation:
    Friendly
    61.4%
  • Joined: 15/12/2008
  • Posts: 19
  • Thanks: 3 times
#15
Originally Posted by: binhchau

I had YAF 1.9.3



OK. Then we are back to the original situation. I'll have you put the original membership settings back into your web.config, and then we will try again to find true problem.

Replace the following section in your web.config:
    <membership defaultProvider="YafMembershipProvider" hashAlgorithmType="MD5">
      <providers>
        <clear/>
        <add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="false" type="YAF.Providers.Membership.YafMembershipProvider" hashHex="true" hashCase="upper" />
      </providers>
    </membership>


With this:
    <membership defaultProvider="YafMembershipProvider" hashAlgorithmType="SHA1">
      <providers>
        <clear/>
        <add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="true" useSalt="true" type="YAF.Providers.Membership.YafMembershipProvider"/>
      </providers>
    </membership>


After that, I'll try to create account or login and we will see what is happening.
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
  • squirrel
  • Rank: YAF Leader
  • Reputation:
    Exalted
    100%
  • Medals:
    YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports the YAF.NET project with a contribution.YAF.NET Purple Supporter: Purple heart for being an Asset to the YAF.NET Community.YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: A huge help to the YAF.NET community!
  • Joined: 14/01/2010
  • Posts: 925
  • Thanks: 249 times
  • Was thanked: 169 time(s) in 160 post(s)
Forum Jump  
  • You cannot post new topics in this forum.
  • You cannot reply to topics in this forum.
  • You cannot delete your posts in this forum.
  • You cannot edit your posts in this forum.
  • You cannot create polls in this forum.
  • You cannot vote in polls in this forum.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved