krinkirkland
2011-11-08T16:19:05Z
Hello all,

I have upgraded my forum to 1.9.6 BETA 1. Since that upgrade, it appears that all posts require moderation regardless of whether or not I have the "Pre-moderated:" option checked for the forum.

Is this a known issue or is there a workaround?

Thank you in advance for your attention.

Sponsor
tha_watcha
2011-11-08T16:24:48Z
Yes its a known Issue and there is A Workaround for that.

The Problem Is the Spam Service Flags sometimes harmless Messages as SPAM, by default in the BETA the Message is flagged as "must be approved by Mod" You can change that in the Host Settings under SPAM Settings you can disable the SPAM Checking "Choose a SPAM Service for Automatically SPAM Checking".
UserPostedImage
krinkirkland
2011-11-08T16:30:12Z
I'm going to give it a try. Thank you for your response!
krinkirkland
2011-11-14T22:21:12Z
Just a follow up:

It appears to work for a while, but the Spam Service appears to be turning back on for a reason that I can't see. I'll turn off Spam Checking, just to have it on the next day.

Is there anything I can do about that?

Thanks again!
krinkirkland
2011-11-18T17:01:17Z
I'm still getting the above issue. I've been going into the host settings and turning it back off daily. I'm curious if there is a process that is restoring it to being switched on?

Thanks!
krinkirkland
2011-12-15T18:34:20Z
I have been clicking to disable the spam filter daily, just to find it turned back on in the next day. Today, I decided to dig deeper and found that the yaf_registry table was not storing the changes that I'd been asking it to do. Apparently there is some disconnect between me clicking save and the changes being written to the database.

In the end, I've updated the database directly and hope this resolves the issue.

I used the following queries:


update yaf_Registry
  SET Value = 'False'
  WHERE RegistryID = 66
  
  update yaf_Registry
  SET Value = '0'
  WHERE RegistryID = 229
tha_watcha
2011-12-15T18:50:23Z
Originally Posted by: krinkirkland 

I have been clicking to disable the spam filter daily, just to find it turned back on in the next day. Today, I decided to dig deeper and found that the yaf_registry table was not storing the changes that I'd been asking it to do. Apparently there is some disconnect between me clicking save and the changes being written to the database.

In the end, I've updated the database directly and hope this resolves the issue.

I used the following queries:


update yaf_Registry
  SET Value = 'False'
  WHERE RegistryID = 66
  
  update yaf_Registry
  SET Value = '0'
  WHERE RegistryID = 229



Is that the only setting that is not saved, or is no setting saved when you click Save?

Is there an Error Entry in the Event Log?

UserPostedImage
krinkirkland
2011-12-15T19:01:20Z
I too have ran into the MaxPostSize issue that was reported here. When I update that I run into the same roadblock. When I try updating another field just now, this is the error log:


System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.InvalidCastException: Null object cannot be converted to a value type.
   at System.Convert.ChangeType(Object value, Type conversionType, IFormatProvider provider)
   at System.Convert.ChangeType(Object value, Type conversionType)
   at YAF.Classes.Pattern.RegistryDictionaryOverride.SetValue[T](String name, T value, Boolean setOverrideOnly)
   at YAF.Classes.Pattern.RegistryDictionaryOverride.SetValue[T](String name, T value)
   at YAF.Classes.YafBoardSettings.set_MaxPostSize(Int32 value)
   --- End of inner exception stack trace ---
   at System.RuntimeMethodHandle._InvokeMethodFast(IRuntimeMethodInfo method, Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeType typeOwner)
   at System.RuntimeMethodHandle.InvokeMethodFast(IRuntimeMethodInfo method, Object target, Object[] arguments, Signature sig, MethodAttributes methodAttributes, RuntimeType typeOwner)
   at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks)
   at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at System.Reflection.RuntimePropertyInfo.SetValue(Object obj, Object value, BindingFlags invokeAttr, Binder binder, Object[] index, CultureInfo culture)
   at System.Reflection.RuntimePropertyInfo.SetValue(Object obj, Object value, Object[] index)
   at YAF.Pages.Admin.hostsettings.Save_Click(Object sender, EventArgs e)
   at System.Web.UI.WebControls.Button.OnClick(EventArgs e)
   at System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument)
   at System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument)
   at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
   at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)


I have downloaded the source code and tried to fix the maxPostSize accessor to be a short instead of an int as recommended, but when I build the DLL the website will no longer function. It then be came a long string of assembly references that wouldn't work. In the end, I updated the registry table to have a smaller maxPostSize as well. I stopped and figured that at this point this is beta software and more than likely will be fixed before release. I put this up here to help anyone else out who has seen this issue.
Dr-Hack
2012-02-01T03:05:24Z
I have the same issue .. all posts get queued for moderation .. how to do i turn it off :S

in Host Settings under "Host Setup" last three options are regarding SPAM ..
i am using Askimet .. and before i selecred "DO nothing" it still use to land all the posts in moderation just changed it right now to flag as inappropriate (what it does?)

so how do i turn moderation off? any place else there is some setting regarding this ?
tha_watcha
2012-02-01T03:42:34Z
Originally Posted by: Dr-Hack 

I have the same issue .. all posts get queued for moderation .. how to do i turn it off :S

in Host Settings under "Host Setup" last three options are regarding SPAM ..
i am using Askimet .. and before i selecred "DO nothing" it still use to land all the posts in moderation just changed it right now to flag as inappropriate (what it does?)

so how do i turn moderation off? any place else there is some setting regarding this ?



If you Set it to inappropriate you turned on the moderating, because a flagged post is set to unapproved.

Choose disabled as spam service type to completely disable that feature.

I investigate on the spam check problem on the weekend, to make sure it works correctly in the final version.

Ps: did you enter your akismet key when using this service?
UserPostedImage
Dr-Hack
2012-02-01T05:07:34Z
Ok.. I will see after disabling... yes I have entered the key took it from my blog.. Yes please do look into it.lately yaf communities are Under great spam so turning it off will be risky but i can do till weekend ...



first post from yaf mobile theme:) how about tapatalk hmm
tha_watcha
2012-02-01T12:10:03Z
Originally Posted by: Dr-Hack 

Originally Posted by: tha_watcha 


Choose disabled as spam service type to completely disable that feature.




Even after Disabling the Service completely the Posts still land in for moderation .. you would really need to look into it now , as there is no notification aswell on the "Moderate" link which should be there ..



It doesnt look like a problem of the spam service. Did you turn on "Pre-moderated" for the Forum you are trying to post in
UserPostedImage
natsuto
2012-02-10T01:47:43Z
Because there is no "moderate" link, there should be notification as well.
Dr-Hack
2012-02-10T03:24:40Z
True that had to be there...

But the spam gets passed askimet ... :
tha_watcha
2012-02-10T03:53:20Z
Originally Posted by: natsuto 

Because there is no "moderate" link, there should be notification as well.



There is a moderate link. And yaf sends out notifications when a message is reported or needs to be approved, to moderators. But this need to be enabled in the host settings.
UserPostedImage

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved