Davey Ravey
  • Posts: 2
  • Joined: 23/08/2011
How do I get the option to upload an image when posting? The user is allowed to upload in their role, I have an uploads directory within the website structure, I've tried the bundled CKEditor and still don't see an upload facility, is there another setting in the depths of the configuration I need to set?

This a fresh install not an upgrade.

Thanks in advance,
Dave.
Sponsor
Thantis
  • Posts: 86
  • Joined: 04/08/2011
I believe in CKeditor there is a button near the top to insert images, as for actually upload them as an attachment, near the bottom there should be an option to attach files. Write your post, once you are done with the body, click post, and it should bring up a secondary screen for uploading files attached to the post.
squirrel
  • Posts: 925
  • Joined: 14/01/2010
 Thantis is right -- if you have all your roles setup correctly, at the bottom of the posting screen (regardless of editor) there will be a checkbox to attach files to the post.

If you have checked all your roles, you may need to flush the yaf_ActiveAccess table to get the roles to accept new permissions.
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
Davey Ravey
  • Posts: 2
  • Joined: 23/08/2011
Originally Posted by: squirrel

 Thantis is right -- if you have all your roles setup correctly, at the bottom of the posting screen (regardless of editor) there will be a checkbox to attach files to the post.

If you have checked all your roles, you may need to flush the yaf_ActiveAccess table to get the roles to accept new permissions.




Cheers buddy, it's not often DELETE * FROM... fixes problems!
squirrel
  • Posts: 925
  • Joined: 14/01/2010
Originally Posted by: Davey Ravey

Originally Posted by: squirrel

 Thantis is right -- if you have all your roles setup correctly, at the bottom of the posting screen (regardless of editor) there will be a checkbox to attach files to the post.

If you have checked all your roles, you may need to flush the yaf_ActiveAccess table to get the roles to accept new permissions.




Cheers buddy, it's not often DELETE * FROM... fixes problems!


It's a known bug in the release version of 1.9.5.5 (the ActiveAccess table reset) - it's been fixed in the SVN but is not in any official releases yet.
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
Users browsing this topic
    Forum Jump  
    • You cannot post new topics in this forum.
    • You cannot reply to topics in this forum.
    • You cannot delete your posts in this forum.
    • You cannot edit your posts in this forum.
    • You cannot create polls in this forum.
    • You cannot vote in polls in this forum.

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved