lfosdal
  •  lfosdal
  • 72.8% (Friendly)
  • YAF Lover Topic Starter
2011-03-25T21:48:26Z
Help!

This wednesday something really weird happened. My hosting ISP went ballistic because the board started taking down the process pool. Note that I have not made any changes to the board, the database, or the .NET code, or to the hosting service.

After a lot of digging, I can see only one common factor.

For most users, the board acts normally - but for one specific user - accessing a thread where the user have posted something (topic or message), or even when accessing the user profile, the server will churn and churn and eat a LOT of CPU - slowing down the entire server. Oddly enough, accessing the user's setting through the admin panel does not cause any problems.

I need advice on how to identify and rectify the cause of this. I suspect some sort of illogical data reference, causing a loop or lockup - but where to start looking? The yaf_User table looks ok.

Using SQL Server Management Studio, I have rebuilt indices, refreshed the views, compacted the db, and run every diagnostic I can think of.
Nothing helps.
- There are no stupid questions.
Sponsor
lfosdal
  •  lfosdal
  • 72.8% (Friendly)
  • YAF Lover Topic Starter
2011-03-26T10:26:10Z
Have noone seen this before? Any suggestions to where start looking?
- There are no stupid questions.
bbobb
  •  bbobb
  • 100% (Exalted)
  • YAF Developer
2011-03-26T11:04:02Z
The problem is that you use an old version. I suspect that it's related to a specific post content as profile has last 10 posts link. The regexps which handle this were many times rwritten since your 1.9.4 version.
You should look for a post which is a troublemaker and delete it.
lfosdal
  •  lfosdal
  • 72.8% (Friendly)
  • YAF Lover Topic Starter
2011-03-26T14:52:53Z
Any post this user has posted in, will freeze the server.

I have inspected the Topic and Message tables for the user within the last week, and can't find anything that looks bad. I also delete the more recent posts from the user, but any thread with this user in, will lock up the server.

I guess making the upgrade is a major task, as we have a custom theme, and also some custom code that needs to be ported.


- There are no stupid questions.
bbobb
  •  bbobb
  • 100% (Exalted)
  • YAF Developer
2011-03-26T15:21:00Z
You should inspect database directly.
Begin with _user table and compare the user data with others.
Look for Flags column too - does it have an unrepeating unusual integer value.
Try and change registration name in membership provider table and in _user table by hand.
Remove his avatar, signature and Location one by one. Maybe temoprarily.
If it's OK move to membership, role and profile providers tables.
Don't forget, that user data is cached and be sure that the cache is reset after the changes.


Dr-Hack
2011-03-26T17:42:14Z
open the text version of the same post that kills the process (no interactive,images etc) and see ... there are many characters which sometimes mess with the site (yes there are like the invisible unicode).

most probably the point covered by bbobb will solve the issue ..

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved