#1
I just compiled and installed the new forum. (rev 4217)
First on our test site and after testing on our live site.

Everything seemed ok, but I noticed that when I would click on a link to jump to a topic, the page was redirected and a #postxxxx was added. This was not really acceptable, so I had to fix this. I haven't really worked with the code, so I have no idea if I did the right thing or I caused other issues, but the following did the trick for me:

in /pages/post.ascx.cs
in BindData
I commented this:

// move to this message on load...
//PageContext.PageElements.RegisterJsBlockStartup(
// this, "GotoAnchorJs", JavaScriptBlocks.LoadGotoAnchor("post{0}".FormatWith(findMessageId)));

This 'otoAnchorJs' caused this behaviour, so I removed it.

Furthermore, I never had installation problems on our test-site, but when I wanted to install it on my production site I got an exception during installation.... #$@$# (that is not what you want on a live website)
I turned off the error redirection and saw that the column NotificationType in yaf_User was checked wrong. With sweety hand palms, I just added the column (int, null) and tried it again and all went fine.

Next I had issues with a lot of stuff, but after saving the host settings and restarting the application, all seems fine.
But I do think that the developers should look at those two problems.

- Robert
My site containing the YAF forum: Globalcaching.eu 
Topic Starter
  • Underground
  • Rank: YAF Commander
  • Reputation:
    Exalted
    100%
  • Joined: 05/06/2009
  • Posts: 103
  • Thanks: 18 times
  • Was thanked: 8 time(s) in 8 post(s)
#2
Developers, are you looking into this or you leave it?
Either or, a reply would be appreciated
My site containing the YAF forum: Globalcaching.eu 
Topic Starter
  • Underground
  • Rank: YAF Commander
  • Reputation:
    Exalted
    100%
  • Joined: 05/06/2009
  • Posts: 103
  • Thanks: 18 times
  • Was thanked: 8 time(s) in 8 post(s)
#3
The Problem with the "#postxx" was reported before and is in the bugtracker

http://tracker.yetanothe...IssueDetail.aspx?id=128. 

As far as i see the code...

JavaScriptBlocks.LoadGotoAnchor


is not needed.
UserPostedImage
  • tha_watcha
  • Rank: YAF.NET Project Lead
  • Reputation:
    Exalted
    100%
  • Medals:
    Medal of Honor: Portal Puzzle Master: Portal Puzzle Master for DNNMedal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.DNN Master: DNN Module ManBug Killer Medal of Honor: Medal for being a kick-ass bug killer!Medal of Honor for the Support King: Support King! Amazing asset to the YAF.NET Community.
  • Joined: 06/03/2010
  • Posts: 4,016
  •  Germany
  • Thanks: 73 times
  • Was thanked: 1211 time(s) in 1036 post(s)
#4
We have the same problem again or still.
In 1.9.5.5. BETA.

Is the script enabled again or never been disabled like I described before?
My site containing the YAF forum: Globalcaching.eu 
Topic Starter
  • Underground
  • Rank: YAF Commander
  • Reputation:
    Exalted
    100%
  • Joined: 05/06/2009
  • Posts: 103
  • Thanks: 18 times
  • Was thanked: 8 time(s) in 8 post(s)
#5
Originally Posted by: tha_watcha

The Problem with the "#postxx" was reported before and is in the bugtracker

http://tracker.yetanothe...IssueDetail.aspx?id=128. 

As far as i see the code...

JavaScriptBlocks.LoadGotoAnchor


is not needed.

Here is a POST made today ago about how USEFUL this feature IS:

http://forum.yetanotherf...s-feature.aspx#post46127 
  • Jaben
  • Rank: YAF Developer
  • Reputation:
    Exalted
    100%
  • Medals:
    Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: Given to a community member who tirelessly answers tons of support questions.
  • Joined: 09/10/2004
  • Posts: 2,544
  • Location: United States
  • Thanks: 142 times
  • Was thanked: 352 time(s) in 195 post(s)
#6
Originally Posted by: Underground

We have the same problem again or still.
In 1.9.5.5. BETA.

Is the script enabled again or never been disabled like I described before?


Uhh -- It's such a simple fix...

I guess if want something done correctly, you have to do it yourself. I'll add a fix for this for v1.9.5.5 final.
  • Jaben
  • Rank: YAF Developer
  • Reputation:
    Exalted
    100%
  • Medals:
    Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: Given to a community member who tirelessly answers tons of support questions.
  • Joined: 09/10/2004
  • Posts: 2,544
  • Location: United States
  • Thanks: 142 times
  • Was thanked: 352 time(s) in 195 post(s)
#7
I understand the purpose of the feauture. Would love it too, unless.... unless it means that the page is loaded twice, then I prefer not to have this 'feature' 😉
My site containing the YAF forum: Globalcaching.eu 
Topic Starter
  • Underground
  • Rank: YAF Commander
  • Reputation:
    Exalted
    100%
  • Joined: 05/06/2009
  • Posts: 103
  • Thanks: 18 times
  • Was thanked: 8 time(s) in 8 post(s)
#8
rev4481.... very fast Jaben! Thanks 🙂
My site containing the YAF forum: Globalcaching.eu 
Topic Starter
  • Underground
  • Rank: YAF Commander
  • Reputation:
    Exalted
    100%
  • Joined: 05/06/2009
  • Posts: 103
  • Thanks: 18 times
  • Was thanked: 8 time(s) in 8 post(s)
#9
And the problem is back... *sigh*
I saw you have added the last unread link in active topics.
And again I see the same problem.
http://forum.yetanotherforum.net/yaf_postsm46591_Error-in-Page-Moderate-ascx.aspx?find=unread#post46591#post46591 
after one refresh (reload) another reload will add another #post46591 and again and again.

One tip: (although problem has been reported numerous times and has been fixed numerous times....)
Check within the method if a # already is within the link. If so, DO NOT ADD #post...


- Robert

edit:
checked the cause of the problem and is caused in /pages/post.ascx.cs
In latest revision changes of that file by vzrus
My site containing the YAF forum: Globalcaching.eu 
Topic Starter
  • Underground
  • Rank: YAF Commander
  • Reputation:
    Exalted
    100%
  • Joined: 05/06/2009
  • Posts: 103
  • Thanks: 18 times
  • Was thanked: 8 time(s) in 8 post(s)
#10
I can't reproduce the problem on the forum.
  • bbobb
  • Rank: YAF Developer
  • Reputation:
    Exalted
    100%
  • Medals:
    Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.Medal of Honor for a YAF Database Key Player: Holds the key to YAF database. Bow down!Medal of Honor for the Support King: Given for answering tons of support questions and generally helping the community.Medal of Honor for the Support Knight: Given to a community member who has answered lots of support questions.
  • Joined: 21/10/2008
  • Posts: 1,558
  •  Man  Russian Federation
  • Location: Moscow
  • Thanks: 51 times
  • Was thanked: 287 time(s) in 253 post(s)
#11
Originally Posted by: bbobb

I can't reproduce the problem on the forum.


go to the link I gave you
(http://forum.yetanotherforum.net/yaf_postsm46591_Error-in-Page-Moderate-ascx.aspx?find=unread#post46591 
and press refresh (reload) of your browser (so reloading the page). I checked the source code and also there I can see there is no check if a anker already exists.

edit:
and don't forget to look at the url after reloading
My site containing the YAF forum: Globalcaching.eu 
Topic Starter
  • Underground
  • Rank: YAF Commander
  • Reputation:
    Exalted
    100%
  • Joined: 05/06/2009
  • Posts: 103
  • Thanks: 18 times
  • Was thanked: 8 time(s) in 8 post(s)
#12
Test
http://forum.yetanotherforum.net/yaf_postsm46592_Error-in-Page-Moderate-ascx.aspx#post46592 
  • bbobb
  • Rank: YAF Developer
  • Reputation:
    Exalted
    100%
  • Medals:
    Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.Medal of Honor for a YAF Database Key Player: Holds the key to YAF database. Bow down!Medal of Honor for the Support King: Given for answering tons of support questions and generally helping the community.Medal of Honor for the Support Knight: Given to a community member who has answered lots of support questions.
  • Joined: 21/10/2008
  • Posts: 1,558
  •  Man  Russian Federation
  • Location: Moscow
  • Thanks: 51 times
  • Was thanked: 287 time(s) in 253 post(s)
#13

I guess with this you mean you cannot reproduce it?
I use Chrome by the way, but looking at the code it should be a problem with every browser.
I hope Jaben or tha_watcha can reproduce it. It is very simple. If not, I have to make a branche myself and that would be too bad.
My site containing the YAF forum: Globalcaching.eu 
Topic Starter
  • Underground
  • Rank: YAF Commander
  • Reputation:
    Exalted
    100%
  • Joined: 05/06/2009
  • Posts: 103
  • Thanks: 18 times
  • Was thanked: 8 time(s) in 8 post(s)
#14
I've reproduced it. I just tested another thing. The implementation is a sample because the last unread functionality was rewritten.
  • bbobb
  • Rank: YAF Developer
  • Reputation:
    Exalted
    100%
  • Medals:
    Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.Medal of Honor for a YAF Database Key Player: Holds the key to YAF database. Bow down!Medal of Honor for the Support King: Given for answering tons of support questions and generally helping the community.Medal of Honor for the Support Knight: Given to a community member who has answered lots of support questions.
  • Joined: 21/10/2008
  • Posts: 1,558
  •  Man  Russian Federation
  • Location: Moscow
  • Thanks: 51 times
  • Was thanked: 287 time(s) in 253 post(s)
#15
k, fixed and committed. Also fixed on this forum. Try it out.
  • Jaben
  • Rank: YAF Developer
  • Reputation:
    Exalted
    100%
  • Medals:
    Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: Given to a community member who tirelessly answers tons of support questions.
  • Joined: 09/10/2004
  • Posts: 2,544
  • Location: United States
  • Thanks: 142 times
  • Was thanked: 352 time(s) in 195 post(s)
Users browsing this topic
    Forum Jump  
    • You cannot post new topics in this forum.
    • You cannot reply to topics in this forum.
    • You cannot delete your posts in this forum.
    • You cannot edit your posts in this forum.
    • You cannot create polls in this forum.
    • You cannot vote in polls in this forum.

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved