ninaxd
  •  ninaxd
  • 62% (Friendly)
  • YAF Camper Topic Starter
2010-10-12T13:11:45Z
Hi - after upgrading to DNN 551, I've also attempted to upgrade the forum and modified my config file accordingly with new version of YAF which I have successfully installed on 551 sites.

this is the error I am experiencing.


AbsoluteURLReferrer: http://XXX/Default.aspx?tabid=582
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
DefaultDataProvider: DotNetNuke.Data.SqlDataProvider, DotNetNuke.SqlDataProvider
ExceptionGUID: 597b9a63-3bcf-4a70-af5e-c75109cfc025
InnerException: The Role Manager feature has not been enabled.
FileName:
FileLineNumber: 0
FileColumnNumber: 0
Method: System.Web.Security.Roles.EnsureEnabled
StackTrace:
Message: DotNetNuke.Services.Exceptions.PageLoadException: The Role Manager feature has not been enabled. ---> System.Configuration.Provider.ProviderException: The Role Manager feature has not been enabled. at System.Web.Security.Roles.EnsureEnabled() at System.Web.Security.Roles.get_ApplicationName() at YAF.Classes.YafBoardSettings..ctor() at YAF.Classes.Core.YafLoadBoardSettings..ctor(Object boardID) at YAF.Classes.Core.YafContext.get_BoardSettings() at YAF.Modules.UnloadSessionModule.UnloadSessionModule_Unload(Object sender, EventArgs e) at System.EventHandler.Invoke(Object sender, EventArgs e) at System.Web.UI.Control.OnUnload(EventArgs e) at System.Web.UI.Control.UnloadRecursive(Boolean dispose) at System.Web.UI.Control.UnloadRecursive(Boolean dispose) at System.Web.UI.Control.UnloadRecursive(Boolean dispose) at System.Web.UI.Control.UnloadRecursive(Boolean dispose) at System.Web.UI.Control.UnloadRecursive(Boolean dispose) at System.Web.UI.Control.UnloadRecursive(Boolean dispose) at System.Web.UI.Control.UnloadRecursive(Boolean dispose) at System.Web.UI.Control.UnloadRecursive(Boolean dispose) at System.Web.UI.Control.UnloadRecursive(Boolean dispose) at System.Web.UI.Control.UnloadRecursive(Boolean dispose) at System.Web.UI.Control.UnloadRecursive(Boolean dispose) at System.Web.UI.Control.UnloadRecursive(Boolean dispose) at System.Web.UI.Page.UnloadRecursive(Boolean dispose) at System.Web.UI.Page.ProcessRequestCleanup() at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) at System.Web.UI.Page.ProcessRequest() at System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context) at System.Web.UI.Page.ProcessRequest(HttpContext context) at ASP.default_aspx.ProcessRequest(HttpContext context) at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) --- End of inner exception stack trace ---



So when I put the code from the old config file in - I get this error when access any of the host pages, as well as the forums still not working
ActiveTabName: Host Settings
RawURL: /Default.aspx?tabid=16&portalId=0
AbsoluteURL: /Default.aspx
AbsoluteURLReferrer: http://XXX/Default.aspx?tabid=52&List=0
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
DefaultDataProvider: DotNetNuke.Data.SqlDataProvider, DotNetNuke.SqlDataProvider
ExceptionGUID: e1e39c8f-53a3-45fa-aea9-3c1069742cc9
InnerException: Unhandled Error:
FileName:
FileLineNumber: 0
FileColumnNumber: 0
Method: DotNetNuke.UI.Containers.ActionBase.get_ActionRoot
StackTrace:
Message: System.Exception: Unhandled Error: ---> DotNetNuke.Services.Exceptions.PageLoadException: An error has occurred. ---> DotNetNuke.Services.Exceptions.ModuleLoadException: An error has occurred. ---> System.NullReferenceException: Object reference not set to an instance of an object. at DotNetNuke.UI.Containers.ActionBase.get_ActionRoot() at DotNetNuke.UI.Containers.ActionBase.Page_Load(Object sender, EventArgs e) --- End of inner exception stack trace --- at DotNetNuke.Services.Exceptions.Exceptions.ProcessModuleLoadException(String FriendlyMessage, Control ctrl, Exception exc, Boolean DisplayErrorMessage) at DotNetNuke.Services.Exceptions.Exceptions.ProcessModuleLoadException(Control ctrl, Exception exc, Boolean DisplayErrorMessage) at DotNetNuke.Services.Exceptions.Exceptions.ProcessModuleLoadException(Control ctrl, Exception exc) at DotNetNuke.UI.Containers.ActionBase.Page_Load(Object sender, EventArgs e) at System.EventHandler.Invoke(Object sender, EventArgs e) at System.Web.UI.Control.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) --- End of inner exception stack trace --- at DotNetNuke.Services.Exceptions.Exceptions.ProcessPageLoadException(Exception exc, String URL) at DotNetNuke.Framework.PageBase.OnError(EventArgs e) at System.Web.UI.Page.HandleError(Exception e) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) at System.Web.UI.Page.ProcessRequest() at System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context) at System.Web.UI.Page.ProcessRequest(HttpContext context) at ASP.default_aspx.ProcessRequest(HttpContext context) at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) --- End of inner exception stack trace ---


And this is the code I am putting into the config file - I have removed variants of it to try and see if it makes a difference, but alas, it does not.
<roleManager enabled="true" defaultProvider="AspNetSqlRoleProvider">
      <providers>
        <clear />
        <add connectionStringName="SiteSqlServer" applicationName="DotNetNuke" name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider" />
      </providers>
    </roleManager>
    <trace enabled="false" />
    <profile enabled="true" defaultProvider="AspNetSqlProfileProvider" inherits="YAF.Classes.Utils.YafUserProfile">
      <providers>
        <clear />
        <add connectionStringName="SiteSqlServer" applicationName="DotNetNuke" name="YafProfileProvider" type="YAF.Providers.Profile.YafProfileProvider" />
        <add connectionStringName="SiteSqlServer" applicationName="DotNetNuke" name="AspNetSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" />
      </providers>
    </profile>


It could very well be the order in which I am doing things - the new config file has some things in it I am not familiar with - but any advice on how to get it sorted out would be appreciated.

Also - I have that debug message coming up - I don't know how to compile it to remove it - does anyone have a build that has that message removed?

Thanks very much
Nina
Sponsor
tha_watcha
2010-10-12T13:33:06Z
Use my official Yaf 1.9.5 RC 1 DNN Module.

http://my-dnn.de/i8WJt 

You dont need to manually edit the web.config.
UserPostedImage
ninaxd
  •  ninaxd
  • 62% (Friendly)
  • YAF Camper Topic Starter
2010-10-12T13:56:06Z
That is the version I used - I found that I had to modify the config file because the app_code folder was no longer required and it was referencing. I will see if i can find an older non yaf config file and start again.

It is late though I might leave this until the morning - or more errors will most likely occur!!

It's such a nice build I was looking forward to get it updated and I did read through the help files before doing anything, so I don't know why it happened.

Nina
ninaxd
  •  ninaxd
  • 62% (Friendly)
  • YAF Camper Topic Starter
2010-10-12T14:07:19Z
Ok - it is working now - I cleared the cache, restarted IIS, reset the config file and reinstalled - I think perhaps I should have waited for a while after upgrading DNN before installing this module - it seems that leaving it for 15 minutes and then coming back to it has helped so NOW it's working!!

This is nice news for me!

Thanks for the response anyway.

Nina
ninaxd
  •  ninaxd
  • 62% (Friendly)
  • YAF Camper Topic Starter
2010-10-12T14:10:33Z
Oh but now I have another problem - it shows perfectly but when clicking on Admin to change theme, it takes me to home page, as does all the other forum posts, when not logged in.

I will have another look tomorrow.

Nina
ninaxd
  •  ninaxd
  • 62% (Friendly)
  • YAF Camper Topic Starter
2010-10-13T06:11:49Z
I have had a look and cannot see anything different to the other config files. I think I will need to delete this whole forum and start again. Everythign I click takes me to the home page again, so something with permissions does not let me do anything.

fortunately I do not have much in these forums. :D

Nina
ninaxd
  •  ninaxd
  • 62% (Friendly)
  • YAF Camper Topic Starter
2010-10-13T12:37:22Z
I now realise I am just talking to myself. So, perhaps I have to accept that Yetanotherforum is an excellent product when installed from new, but does not upgrade very well.

I spent too many hours now on a site that I can no longer use Yetanotherforum. I have uninstalled, and reinstalled, to find that whenever I click anything on the forum page, it takes me straight back to home page. There is no option for me to do anything any more.

Oh well, it was good while it lasted.

I hope a forum moderator can read this whole topic and just delete it.
I have think I can not continue with these forums unless I just stick to one version forever.

Thanks for ride.. pity it was never for long!

Bye
Nina
bbobb
  •  bbobb
  • 100% (Exalted)
  • YAF Developer
2010-10-13T13:34:13Z
 Antonina222 , currently developers struggle to make 1.9.5.
All forces are put into it. You should understand, that this is a primary development goal. If you want to solve some personal integration problem, not YAF problem per se, YAF has primary(paid) support .
Or you can simply use previous versions which work fine in your case.
cagliostro
2010-10-13T13:55:36Z
ninaxd wrote:

I now realise I am just talking to myself. So, perhaps I have to accept that Yetanotherforum is an excellent product when installed from new, but does not upgrade very well.

I spent too many hours now on a site that I can no longer use Yetanotherforum. I have uninstalled, and reinstalled, to find that whenever I click anything on the forum page, it takes me straight back to home page. There is no option for me to do anything any more.

Oh well, it was good while it lasted.

I hope a forum moderator can read this whole topic and just delete it.
I have think I can not continue with these forums unless I just stick to one version forever.

Thanks for ride.. pity it was never for long!

Bye
Nina



I don't really understand. There is a working version under DNN, 1.9.4, why don't you use that ?

Why use a RC or a beta and say it doesn't work (it doesn't actually, the DNN version).
ninaxd
  •  ninaxd
  • 62% (Friendly)
  • YAF Camper Topic Starter
2010-10-13T22:33:48Z
bbobb wrote:

 Antonina222 , currently developers struggle to make 1.9.5.
All forces are put into it. You should understand, that this is a primary development goal. If you want to solve some personal integration problem, not YAF problem per se, YAF has primary(paid) support .
Or you can simply use previous versions which work fine in your case.



You do not know my situation - I am already engaged in paid support on another issue with Jaben. He got married on the weekend. So please do not assume I am here for a free ride or anything.
bbobb
  •  bbobb
  • 100% (Exalted)
  • YAF Developer
2010-10-13T23:01:22Z
I don't think about free ride. 99% of YAF users are free riders.:)
The DNN code is supported by tha_watcha and it's not a piece of cake to make it work fine everytime, because it's not only YAF, but DNN too. Some more patience.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved