tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2019-11-04T15:29:44Z
I saw that some problems with the robots meta-tag had been fixed in the v2.24.20 (see this ). I downloaded the new version install using the official link  but could not launch it. I always got a server error. After analyzing the source code and playing with it a little bit, I came to a conclusion that the problem is in the root default.aspx.file. See, the new version does not contain the following tag definitions:

<%@ Register TagPrefix="YAF" Assembly="YAF" Namespace="YAF" %>
<%@ Register TagPrefix="url" Namespace="Intelligencia.UrlRewriter" Assembly="Intelligencia.UrlRewriter" %>


However, you try to use them in the body of the page:

    <YAF:Form id="form1" runat="server" enctype="multipart/form-data">
        <YAF:Forum runat="server" ID="forum" BoardID="1">
        </YAF:Forum>
    </YAF:Form>


Do I understand something wrong? And I see no mentions of the robot meta-tag...
Sponsor
tha_watcha
2019-11-04T16:09:33Z
Yes you are right re-adding them should solve the problem

Quote:

Do I understand something wrong? And I see no mentions of the robot meta-tag...



Mentions where? the tags are generated dynamically in the code!
UserPostedImage
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2019-11-05T07:35:57Z
Originally Posted by: tha_watcha 

Yes you are right re-adding them should solve the problem



I guess, we need only the YAF tag prefix? I can't find any usage of the 'url' tag prefix in default.aspx now.

And this MUST BE done in the official download package too.
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2019-11-05T07:57:23Z
Originally Posted by: tha_watcha 

Mentions where? the tags are generated dynamically in the code!



What kinds of pages are we talking about? Perhaps, we are talking about different kinds of pages. Here are the page url templates I originally blocked in my robots.txt:

Disallow: /forum/posts/t*findunread
Disallow: /forum/posts/t*findlastpost
Disallow: /forum/posts/m
Disallow: /forum/profile/
Disallow: /forum/mytopics
Disallow: /forum/search
Disallow: /forum/help_index
Disallow: /forum/login
Disallow: /forum/rules


I upgraded to v2.24.20 (I did replace the DLLs in the bin subfolder), but some of the pages I am interested in still do not have the 'noindex' setting, for example the '/forum/posts/t*findunread' pages. It seems, only the '/forum/posts/m' pages were really fixed.

P.S. Perhaps, we need to put the discussion of the 'noindex' setting into a separate topic dedicated solely to this question.
tha_watcha
2019-11-05T10:28:04Z
Originally Posted by: tecman 

Originally Posted by: tha_watcha 

Yes you are right re-adding them should solve the problem



I guess, we need only the YAF tag prefix? I can't find any usage of the 'url' tag prefix in default.aspx now.

And this MUST BE done in the official download package too.



I updated the download packages. there was the wrong default.aspx inside.
UserPostedImage
tha_watcha
2019-11-05T10:33:57Z
Originally Posted by: tecman 

I upgraded to v2.24.20 (I did replace the DLLs in the bin subfolder), but some of the pages I am interested in still do not have the 'noindex' setting, for example the '/forum/posts/t*findunread' pages. It seems, only the '/forum/posts/m' pages were really fixed.



Well you didn't say that before, i implemented the changes as requested! I can change that in 2.3.00


UserPostedImage

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved