#1
I just installed YAF. I stepped through all the installation steps and entered an administration account with a simple user name and simple password.

After completion I see a record in the users table.

Nevertheless YAF keeps telling me my the account or password is invalid.

I tried this installation two times. Once without and once with AspNetSqlMembershipProvider enabled

I can't get my finger behind this issue...
any help would be nic

I am a yaf newbie! first time installation
Topic Starter
  • nopfinance
  • Rank: YAF Forumling
  • Reputation:
    Neutral
    53%
  • Joined: 27/07/2018
  • Posts: 5
  •  Netherlands
  • Location: hhw
#2
btw

The yaf_user record shows 'na' in the password field

Topic Starter
  • nopfinance
  • Rank: YAF Forumling
  • Reputation:
    Neutral
    53%
  • Joined: 27/07/2018
  • Posts: 5
  •  Netherlands
  • Location: hhw
#3
I noticed one more thing:

I registered a new user with username 'test' and password 'test12'

Upon registration I was automatically logged in.

Then I logged out.

Next when I try to login with test, test12 I received the error that my account or password are incorrect.

I now have the source code running on my development computer. Where does the actual username / password get checked, in what c# function?
Topic Starter
  • nopfinance
  • Rank: YAF Forumling
  • Reputation:
    Neutral
    53%
  • Joined: 27/07/2018
  • Posts: 5
  •  Netherlands
  • Location: hhw
#4
Please change the hashAlgorithmType to SHA1 in the web.config

from-...
<membership defaultProvider="YafMembershipProvider" hashAlgorithmType="HMACSHA256">


to
 <membership defaultProvider="YafMembershipProvider" hashAlgorithmType="SHA1">


You also need to clear the database
test
  • tha_watcha
  • Rank: YAF.NET Project Lead
  • Reputation:
    Exalted
    100%
  • Medals:
    Medal of Honor: Portal Puzzle Master: Portal Puzzle Master for DNNMedal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.DNN Master: DNN Module ManBug Killer Medal of Honor: Medal for being a kick-ass bug killer!Medal of Honor for the Support King: Support King! Amazing asset to the YAF.NET Community.
  • Joined: 06/03/2010
  • Posts: 3,983
  •  Germany
  • Thanks: 73 times
  • Was thanked: 1202 time(s) in 1029 post(s)
#5
thx. I'll try this later
Topic Starter
  • nopfinance
  • Rank: YAF Forumling
  • Reputation:
    Neutral
    53%
  • Joined: 27/07/2018
  • Posts: 5
  •  Netherlands
  • Location: hhw
#6
SHA1 was indeed the solution!

Request: Set SHA1 default in the webconfig, instead of SHA256. Saves ignorant users like me a lot of time....
Topic Starter
  • nopfinance
  • Rank: YAF Forumling
  • Reputation:
    Neutral
    53%
  • Joined: 27/07/2018
  • Posts: 5
  •  Netherlands
  • Location: hhw
Forum Jump  
  • You cannot post new topics in this forum.
  • You cannot reply to topics in this forum.
  • You cannot delete your posts in this forum.
  • You cannot edit your posts in this forum.
  • You cannot create polls in this forum.
  • You cannot vote in polls in this forum.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved