toilaai
  • Posts: 2
  • Joined: 11/10/2014
On me logged on to the forume, click on the "Home", the show page error (I have tried to write in English and no post image):

Server Error in '/' Application.

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[NullReferenceException: Object reference not set to an instance of an object.]
YAF.Core.Services.PageElementRegister.RegisterJQuery() +128
YAF.Controls.UserLink.OnPreRender(EventArgs e) +116
System.Web.UI.Control.PreRenderRecursiveInternal() +112
System.Web.UI.Control.PreRenderRecursiveInternal() +221
System.Web.UI.Control.PreRenderRecursiveInternal() +221
System.Web.UI.Control.PreRenderRecursiveInternal() +221
System.Web.UI.Control.PreRenderRecursiveInternal() +221
System.Web.UI.Control.PreRenderRecursiveInternal() +221
System.Web.UI.Control.PreRenderRecursiveInternal() +221
System.Web.UI.Control.PreRenderRecursiveInternal() +221
System.Web.UI.Control.PreRenderRecursiveInternal() +221
System.Web.UI.Control.PreRenderRecursiveInternal() +221
System.Web.UI.Control.PreRenderRecursiveInternal() +221
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4296
Sponsor
tha_watcha
  • Posts: 4133
  • Joined: 06/03/2010
Please open the Default.aspx and remove the following code...

<h3>YAF What's New</h3>
    <div class="yafWhatsNew">
        <YAF:ForumActiveDiscussion ID="ActiveDiscussions" runat="server" />
    </div>

UserPostedImage
toilaai
  • Posts: 2
  • Joined: 11/10/2014
Thank you very much. But it would not be such a message board on the home page. Why is it do not error if we do not log in?
eric7704
  • Posts: 2
  • Joined: 13/03/2015
I had exactly the same problem, when i deleted that line, the new post wont show on home page anymore, can someone help?
Users browsing this topic
    Forum Jump  
    • You cannot post new topics in this forum.
    • You cannot reply to topics in this forum.
    • You cannot delete your posts in this forum.
    • You cannot edit your posts in this forum.
    • You cannot create polls in this forum.
    • You cannot vote in polls in this forum.

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved