Welcome Guest! To enable all features please Login or Register.
2 Pages<12
Options
View
Go to last post Go to first unread
Offline de broekies  
#16 Posted : Tuesday, January 21, 2014 2:11:53 PM(UTC)
de broekies


Rank: YAF Camper

Reputation:

Joined: 1/21/2014(UTC)
Posts: 23
Netherlands

Thanks: 10 times
Was thanked: 3 time(s) in 3 post(s)
Originally Posted by: Zero2Cool Go to Quoted Post
I can't recall many issues with the read/unread icons, but I have had users state such issues persist, hence why I tried db tracking several times.

Yes, thats the reaon I am in doubt too. Some users complain that the last read is not working, not even using the same browser on the same machine. They say that going to the last unread moves them to the first post. This does not happen for all threads, but for some.
But if JP says that it is not working for multiple pages, well, then... I guess it is chosing between two options that are both not perfect.
Offline Jaben  
#17 Posted : Tuesday, January 21, 2014 10:37:06 PM(UTC)
Jaben


Rank: YAF Developer

Reputation:

Medals: Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: Given to a community member who tirelessly answers tons of support questions.

Joined: 10/9/2004(UTC)
Posts: 2,549
Location: United States

Thanks: 142 times
Was thanked: 358 time(s) in 199 post(s)
Updated bin to release build on v2.1.
Offline francoz  
#18 Posted : Wednesday, January 22, 2014 12:13:02 PM(UTC)
francoz


Rank: YAF Lover

Reputation:

Joined: 3/10/2011(UTC)
Posts: 56

Thanks: 34 times
Was thanked: 11 time(s) in 8 post(s)
Originally Posted by: de broekies Go to Quoted Post

Yes, thats the reaon I am in doubt too. Some users complain that the last read is not working, not even using the same browser on the same machine. They say that going to the last unread moves them to the first post. This does not happen for all threads, but for some.


Exactly what happens on my forum.

Originally Posted by: de broekies Go to Quoted Post

But if JP says that it is not working for multiple pages, well, then... I guess it is chosing between two options that are both not perfect.


I can confirm this: it never works with multi-page threads with the database option. I will try for the cookie option in the next few days, even if it will not work by design with multiple client devices, of course.

This bug should really be addressed ASAP, it is a highly appreciated feature.


Offline de broekies  
#19 Posted : Wednesday, January 22, 2014 2:17:18 PM(UTC)
de broekies


Rank: YAF Camper

Reputation:

Joined: 1/21/2014(UTC)
Posts: 23
Netherlands

Thanks: 10 times
Was thanked: 3 time(s) in 3 post(s)
The cookie option does not work on multi pages either.
A fix for this would be greatly appreciated.
thanks 1 user thanked de broekies for this useful post.
JP on 2/4/2014(UTC)
Offline photogearch  
#20 Posted : Thursday, January 23, 2014 11:58:49 AM(UTC)
photogearch


Rank: YAF Forumling

Reputation:

Joined: 1/20/2014(UTC)
Posts: 2

Originally Posted by: de broekies Go to Quoted Post
I also installed the RTW 2.1. But it seems a debug build.
Do we get a release build soon or does everyone needs to build the release mode themselfs? I prefer to download the release build instead of installing Visual Studio Express for Web.
(I don't know if there is a lot of #if DEBUG which slows down the process, but for me as an admin the sql performance list at the bottom is not pleasant)

I believe that including debug build into binary distribution is nothing else than a mistake. Unless a sounding reason for doing so is specified in big red letters near the download link, at least.
Considering strange errors I got using that distribution I personally suppose that there could also be some mix of the versions of the binaries in it.
However, I do not think that changing to release build may affect SQL server performance, unless different queries are used for debug and release code, which is highly unlikely.

Edited by user Thursday, January 23, 2014 12:00:04 PM(UTC)  | Reason: Not specified

Offline de broekies  
#21 Posted : Friday, January 24, 2014 12:53:55 AM(UTC)
de broekies


Rank: YAF Camper

Reputation:

Joined: 1/21/2014(UTC)
Posts: 23
Netherlands

Thanks: 10 times
Was thanked: 3 time(s) in 3 post(s)
Originally Posted by: photogearch Go to Quoted Post
I believe that including debug build into binary distribution is nothing else than a mistake. Unless a sounding reason for doing so is specified in big red letters near the download link, at least.
Considering strange errors I got using that distribution I personally suppose that there could also be some mix of the versions of the binaries in it.
However, I do not think that changing to release build may affect SQL server performance, unless different queries are used for debug and release code, which is highly unlikely.

I am sure it was just a mistake and a thing that can happen. I have no problems with that. But when it is reported, I think it should be fixed and Jaben has done that.

Yes, I also had strange errors with the newton json assembly not being the right version. I didn't have this with V2.0.0. I build YAF in release mode, but this error still pops up. Strange thing is:
When I update the binaries of the web application on the server (any binairy like YAF or my own) the webapplication crashes due to wrong Newton JSON assembly version and when I touch the web.config (forcing to reload the web application) it runs. Isn't that weird?


Anyways, I have the feeling that the release build is faster. So, I assume there is some #if DEBUG that slows down the process. And yes, I don't assume it is in the queries, but with other stuff.

Edited by user Friday, January 24, 2014 12:55:01 AM(UTC)  | Reason: Not specified

Offline Hellboy75  
#22 Posted : Friday, January 24, 2014 4:40:19 AM(UTC)
Hellboy75


Rank: YAF Camper

Reputation:

Medals: Pro Customer: Supports the YAF.NET Project

Joined: 9/13/2013(UTC)
Posts: 24
Man
France

Thanks: 9 times
Was thanked: 2 time(s) in 2 post(s)
Hi, thank you for this release. Can you tell the scheduled date to release YAF.NET Internal Usage License v2.1.0 ?

br.
Offline Jaben  
#23 Posted : Monday, January 27, 2014 8:58:24 AM(UTC)
Jaben


Rank: YAF Developer

Reputation:

Medals: Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: Given to a community member who tirelessly answers tons of support questions.

Joined: 10/9/2004(UTC)
Posts: 2,549
Location: United States

Thanks: 142 times
Was thanked: 358 time(s) in 199 post(s)
Originally Posted by: Hellboy75 Go to Quoted Post
Hi, thank you for this release. Can you tell the scheduled date to release YAF.NET Internal Usage License v2.1.0 ?

br.


I'll release a commercial version of v2.1 in the next day or two.
thanks 2 users thanked Jaben for this useful post.
Hellboy75 on 1/28/2014(UTC), crf370 on 2/2/2014(UTC)
Rss Feed  Atom Feed
Users browsing this topic
2 Pages<12
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Notification

Icon
Error