QTLogic
  • Posts: 8
  • Joined: 14/12/2012
We just broke into the top 1 million sites on Alexa! Thanks YAF!

http://www.Coupon-Codes-Bonus-Codes.com 

Your forum software is great. Very easy to use and administer.

After finding that info on how to make it never have a delay when starting up the site has been killer. Information by the way I am looking for again. LOL Putting up a couple more forums and this time using the latest builds.

The latest build is sweet! It feels really solid and is just a total pleasure to use.

Pierce
CCBC Admin
Sponsor
squirrel
  • Posts: 925
  • Joined: 14/01/2010
Most times, the delay comes from IIS idling down the Application Pool that YAF runs in. In a best case scenario, the Application pool needs to stay running as long as possible - whenever it restarts or idles down, that's when YAF gets hit with a startup lag.

I usually set 'test builds' of YAF to recycle their pool daily at a non-peak time - and production builds that I find 'memory stable' I keep about a weekly recycle - and go from there. There's still the lag from the site when it does start back up, but it's only that one time so long as IIS keeps the pool running -

Hope that helps!

Additionally, don't forget the machineKey trick in the web.config for keeping users logged in past recycles --



If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
Jaben
  • Posts: 2544
  • Joined: 09/10/2004
For faster restarts, please read about adding this setting to your web.config:

http://www.dnnsoftware.c...ave-you-development-time 
squirrel
  • Posts: 925
  • Joined: 14/01/2010
Originally Posted by: Jaben

For faster restarts, please read about adding this setting to your web.config:

http://www.dnnsoftware.c...ave-you-development-time 



HOLY CONFIG SETTINGS BATMAN... That is the holy grail of .NET information for large applications.

Do you plan on incorporating that into the forum configs (maybe put it in as a commented alternative line under the current one - explaining that if you don't make changes to YAF - rather just run it, enable this for performance?

I'll add this note to my further posts for YAF installs :)






If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
squirrel
  • Posts: 925
  • Joined: 14/01/2010
UPDATE: I just added the note from Jaben to the config on two of our YAF sites and startup times went from 30 seconds on the light site to 3 seconds, and on the heavy site where it usually takes a full minute to load the forums from a restart, the same response - approx 2 seconds from a restart to a forum homepage.

You, sir, are a GOD.
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
Forum Jump  
  • You cannot post new topics in this forum.
  • You cannot reply to topics in this forum.
  • You cannot delete your posts in this forum.
  • You cannot edit your posts in this forum.
  • You cannot create polls in this forum.
  • You cannot vote in polls in this forum.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved