Clegs
  •  Clegs
  • 64.4% (Friendly)
  • YAF Forumling
2008-04-07T12:15:00Z
I had some errors in the install. In indexes.sql two of the 'GO' statements are lowercase. I don't think that would matter but for some reason my MsSQL 2005 didn't like it. Just capitalized them and ran the script through the database again and it worked :D
Seems to be running a little smoother now, only problem is the Admin Control panel just died on me, but I think that was caused from the issues I had installing the script. Oh what I would do to get off a shared host ;)

Thanks for the good work!
calebgo.com  - My Site
jdadojr
2008-04-07T21:35:43Z
Hi,

I tried to add 40K users and with lots of categories and subcategories and
the result is sql timeout.

I debug and found out that calling the sp. yaf_forum_moderators, specfically
the view named [yaf_vaccessfull] is causing the very long access time.

Digging deeper this 2nd union on the yaf_vaccessfull, aggravates everything
select
b.UserID,
c.ForumID,
ReadAccess = convert(int,d.Flags & 1),
PostAccess = convert(int,d.Flags & 2),
ReplyAccess = convert(int,d.Flags & 4),
PriorityAccess = convert(int,d.Flags & 😎,
PollAccess = convert(int,d.Flags & 16),
VoteAccess = convert(int,d.Flags & 32),
ModeratorAccess = convert(int,d.Flags & 64),
EditAccess = convert(int,d.Flags & 128),
DeleteAccess = convert(int,d.Flags & 256),
UploadAccess = convert(int,d.Flags & 512),
DownloadAccess = convert(int,d.Flags & 1024),
AdminGroup = convert(int,e.Flags & 1)
from
[dbo].[yaf_UserGroup] b
INNER JOIN [dbo].[yaf_ForumAccess] c on c.GroupID=b.GroupID
INNER JOIN [dbo].[yaf_AccessMask] d on d.AccessMaskID=c.AccessMaskID
INNER JOIN [dbo].[yaf_Group] e on e.GroupID=b.GroupID

this will return more than 3Million rows on a 40k user.


I think we may need to optimize this yaf_vaccessfull









Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer Topic Starter
2008-04-07T23:50:08Z
It's optimized in future versions.
jdadojr
2008-04-08T13:01:44Z
I also used the future version which is the 1.9.3 and it is still the same yaf_vaccessfull.
I also found that the yaf_forum_listread which uses the function lasttopic,lastposted also suffers with sql timeout
because it process every row that the yaf_vaccess returns.

What i have done for now is to modify the yaf_forum_moderators and create a new view (yav_vaccessfull_mods)
to only return list of moderators (64 flags) only.
On the yaf_forum_listread I just replace the function with the b.lasttopicid (for the meantime, i dont know the consequence of this yet).

Now its much faster ano no sql timeout.

Later I will try look into mail_list and moderate.
zendear
2008-04-10T04:18:15Z
Hi All,

Is there any sort of database migration script for going from 1.9.1.6 to 1.9.1.8?

If not, I'd be happy to write one this evening and share it. I just didn't want to re-invent the wheel.

Thanks!
agibby5
2008-04-10T04:23:07Z
When I installed .8, I was prompted with the install screen. It notes that if you're upgrading it will perform differently than if you were just installing. I believe that it runs the new scripts to install the changes into the database from .6 to .8.
agibby5
2008-04-10T04:24:34Z
agibby5 wrote:

When I installed .8, I was prompted with the install screen. It notes that if you're upgrading it will perform differently than if you were just installing. I believe that it runs the new scripts to install the changes into the database from .6 to .8.





Also:

Mek wrote:

yup, the order to be run is on the forums somewhere or just try running /install/default.aspx?forceupgrade=1



from: this post 
sparrow
2008-04-17T17:40:29Z
ok im a super noob when it comes to this stuff but i have a site called vscrubs.com and have it hosed with godaddy. Im trying to update from .7 to .8 but i have NO IDEA what im doing..... please help!
thanks
~sparrow~
tmostuff
2008-04-17T19:55:38Z
Hello...

I'm a real newbie here but here goes:

I'm running 1.9.1.7 that was automatically from the GoDaddy site.

Which of the new versions do I need to load to be updated?

Do I have to copy the entire zip file and unzip it on the host or unzip it on my hard drive and upload individual files?

Thanks!
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer Topic Starter
2008-04-17T20:48:20Z
Unzip on your local computer and then FTP to your GoDaddy account.

Upload and overwrite all the files EXCEPT for your yafnet.config and web.config files.
samsi
  •  samsi
  • 53% (Neutral)
  • YAF Forumling
2008-05-04T00:21:20Z
I've upgraded from 1.9.1.6 to 1.9.1.8, and i cannot see anymore the images attached to posts. Need help!
samsi
  •  samsi
  • 53% (Neutral)
  • YAF Forumling
2008-05-04T03:00:06Z
I've solved the problem. Because I copyied the forum from "forum" directory to "forum1" directory, some security permissions were lost. I've granted full access permissions to NETWORK SERVICES for upload directory and the images are OK now.
test2005
2008-05-04T11:40:11Z

Glad you got it working, and thanks for posting the solution to your particular problem. It will help others!

:-P


.....the man in black fled across the desert..........and the gunslinger followed.....
thargaung
2008-05-24T21:34:09Z
Hi there,

Now i am using that Yet Another Forum.net version 1.9.1.8.
So can i remove your footer copyright text.
If we can remove it, could you tell me how to remove.
Thanks
RikoNaz
2008-05-25T18:00:07Z
I get the following error when attempting to upgrade my version from .7 to .8
seems like the database version isnt updating for me.

im running windows sever 2003 with vs 2008 and sql 2005.


UserPostedImage

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved