mrtanvirali
2009-03-12T02:05:53Z
I am getting the following error after loging in as admin and clicking on admin link




Server Error in '/YetAnotherForum.NET' Application.


Object reference not set to an instance of an object.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:


Line 138:
Line 139: // parse custom provider data...
Line 140: GetDbTypeAndSizeFromString( property.Attributes ["CustomProviderData"].ToString(), out dbType, out size );
Line 141:
Line 142: // default the size to 256 if no size is specified


Source File: C:\Users\admin\Desktop\YAF-v1.9.3-RC2-SRC\YAF.Providers\Profile\YafProfileProvider.cs Line: 140

Stack Trace:


[NullReferenceException: Object reference not set to an instance of an object.]
YAF.Providers.Profile.YafProfileProvider.LoadFromPropertyCollection(SettingsPropertyCollection collection) in C:\Users\admin\Desktop\YAF-v1.9.3-RC2-SRC\YAF.Providers\Profile\YafProfileProvider.cs:140
YAF.Providers.Profile.YafProfileProvider.GetPropertyValues(SettingsContext context, SettingsPropertyCollection collection) in C:\Users\admin\Desktop\YAF-v1.9.3-RC2-SRC\YAF.Providers\Profile\YafProfileProvider.cs:400
System.Configuration.SettingsBase.GetPropertiesFromProvider(SettingsProvider provider) +258
System.Configuration.SettingsBase.GetPropertyValueByName(String propertyName) +132
System.Configuration.SettingsBase.get_Item(String propertyName) +102
System.Web.Profile.ProfileBase.GetInternal(String propertyName) +36
System.Web.Profile.ProfileBase.get_Item(String propertyName) +68
YAF.Classes.Utils.YafUserProfile.get_Location() in C:\Users\admin\Desktop\YAF-v1.9.3-RC2-SRC\YAF.Classes\YAF.Classes.Utils\UserProfile.cs:41
ASP.pages_members_ascx.__DataBind__control4(Object sender, EventArgs e) in c:\Users\admin\Desktop\YAF-v1.9.3-RC2-SRC\YetAnotherForum.NET\pages\members.ascx:44
System.Web.UI.Control.OnDataBinding(EventArgs e) +99
System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding) +92
System.Web.UI.Control.DataBind() +15
System.Web.UI.Control.DataBindChildren() +211
System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding) +102
System.Web.UI.Control.DataBind() +15
System.Web.UI.WebControls.Repeater.CreateItem(Int32 itemIndex, ListItemType itemType, Boolean dataBind, Object dataItem) +124
System.Web.UI.WebControls.Repeater.CreateControlHierarchy(Boolean useDataSource) +443
System.Web.UI.WebControls.Repeater.OnDataBinding(EventArgs e) +51
System.Web.UI.WebControls.Repeater.DataBind() +75
System.Web.UI.Control.DataBindChildren() +211
System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding) +102
System.Web.UI.Control.DataBind() +15
YAF.Pages.members.BindData() in c:\Users\admin\Desktop\YAF-v1.9.3-RC2-SRC\YetAnotherForum.NET\pages\members.ascx.cs:188
YAF.Pages.members.Page_Load(Object sender, EventArgs e) in c:\Users\admin\Desktop\YAF-v1.9.3-RC2-SRC\YetAnotherForum.NET\pages\members.ascx.cs:70
System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14
System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +35
System.EventHandler.Invoke(Object sender, EventArgs e) +0
System.Web.UI.Control.OnLoad(EventArgs e) +99
System.Web.UI.Control.LoadRecursive() +50
System.Web.UI.Control.LoadRecursive() +141
System.Web.UI.Control.LoadRecursive() +141
System.Web.UI.Control.LoadRecursive() +141
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +627
Sponsor
mrtanvirali
2009-03-13T00:06:45Z
its solved through the provided configuration file, recommended-NETv3.5-web.config
janna574
2009-07-19T07:31:39Z
yes me 2 and nothing solved u can check my tested forum www.esh7n.com/forum 

most of links when i click get this error "System.NullReferenceException: Object reference not set to an instance of an object. at YAF.Providers.Profile.YafProfileProvider.LoadFromPropertyCollection(SettingsPropertyCollection collection) in YafProfileProvider.cs:line 140"

when i click admin, when i register, when i post new topic and so on

anyone can help?
janna574
2009-07-20T07:21:44Z
janna574
2009-07-20T10:40:36Z
i have noticed that the error is here

"<%# BBCode.EncodeHTML( PageContext.GetProfile( Eval("UserName").ToString() ).Location ) %>"

this in many pages like admin.ascx and others !!!!

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved