DanComperini2
2009-01-13T15:56:44Z
Hello,

I would really appreciate some help with my yaf installation on GoDaddy.com. I loaded all the directories and files from the yaf zip file (bin) to /myweb/wamimusic/Forumn. I created a SQL server database call WamiForumn in GoDaddy and placed the connection string in the appropriate .config file.

I adde the <ROOT> Tag to my yafnet.config to find the yaf forumn. I played around with the ROOT tag but continue to have problems. Currently my .config files are located in /myweb/wamimusic/Forumn. Below are my .config files and error message. Any help would be appreciated! :?

yafnet.config
<yafnet>
<connstr>Data Source=WamiForumnxxxxxxx; Initial Catalog=xxxxxxxx; User ID=xxxxxxxx; Password='xxxxxxxx'; timeout=90</connstr>

<root>myweb/wamimusic/Forumn/</root>

<uploaddir>~/upload/</uploaddir>
<boardid>1</boardid>
<!-- Enable URL Rewriting -->
<enableurlrewriting>false</enableurlrewriting>
<!--logtomail>email=;server=;user=;pass=;</logtomail-->
<!--categoryid>1</categoryid-->
<!-- Enable these to use a custom user class "provider" -->
<!--CustomUserAssembly>TinyGecko.YAFIntegration.dll</CustomUserAssembly>
<CustomUserClass>TinyGecko.YAFIntegration.yafUserClass</CustomUserClass-->
</yafnet>

Web.config

<?xml version="1.0"?>
<configuration>
<configSections>
<section name="yafnet" type="yaf.SectionHandler,yaf"/>
<section name="rewriter" type="Intelligencia.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, Intelligencia.UrlRewriter" />
</configSections>

<yafnet configSource="yafnet.config" />

<rewriter configSource="urlrewriter.config"/>

<system.web>
<httpModules>
<add type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter" name="UrlRewriter" />
</httpModules>
<globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
<compilation defaultLanguage="c#" debug="false"/>
<pages enableEventValidation="false" validateRequest="false" smartNavigation="false"/>
<customErrors mode="Off"/>
<xhtmlConformance mode="Legacy"/>
</system.web>


</configuration>

ERROR
Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not load file or assembly 'yaf' or one of its dependencies. The system cannot find the file specified.

Source Error:

Line 1: <%@ Page Language="C#" %>
Line 2: <%@ Register TagPrefix="yaf" Namespace="yaf" Assembly="yaf" %>
Line 3: <%@ Register TagPrefix="yc" Namespace="yaf.controls" Assembly="yaf" %>
Line 4:

Source File: /wamimusic/forumn/default.aspx Line: 2
Sponsor
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2009-01-13T16:10:57Z
the .dll YAF files in /bin have to be in the ROOT /bin directory -- not the /forum/bin directory.
DanComperini2
2009-01-13T16:44:01Z
Thanks for the quick response!!

Actually, I have the /bin directory with yaf.dll and Intelligencia.UrlRewriter.dll at both locations. The /bin exists at the root and in the /Forumn directory.

DanComperini2
2009-01-14T14:12:30Z
... any other suggestions?
Spy4001
2009-06-10T09:54:00Z
DanComperini2 wrote:

... any other suggestions?



I'm on go daddy also, and I'm getting an error? is there anything i need to do beyond the help file?

thank you

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved