Mek
  •  Mek
  • 100% (Exalted)
  • YAF Developer
2008-12-27T03:30:27Z
@LaB:
Thanks for the bug report. I've added a new check box for IsApproved and added the relevant Flag save for it and updated the SVN.
Fix Included in latest SVN 27/12/2009.

@Everyone:
If you have a bug, problem, fix please create a new thread with all the relevant information (see Problems forum sticky).

UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )
danielgindi
2008-12-28T09:03:49Z
When installing the 1.8.3 RC2 on a sub-folder, the forum can't start!
For example:

Virtual directory is: /TestForum
YAF under: /TestForum/yaf

Exception Details: System.Web.HttpException: The file '/TestForum/pages/forum.ascx' does not exist.

it should look for /TestForum/yaf/pages not /TestForum/pages

And the paths ARE configured in App.config
TommyB
2009-01-03T12:29:54Z
An user has crashed my forum :/

I have set the full baseurl in app.config and recycled the apppool to get it working again (before it was "~/", now "http://forum.devs-on.net").
Before I have done this any links were destoyed (href="//default.aspx" which results in http://default.aspx" ).

He created a new thread that name contains an "ß" (german charter) and a smiley.

The complete name of the thread was: "2 kleine Anregungen und 1 Große :)"

(translated to english: Two small suggestions and a large one)
- Sry for my english ;)

BattCursor.Net  - Official homepage of that tool for vista laptops!
danielgindi
2009-01-04T03:29:32Z
ANNOUNCMENT:

There is a MySQL patch to download from the "Modifications, Patches, Themes and Languages " forum.
jaskey
  •  jaskey
  • 51.2% (Neutral)
  • YAF Forumling
2009-01-13T13:53:03Z
Hello excellent developers...

I am running the latest BETA and have several issues that I was wondering had already been fixed... I will be happy to track down the issues in the BETA source and solve them if you want but I didn't want to go off and do that if the issue was already fixed OR I was just being a moron in my config somehow...

1. When clicking the 'Lost Password' link, I simply get the login page again because I am not authenticated and allowed to get to the password reminder page. Once I login, I am happily forwarded to the Password Reminder page. :cheesy:

2. I have users that are assigned as an 'Administrator' and those users can happily create forums. However, those forums are not shown in the 'Forum Jump' and when the admin tries to create a new topic or reply to an existing topic the admin is redirected to the forum list of the first category instead.

does anyone have any thoughts or feedback on these... I will dig deeper and look for the issue if there is one.

Also... I am running the source from SVN as of today (1/13/2009).

thank you for all of your work on YAF... I use it on 3 of my sites and it is quite lovely.

j
havali
  •  havali
  • 54.2% (Neutral)
  • YAF Forumling
2009-01-14T04:19:48Z
Is there support for Active Directory?
I tried the ADProvider but it didn't work.
loki
  •  loki
  • 52.4% (Neutral)
  • YAF Forumling
2009-01-26T06:27:43Z
Hey guys. how is the final release coming along? ive done some modifications to the RC1 and am just looking at upgrading it again to fix any outstanding issues it has. will the final release be soon ish? or am i better of just going with RC2 for the moment?

N.
mddubs
2009-01-26T10:59:08Z
As far as I know, there's no date for the final release yet. I'd say go with RC2, document your own changes well, and then upgrade when it's released (that's what I'm doing).
UserPostedImage 
www.bunkerhollow.com  | www.careercomputing.com 
When I post fp:mddubs in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Mek 🙂, who stole this off Ederon 🙂 )
mack
  •  mack
  • 100% (Exalted)
  • YAF Commander
2009-01-28T13:43:24Z
I'm running the latest SVN version. So far, I love all the new features, it runs better and just works well overall. Hopefully the final will come out soon.
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer Topic Starter
2009-01-28T16:04:03Z
mack wrote:

I'm running the latest SVN version. So far, I love all the new features, it runs better and just works well overall. Hopefully the final will come out soon.


Yes! Soon! 🙂
victorantos
2009-02-01T09:39:03Z
upgraded to RC2, not an easy task...

I had to run my cursor in order to complete the user sys and I'm still not sure if everything is ok

- had problems with attachments, solved after giving write/read access to network service user

- still having problems with url rewrite if topic name contains some special chars,
for example this post does not, because it contains ă char

work: http://forum.yetanotherf...ers-ă-does-not-work.aspx 

- somewhere in the code is an error "filename" instead of "fileName" variable name

- because I had previously a Romanian language setting, I had some compilation error, and need to comment a line of code

over all took me more than 10 hours, and I estimated 1-2 hours,
but new forum looks good!


mack
  •  mack
  • 100% (Exalted)
  • YAF Commander
2009-02-03T15:00:22Z
I found a possible bug. When you 'report spam' or 'report abuse'.. can click 'moderate'. You can click the number of reports to I guess view data, but I get the error:
System.ArgumentException: Flags is neither a DataColumn nor a DataRelation for table Table.
at System.Data.DataRowView.get_Item(String property)
at YAF.Pages.moderate.reportedposts.FormatMessage(DataRowView row)
at ASP.pages_moderate_reportedposts_ascx.__DataBind__control15(Object sender, EventArgs e)
at System.Web.UI.Control.OnDataBinding(EventArgs e)
at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
at System.Web.UI.Control.DataBindChildren()
at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
at System.Web.UI.WebControls.Repeater.CreateControlHierarchy(Boolean useDataSource)
at System.Web.UI.WebControls.Repeater.OnDataBinding(EventArgs e)
at System.Web.UI.Control.DataBindChildren()
at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
at YAF.Pages.moderate.reportedposts.BindData()
at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
mack
  •  mack
  • 100% (Exalted)
  • YAF Commander
2009-02-03T15:06:40Z
mack wrote:

I found a possible bug. When you 'report spam' or 'report abuse'.. can click 'moderate'. You can click the number of reports to I guess view data, but I get the error:
System.ArgumentException: Flags is neither a DataColumn nor a DataRelation for table Table.
at System.Data.DataRowView.get_Item(String property)
at YAF.Pages.moderate.reportedposts.FormatMessage(DataRowView row)
at ASP.pages_moderate_reportedposts_ascx.__DataBind__control15(Object sender, EventArgs e)
at System.Web.UI.Control.OnDataBinding(EventArgs e)
at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
at System.Web.UI.Control.DataBindChildren()
at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
at System.Web.UI.WebControls.Repeater.CreateControlHierarchy(Boolean useDataSource)
at System.Web.UI.WebControls.Repeater.OnDataBinding(EventArgs e)
at System.Web.UI.Control.DataBindChildren()
at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
at YAF.Pages.moderate.reportedposts.BindData()
at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)



I can also report myself... I am using the SVN version. Not sure if this version will do it.
flow7oo
2009-02-03T23:29:49Z
Is anyone aware of this forum not working properly???
I try to follow the link to this forum from www.yetanotherforum.net  and I get a yellow screen of death and the same if I just click on the home link here. The only way I could get on here is by googling 'yaf forum down' and I got here, but a few characters are in Japanese ... very odd ... any ideas??? Here's the error page:

Server Error in '/' Application.
Index (zero based) must be greater than or equal to zero and less than the size of the argument list.

Stack Trace:

[FormatException: Index (zero based) must be greater than or equal to zero and less than the size of the argument list.]
   System.Text.StringBuilder.AppendFormat(IFormatProvider provider, String format, Object[] args) +7481133
   System.String.Format(IFormatProvider provider, String format, Object[] args) +107
   System.String.Format(String format, Object arg0) +43
   YAF.Controls.ForumStatistics.BindData() +1054
   YAF.Controls.ForumStatistics.DataBind() +13
   System.Web.UI.Control.DataBindChildren() +211
   System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding) +102
   System.Web.UI.Control.DataBind() +15
   YAF.Pages.forum.BindData() +171
   YAF.Pages.forum.Page_Load(Object sender, EventArgs e) +353
   System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14
   System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +35
   System.EventHandler.Invoke(Object sender, EventArgs e) +0
   System.Web.UI.Control.OnLoad(EventArgs e) +99
   System.Web.UI.Control.LoadRecursive() +50
   System.Web.UI.Control.LoadRecursive() +141
   System.Web.UI.Control.LoadRecursive() +141
   System.Web.UI.Control.LoadRecursive() +141
   System.Web.UI.Control.LoadRecursive() +141
   System.Web.UI.Control.LoadRecursive() +141
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +627

We’ve gone on holiday by mistake! Are you the farmer?
flow7oo
2009-02-03T23:33:06Z
Update: I'm on Firefox. Just tried browsing the forum with IE and it works. Must be a corrupt cookie or something...:shock:
We’ve gone on holiday by mistake! Are you the farmer?
Similar Topics
Users browsing this topic

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved