ahsan
  •  ahsan
  • 54.8% (Neutral)
  • YAF Forumling
2008-06-12T06:14:38Z
Source File: c:\xxx\My Documents\Visual Studio 2005\WebSites\YetAnotherForum.NET-beta\App_Code\YAF\Forum.cs Line: 108
dilson
  •  dilson
  • 52.4% (Neutral)
  • YAF Forumling
2008-06-12T23:31:54Z
"SQL changes for SQL Server 2000 compatibility."
is it still compatible for sql server 2005???
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer Topic Starter
2008-06-13T00:10:11Z
dilson wrote:

"SQL changes for SQL Server 2000 compatibility."
is it still compatible for sql server 2005???


Yeah, that was never a problem.
dilson
  •  dilson
  • 52.4% (Neutral)
  • YAF Forumling
2008-06-13T00:33:21Z
hi again, when i hit the next button after creating a config password, i get have this error message,

Server Error in '/yetanotherforum.net' Application.


Unable to save the configPassword. Please verify that the ASPNET user has write access permissions to the app.config file.

phaedoHD
2008-06-16T23:16:58Z
wow, awesome. I've been waiting for this for a while. nice work everybody involved.

I do have one question. My existing web app uses asp.net 3.5. So i downloaded the yaf source and used visual studio 2008 pro to auto upgrade everything to 3.5 to match my app. That worked fine.

However, when i publish yaf and then upload it and try to plug it in to my app i end up running into a conflict because when i published it, it created an App_Code.dll for yaf and this obviously would overwrite the existing one for my app.

So basically i can either have yaf work or my app, but not both because of this.

So i'm assuming i just need to publish it a little differently to avoid the conflict. Specifically publish it the way you guys did where there is no app_code.dll, but just mainly a bunch of YAF_*.dll libraries.

I just can't seem to figure out how to compile it correctly it seems. Once i do it appears it will work :-)

So what am I doing wrong here?
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer Topic Starter
2008-06-16T23:32:21Z
Just rename the App_Code.dll to something else -- .NET doesn't care the name of the dll.
dagzee
  •  dagzee
  • 51.8% (Neutral)
  • YAF Forumling
2008-06-17T00:05:23Z
It seems that after upgrading, no one can login anymore.

The forums are there, and they can be read fine by the guest user, but current users can't login. It simply always says that "user name or password entered is incorrect".

Using the "Lost Password" link always says "Unable to locate the user name entered".

I've checked yaf_user, and the users are still there. What could be going on?
phaedoHD
2008-06-17T00:16:36Z
really? I assumed it would complain at me if I did something like that, something like "unable to find bla bla bla" :-)

Thanks! I'll give it a go.
teknohippy
2008-06-18T04:06:43Z
I integrated v1.9.3 alpha into an existing site in a sub folder, and reworked everything to run from YAF membership, role and profile providors. I got it all working perfectly.

Now I'll try and apply the beta, although I forget everything I had to change to get YAF working in a subdirectory.

I'll see how it goes and report any problems.

I
teknohippy
2008-06-18T04:46:32Z
Does the database need updating from alpha? And is that all the install script does? As it fails when trying to create a table that already exists.

jtrac429
2008-06-18T04:59:22Z
Any idea when 1.9.3 will be ready for full release and will upgrading be easy? I am really looking forward to the next version.

I already downloaded the Beta version but as someone with limited programming experience I'm a little hesitant to try the upgrade with the current install.txt instructions.

Thanks!
teknohippy
2008-06-18T05:00:59Z
I've run into problems, I don't really need to upgrade while I'm finnishing the rest of the site so I'll probably leave it till release time and not have to fiddle a second time.

If anyone is interested, here's a work in progress example of how well YAF can be embedded into a website. With a complete shared user/profile/role base.

http://www.gigajamonline.com/forum/ 

I
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer Topic Starter
2008-07-03T19:39:38Z
Updated for July 3rd release. If most things are good it's going to go Release Candidate 1 very soon here.
Lac
  •  Lac
  • 89.60001% (Honored)
  • YAF Forumling
2008-07-05T01:42:12Z
Please make somethink with archive names for difference between updates (may be a build number).
smath
  •  smath
  • 52.4% (Neutral)
  • YAF Forumling
2008-07-10T08:13:58Z
dagzee wrote:

It seems that after upgrading, no one can login anymore.

The forums are there, and they can be read fine by the guest user, but current users can't login. It simply always says that "user name or password entered is incorrect".

Using the "Lost Password" link always says "Unable to locate the user name entered".

I've checked yaf_user, and the users are still there. What could be going on?



Same finding. I had update from 1.9.1.8 version to 1.9.3 beta and I can't login as Administrator. Although all users presents in dbo.yaf_User table.

Also I have several errors with "Cyrillic_General_CI_AS" and "SQL_Latin1_General_CP1250_CI_AS" sort params.

Exception Details: System.Data.SqlClient.SqlException: Не удалось разрешить конфликт параметров сортировки между "Cyrillic_General_CI_AS" и "SQL_Latin1_General_CP1250_CI_AS" в операции equal to. (Sorry, I have only russian description :oops: ).

Source Error:
Line 751: if ( UserProfile.Location != string.Empty )

Source File: d:\http_server\forum\controls\DisplayPost.ascx.cs Line: 751

My MS SQL Server 2005 has "SQL_Latin1_General_CP1250_CI_AS" sort params in Preferences.

Please, can you help me with these issues?
Source Error:
Line 91: if (1==0&& !statisticsDataRow.IsNull( "LastPost" ) )

Source File: d:\http_server\forum\controls\ForumStatistics.ascx.cs Line: 91
Users browsing this topic

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved