guest
2008-01-22T11:00:47Z
I got it up and running in a couple hours... got it all converted to a web app until I realized the app_code wasnt working right and dint want to mess with it.

I'm running a ASP.NET 3.5 Ajax futures site with the forum integrated into asp.net membership, role, and profile providers on VS2008 Team Systems
guest
2008-01-22T23:26:26Z
MaxxedMan Please! Give us a sample project! 🙂
guest
2008-01-24T07:40:38Z
Ederon wrote:

aewrigley wrote:

Hi

I am looking at v1.9.3, but can't get it to compile. I get 88 errors, all related to Unknown server tag 'YAF.[name of control]'.


What type of project? 1.9.3 uses VS2005 web site project with dynamic compilation, those unknown YAF tags are defined in web.config (are you missing it?). Look in install.txt.



Arrgh! Why did I not read install.txt?
bladefist
2008-01-24T17:07:00Z
I was wanting to use the defualt, asp.net membership stuff with YAF. I have successfully changed the web.config for roles and memberships to the defualt. The profile however, I cannot figure out. Does anyone have the web.config to do this?

Thanks
Lac
  •  Lac
  • 89.60001% (Honored)
  • YAF Forumling
2008-01-24T20:04:45Z
bladefist wrote:

I was wanting to use the defualt, asp.net membership stuff with YAF. I have successfully changed the web.config for roles and memberships to the defualt. The profile however, I cannot figure out. Does anyone have the web.config to do this?

Thanks

this:?
<roleManager enabled="true" defaultProvider="AspNetSqlRolesProvider">
      <providers>
        <clear/>
        <add
        name="AspNetSqlRolesProvider"
        type="System.Web.Security.SqlRoleProvider"
        connectionStringName="yafnet"
        applicationName="YetAnotherForum" />
      </providers>
    </roleManager>
    <membership defaultProvider="AspNetSqlMembershipProvider">
      <providers>
        <clear/>
        <add name="AspNetSqlMembershipProvider"
             type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
             connectionStringName="yafnet"
             enablePasswordRetrieval="false"
             enablePasswordReset="true"
             requiresQuestionAndAnswer="false"
             applicationName="YetAnotherForum"
             requiresUniqueEmail="false"
             passwordFormat="Hashed"
             maxInvalidPasswordAttempts="20"
             minRequiredPasswordLength="7"
             minRequiredNonalphanumericCharacters="1"
             passwordAttemptWindow="10"
             passwordStrengthRegularExpression="" />
      </providers>
    </membership>
    <profile defaultProvider="AspNetSqlProfileProvider" inherits="YAF.Classes.Utils.YafUserProfile">
      <providers>
        <clear />
        <add name="AspNetSqlProfileProvider"
             type="System.Web.Profile.SqlProfileProvider"
             connectionStringName="yafnet"
             applicationName="YetAnotherForum"
             description="desc" />
      </providers>
      <properties>
        
      </properties>
    </profile>

bladefist
2008-01-25T10:20:33Z
lac, thanks!

Only question, why does the profile part inherit "YAF.Classes.Utils.YafUserProfile" ??
RikoNaz
2008-01-26T04:47:16Z
Jaben will someone be able to look up the issue where a user will be able to create a duplicate screenname of a user when registering. ive tested the flaw in 1.9.1.7 and 1.9.3 and it works on both, allowing a user to create an exact duplicate of a name. so far ederon is looking into it.
Ederon
2008-01-26T06:23:59Z
RikoNaz wrote:

Jaben will someone be able to look up the issue where a user will be able to create a duplicate screenname of a user when registering. ive tested the flaw in 1.9.1.7 and 1.9.3 and it works on both, allowing a user to create an exact duplicate of a name. so far ederon is looking into it.


It's now fixed, but so far only available via SVN.

I strongly advise against putting 1.9.3 ALPHA into procution. Apart from the fact its still ALPHA, your forum is vulnerable unless you apply all fixes added to the SVN. They are not published as a download package yet. If you have 1.9.3 forum online, download latest version from SVN and update your forum immediately.
When I post FP:Ederon in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting.
UserPostedImage 
BoSJo
  •  BoSJo
  • 57.8% (Neutral)
  • YAF Forumling
2008-01-26T15:21:29Z
db.config
Original:
<add name="yafnet" connectionString="data source=(local);initial catalog=yafnet;integrated security=SSPI" />

had to remove "integrated security=SSPI" and add UID & PWD
Am not much in to MsSQL and .net so it might be me that don't understand it, so just a heads up on that one 😛 .


When "Require User Login:" is enabled :
No logg in box is visible in IE 7
Well actually, I can't get the log Inn box to show at all in IE 7
Seems like the Box HTML ain't being sent out at all


When editing under Administration/Host Setting
Clicking Save, don't take you back to the same pages, but to the Admin main page.
Ill put it up as a BUG as it's annoying to have to click 2 extra times during setting up each page.
But a much improved interface :-d


Viewing a direct (Copy/Paste in browser address bar) link with out permission on the user will generate the following error :
System.NullReferenceException: Object reference not set to an instance of an object.
at YAF.Classes.Base.ForumPage.ForumPage_Load(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
This was Copy/paste a link to the Admin section with a Guest user.
Seems that this only happens when "Require User Login:" is set


Clicking link in new Reply notification mail invoked the "you have tried to access a page you do not have access to.....or something"
Redirected to :
There has been a serious error loading the forum. No futher information is available.

Please contact the administrator if this message persists.

Event log shows :

System.FormatException: Index (zero based) must be greater than or equal to zero and less than the size of the argument list.
at System.Text.StringBuilder.AppendFormat(IFormatProvider provider, String format, Object[] args)
at System.String.Format(IFormatProvider provider, String format, Object[] args)
at YAF.Controls.ForumStatistics.BindData()
at YAF.Controls.ForumStatistics.DataBind()
at System.Web.UI.Control.DataBindChildren()
at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
at System.Web.UI.Control.DataBind()
at YAF.Pages.forum.BindData()
at YAF.Pages.forum.Page_Load(Object sender, EventArgs e)
at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

I only got this Event log out because i Had a Tab open in the Admin section.
I can no longer enter the forum without getting the above error.

BoSJo
  •  BoSJo
  • 57.8% (Neutral)
  • YAF Forumling
2008-01-26T15:26:47Z
Forum inaccessible at test.bojohansen.no 
But if i enter a direct link to admin section http://test.bojohansen.no/default.aspx?g=admin_hostsettings  i get in.
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer Topic Starter
2008-01-26T18:38:38Z
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer Topic Starter
2008-01-26T21:37:21Z
Updated release! Please be sure and test this baby. Hopefully it will be much closer and we can think about a BETA release of v1.9.3.
BoSJo
  •  BoSJo
  • 57.8% (Neutral)
  • YAF Forumling
2008-01-27T01:46:05Z
Jaben wrote:

http://test.bojohansen.no worked fine for me.



I deleted the cookies in IE7, and the site displays the login box again.
After login i get the same error again.

Try going to test.bojohansen.no
User: BoSJo_Test
PWD: 123456

After login you get the error, but then paste this in the browser
http://test.bojohansen.no/default.aspx?g=cp_pm 

You can surf everything except the forum part.

Should i keep it for debugging, or just overwrite with the new release?
Ederon
2008-01-27T03:00:20Z
BoSJo wrote:

Jaben wrote:

Should i keep it for debugging, or just overwrite with the new release?


Maybe send us your web.config/app.config as I suspect it's config error. Anyway, have you looked to YAF event log? If you can't reach it via web, look directly to the database.
When I post FP:Ederon in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting.
UserPostedImage 
BoSJo
  •  BoSJo
  • 57.8% (Neutral)
  • YAF Forumling
2008-01-27T03:18:55Z
Ederon wrote:


Maybe send us your web.config/app.config as I suspect it's config error. Anyway, have you looked to YAF event log? If you can't reach it via web, look directly to the database.



Event log when calling site root with firefox and cookie set on an administrator account.

System.FormatException: Index (zero based) must be greater than or equal to zero and less than the size of the argument list.
at System.Text.StringBuilder.AppendFormat(IFormatProvider provider, String format, Object[] args)
at System.String.Format(IFormatProvider provider, String format, Object[] args)
at YAF.Controls.ForumStatistics.BindData()
at YAF.Controls.ForumStatistics.DataBind()
at System.Web.UI.Control.DataBindChildren()
at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
at System.Web.UI.Control.DataBind()
at YAF.Pages.forum.BindData()
at YAF.Pages.forum.Page_Load(Object sender, EventArgs e)
at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Web.Config and app.config are mailed

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved