jj72uk
  •  jj72uk
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2014-09-05T09:46:04Z
I know there are a lot of threads on this forum around this but none have helped or solved my issue.

My issue is pretty simple, and that is my YAF can't send emails...so no registration confirmations, no emails to user groups..not even using the SMTP Test in the install pages.

So, in my app.config file I have:

Quote:


<appSettings>
//
//
//
<add key="YAF.UseSMTPSSL" value="true" />
//
//
</appSettings>



In my mail.config I have:

Quote:


<smtp deliveryMethod="Network" from="noreply@domain.co.uk">
<!-- Uncomment to specify SMTP settings -->
<network host="smtp.zoho.com" port="465" password="password" userName="noreply@domain.co.uk" />
</smtp>



If I try to send a registration confirmation, a test email or even a Mail (SMTP) Sending Test it all fails, nothing, nada.

The details I am using (password, host, port etc) are all correct, I know this because I have used the same details when setting up the POP3/SMTP to link the mailbox to my phone, it works.

Checking YAF logs and it says this:

Quote:


SendMailThread Failed for the 2nd time (the email will now deleted) with an SmtpException (Email to: info@domain.co.uk, Subject: Test): System.Net.Mail.SmtpException: The operation has timed out. at System.Net.Mail.SmtpClient.Send(MailMessage message) at YAF.Core.Services.YafSendMail.SendAll(IEnumerable`1 messages, Action`2 handleException)



The Mail (SMTP) Sending Test times out as well.

I am running the latest version of YAF (2.1.2) and have restarted the app (using the admin menus within YAF).

I'm close to whits end!

Any help would be great.
Sponsor
tha_watcha
2014-09-07T04:28:48Z
Are you sure your Mail Server uses SSL?

try to set it to false...
<add key="YAF.UseSMTPSSL" value="false" />

UserPostedImage
jj72uk
  •  jj72uk
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2014-09-07T21:12:38Z
Originally Posted by: tha_watcha 

Are you sure your Mail Server uses SSL?

try to set it to false...

<add key="YAF.UseSMTPSSL" value="false" />




I can try, but according to the settings:

http://www.zoho.com/mail/help/zoho-smtp.html 

It uses SSL
jj72uk
  •  jj72uk
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2014-09-08T07:35:03Z
Originally Posted by: tha_watcha 

Are you sure your Mail Server uses SSL?

try to set it to false...

<add key="YAF.UseSMTPSSL" value="false" />



Still not working!

jj72uk
  •  jj72uk
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2014-09-08T08:02:37Z
Ok,

Solved it!!

It seems that Zoho does not support TLS (latest SSL protocol)....and Microsoft .Net supports only TLS..not SSL (older protocol). Thats why it wont work.

See http://msdn.microsoft.co...mtpclient.enablessl.aspx 

The SmtpClient class only supports the SMTP Service Extension for Secure SMTP over Transport Layer Security as defined in RFC 3207. In this mode, the SMTP session begins on an unencrypted channel, then a STARTTLS command is issued by the client to the server to switch to secure communication using SSL. See RFC 3207 published by the Internet Engineering Task Force (IETF) for more information.

So changing to use port 587 worked.

EDIT

Still doesn't work. It worked when using the test in the install pages, but when registering, and/or sending mail to users it still doesnt work.

Back to square one.

EDIT OF THE EDIT

Got it to work. As above but I had the wrong "From" email in the "Board Settings" page within YAF itself
Users browsing this topic

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved