netghost
  •  netghost
  • 80.6% (Honored)
  • YAF Lover Topic Starter
2012-04-25T13:19:29Z
i am trying to send an email from the test email page during the installation of my site , but i keep getting the same error message


Failed to connect:

Mailbox unavailable. The server response was: Authentication is required for relay


MY SMTP CODE IS SHOWN BELOW

<!--
	SMTP setup for sending of e-mails from your forum.
	If the SMTP is SSL, you must edit the appSettings and set
	"YAF.UseSMTPSSL" to "true".
-->
<smtp deliveryMethod="Network" from="info@MYSITE.COM">
	<!-- Uncomment to specify SMTP settings -->
	<network host="mail.MYSITE.COM" port="25" password="" userName="j" />
</smtp>

<!-- Use this setting for development: pickup directory must be exact path -->
<!--smtp deliveryMethod="SpecifiedPickupDirectory">
	<specifiedPickupDirectory pickupDirectoryLocation="C:\Inetpub\wwwroot\email" />
</smtp-->
Sponsor
francoz
2012-04-25T14:44:41Z
It cannot work if this is really your actual code!
<network host="your_real_smtp_server-FQDN" port="25" password="your real password" userName="your realusername" />

If your server does not require athentication (usually when on the same subnet or given from your provider:
<network host="your_real_smtp_server-FQDN" port="25" password="" userName="" />
Chetan Bavarva
2016-11-19T13:24:13Z
You need to change in web.config


<system.net>
    <mailSettings>
      <smtp>
              <network host="hostName" port="port" enableSsl="true|false" password="your real password" userName="your real userName" />       
      </smtp>
    </mailSettings>
</system.net>

Chetan Patel
Custom software company India 
iFour Technolab Pvt. Ltd

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved