Racingtrader
2011-12-19T00:28:01Z
I downloaded Mircosoft Webmatrix to updated to the latest version.

I uploaded all files and ran the installer I kept getting a "could not connect to database error" and now I am getting: I think I have more then 1 issue now. Lets start here.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
Sponsor
squirrel
2011-12-19T03:45:26Z
Originally Posted by: Racingtrader 

I downloaded Mircosoft Webmatrix to updated to the latest version.

I uploaded all files and ran the installer I kept getting a "could not connect to database error" and now I am getting: I think I have more then 1 issue now. Lets start here.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>



In order to see the true error, you need to do exactly what this response tells you: Edit your web.config file, change the line for custom errors to read:
<customErrors mode="off">

upload it back to the server, then run the page -- you will get a detailed error.

If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
Racingtrader
2011-12-19T04:25:53Z
I found 2 web.config files. One is located under the root and the 2nd is in a folder called webconfigs with 2 other files in it plus a web.config. Which one do I edit.
Racingtrader
2011-12-19T04:53:25Z
I tried editing both and I'm still getting the same error here is my edit:

<system.web>
<customErrors mode="Off">
<trace enabled="false"/>
<xhtmlConformance mode="Transitional"/>
<globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
<authentication mode="Forms">
<forms name=".YAFNET_Authentication" protection="All" timeout="43200" cookieless="UseCookies"/>
</authentication>
<!-- Set debug to "true" to test out the system in development -->
<compilation defaultLanguage="c#" debug="false">
<assemblies>
tha_watcha
2011-12-19T12:10:08Z
You only need to Modify the Web.Config in the Root folder.

Did you run the Install Wizard to Create the Database? You need to run yourforumdomain.com/install/default.aspx First in order to setup YAF.
UserPostedImage
Racingtrader
2011-12-19T13:10:26Z
I ran the installer but it would not connect to exisiting database. I edited the config file to update username/password. someone around there is when it went bad.
Racingtrader
2011-12-20T05:09:55Z
I checked the file thru my ftp in the browser and noticed a error.

XML Parsing Error: not well-formed
Location: ftp://ftp.racingtrader.ca/web.config 
Line Number 25, Column 38: <xhtmlConformance mode="Legacy"/></ system.web>
---------------------------------------------------^


This is how the config file is:

<?xml version="1.0"?>
<configuration>
<configSections>
<section name="yafnet" type="yaf.SectionHandler,yaf"/>
<section name="rewriter" type="Intelligencia.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, Intelligencia.UrlRewriter" />
</configSections>

<yafnet configSource="yafnet.config"/>
<rewriter configSource="urlrewriter.config"/>
<connectionStrings>
<add name="Member" connectionString="Server=xxxxxx;Database=xxxxxxxr;uid=xxxxxxxr;pwd=xxxxxxxx"/>
</connectionStrings>
<system.web>
<httpModules>
<add type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter" name="UrlRewriter" />
</httpModules>
<globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
<compilation defaultLanguage="c#" debug="false"/>
<pages enableEventValidation="false" validateRequest="false" smartNavigation="false"/>
<authentication mode="Forms">
<forms name=".YAFNET_Authentication" timeout="525600" />
</authentication>
<customErrors mode="Off">
<!--trace enabled="true" pageOutput="true"/-->
<xhtmlConformance mode="Legacy"/></system.web>
</configuration>



xxxx = removed info
tha_watcha
2011-12-20T10:41:04Z
Please change the line from

<customErrors mode="Off">

to

<customErrors mode="Off" />



UserPostedImage

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved