ultrafly5
  •  ultrafly5
  • 52.4% (Neutral)
  • YAF Forumling Topic Starter
2011-05-31T01:17:21Z
Hi everybody..

I'm trying to upgrade from v1.9.1.8 to v1.9.5.5.
However at the upgrade stage, there's never a user migrating procedure. This caused the upgrade forum does not have any correspondent values for the previous registered over 15000 users. They could not login at all. Please help me. I can pay for the support.
What's the problem anyway!?!
This is very urgent!!!
Sponsor
squirrel
2011-05-31T02:45:25Z
You used the wrong web.config when you uploaded the new code to the server. In order to upgrade from v1.9.1.8 you have to use the "UPGRADE" web.config in the web.configs folder inside the zip package. This will migrate the old user password format during the upgrade process.
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
ultrafly5
  •  ultrafly5
  • 52.4% (Neutral)
  • YAF Forumling Topic Starter
2011-05-31T02:54:53Z
v191-upgrade-web.config

I use the above config file and renamed it to web.config.

No migrating process at all.

Please help!!!!!
Thank you.
squirrel
2011-05-31T11:21:48Z
Originally Posted by: ultrafly5 

v191-upgrade-web.config

I use the above config file and renamed it to web.config.

No migrating process at all.

Please help!!!!!
Thank you.



Did you go to ~/install/default.aspx to run the upgrade process?

If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
ultrafly5
  •  ultrafly5
  • 52.4% (Neutral)
  • YAF Forumling Topic Starter
2011-05-31T22:27:55Z
I have been working on this for over 5 days. I certainly have installed it with install/default.aspx.
The problem is that at the upgrade stage, the program never process the existing users migration.
It simply skipped this stage. Anyone can help me with this problem. I will pay 100$ for him. Please help!!
logan
  •  logan
  • 100% (Exalted)
  • YAF Leader
2011-05-31T23:08:44Z

Browse to Yoursite.com//install/default.aspx?upgrade=25

See if that kicks in the migration.
test
ultrafly5
  •  ultrafly5
  • 52.4% (Neutral)
  • YAF Forumling Topic Starter
2011-05-31T23:33:15Z
Thank you for all your replys. I kind of got the reason.
I found that those sql queries never run successfully due to permission stuff. Following is the error message I got with those queries manually run in sql server manager. This permission thing caused failing to run those migrating sql queries. Anybody know how to fix it!?!!?! A BUNCH OF THANKS!



Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_upgrade, Line 17
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_createapplication, Line 15
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_changepassword, Line 17
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_changepasswordquestionandanswer, Line 15
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_createuser, Line 23
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_deleteuser, Line 24
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_findusersbyemail, Line 31
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_findusersbyname, Line 31
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_getallusers, Line 30
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_getnumberofusersonline, Line 19
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_getuser, Line 23
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_getusernamebyemail, Line 13
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_resetpassword, Line 19
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_unlockuser, Line 14
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_updateuser, Line 44
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_role_addusertorole, Line 27
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_role_deleterole, Line 30
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_role_findusersinrole, Line 17
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_role_createrole, Line 14
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_role_getroles, Line 16
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_role_isuserinrole, Line 14
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_role_removeuserfromrole, Line 19
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_role_exists, Line 13
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_profile_deleteinactive, Line 26
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_profile_deleteprofiles, Line 54
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_profile_getprofiles, Line 48
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.
Msg 2760, Level 16, State 1, Procedure {objectQualifier}prov_profile_getnumberinactiveprofiles, Line 11
The specified schema name "{databaseOwner}" either does not exist or you do not have permission to use it.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved