JBenH
  •  JBenH
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
2011-02-24T18:49:05Z
I've change the web.config as follows

<authentication mode="Windows">
<forms name=".YAFNET_Authentication" protection="All" timeout="43200" cookieless="UseCookies"/>
</authentication>

<membership defaultProvider="AspNetActiveDirectoryMembershipProvider" >
<providers>
<clear />
<add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="true" useSalt="true" type="YAF.Providers.Membership.YafMembershipProvider" />
<add name="AspNetActiveDirectoryMembershipProvider" attributeMapUsername="sAMAccountName" type="System.Web.Security.ActiveDirectoryMembershipProvider,System.Web, Version=2.0.3600.0, Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="ADConnection" connectionUsername="readonly" connectionPassword="ask123" />
</providers>
</membership>

But I am getting the following error when the forum loads
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: The connection name 'ADConnection' was not found in the applications configuration or the connection string is empty.

Source Error:


Line 91: <clear />
Line 92: <add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="true" useSalt="true" type="YAF.Providers.Membership.YafMembershipProvider" />
Line 93: <add name="AspNetActiveDirectoryMembershipProvider" attributeMapUsername="sAMAccountName" type="System.Web.Security.ActiveDirectoryMembershipProvider,System.Web, Version=2.0.3600.0, Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="ADConnection" connectionUsername="readonly" connectionPassword="ask123" />
Line 94:
Line 95: </providers>


Source File: c:\inetpub\wwwroot\apps\MillForum\web.config Line: 93

Does anyone have notes on how to setup the 'ADConnection'?

Sponsor
rickjackson
2011-06-21T09:12:13Z
Originally Posted by: JBenH 

I've change the web.config as follows

<authentication mode="Windows">
<forms name=".YAFNET_Authentication" protection="All" timeout="43200" cookieless="UseCookies"/>
</authentication>

<membership defaultProvider="AspNetActiveDirectoryMembershipProvider" >
<providers>
<clear />
<add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="true" useSalt="true" type="YAF.Providers.Membership.YafMembershipProvider" />
<add name="AspNetActiveDirectoryMembershipProvider" attributeMapUsername="sAMAccountName" type="System.Web.Security.ActiveDirectoryMembershipProvider,System.Web, Version=2.0.3600.0, Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="ADConnection" connectionUsername="readonly" connectionPassword="ask123" />
</providers>
</membership>

But I am getting the following error when the forum loads
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: The connection name 'ADConnection' was not found in the applications configuration or the connection string is empty.

Source Error:


Line 91: <clear />
Line 92: <add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="true" useSalt="true" type="YAF.Providers.Membership.YafMembershipProvider" />
Line 93: <add name="AspNetActiveDirectoryMembershipProvider" attributeMapUsername="sAMAccountName" type="System.Web.Security.ActiveDirectoryMembershipProvider,System.Web, Version=2.0.3600.0, Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="ADConnection" connectionUsername="readonly" connectionPassword="ask123" />
Line 94:
Line 95: </providers>


Source File: c:\inetpub\wwwroot\apps\MillForum\web.config Line: 93

Does anyone have notes on how to setup the 'ADConnection'?




Have you ever got solution to your problem...... If yes please post step by step instruction so we can implement that in our application.... please even just reply to this post with the information i haven't seen administrators try to help us on this......

regards,

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved