Underground
2010-11-21T10:44:36Z
Again, I want to put this into the attention of the developers. I do this, because I never received any answer on this matter while this problem causes me to stick with version 1.9.4

During the development, the email notification got broken. I always have the development version running on my testsite where people are testing it. And if found OK, I moved it to the real site (www.globalcaching.eu/forum/)
But some time ago, the email notifications of new posts didn't work anymore. The email service (e.g. sending a PM notification) is working. Just gettting an email when someone posted in a thread you are watching is not working.
Same here on this forum. I will put a watch on this thread, but I know I won't get an email if someone answers to this post.

Now, In another thread another user also reported this, but again....total silence... :(
I know that people are working hard on the forum software. Every day I do a SVN Update on the repository and every day I see that the source is updated.

Can a developer help me with this issue? Am I doing something wrong here?
Again, also putting a watch on this thread doesn't work (digest is off). So, it doesn't seem te be a problem on my server/email host (gmail).
I am using gmail account for both sending emails and receiving. I don't see any error message in the error log.

Any comment or feedback on the status or whatever would be appreciated.
If you are saying that you are working on it, ok.
If you are saying that you don't work on it, ok (I stick to 1.9.4 and wait for 2.0 or something)
My site containing the YAF forum: Globalcaching.eu 
Sponsor
tha_watcha
2010-11-21T13:42:10Z
Quote:

Can a developer help me with this issue? Am I doing something wrong here?



I had some Similar Problems, but strangely they are disappear, and i can not reproduce them.

Emails work also on that forum.

I did noticed one thing it didn't worked once, but after i hit the "save" Button on the Subscriptions Page in User Control Panel Email Notifications working again.

You could post this on The YAF Bugtracker.
UserPostedImage
Underground
2010-11-21T14:04:54Z
tha_watcha, thanks for your reply.

But also now, I didn't receive an email notification. (And I added this thread to the watch list).
And the settings are attached to this post (settings here at yaf forum)


edit:
weird...
You see the second picture at the bottom this tthread? (email notification doesn not work)
When I click on it, it brings me to another thread. (http://forum.yetanotherforum.net/yaf_postst4268_CAPTCHA-Mod--version-1-0.aspx)
Underground attached the following image(s):

My site containing the YAF forum: Globalcaching.eu 
tha_watcha
2010-11-22T10:45:15Z
Originally Posted by: Underground 

edit:
weird...
You see the second picture at the bottom this tthread? (email notification doesn not work)
When I click on it, it brings me to another thread. (http://forum.yetanotherforum.net/yaf_postst4268_CAPTCHA-Mod--version-1-0.aspx)



Confirmed Watch Topics and Watch Forums where showing wrong Topics and Forums, fixed in Rev. 4158

UserPostedImage
Underground
2010-11-22T14:51:05Z
Thanks!

Also, you said it was fixed for you when you saved the notification setting (in edit profile?)
Well, I did this (here in this forum) and now I got a notification email.

I will test it on our test site too.
But does this mean that all existing (or even new) users must do this?
My site containing the YAF forum: Globalcaching.eu 
tha_watcha
2010-11-22T15:55:53Z
Quote:

I will test it on our test site too.
But does this mean that all existing (or even new) users must do this?



I Think only for existing. But that can be done tru an Updated Sql Update Script. But first i have to figure out what setting needs to be updated.
UserPostedImage
cagliostro
2010-11-22T23:29:20Z
It doesn't work for me also, with the latest 1.9.5 rtm and DNN.

PM or send an topic with email works, new posts do not.
cagliostro
2010-11-23T17:18:14Z
Originally Posted by: Underground 

Thanks!

Also, you said it was fixed for you when you saved the notification setting (in edit profile?)
Well, I did this (here in this forum) and now I got a notification email.

I will test it on our test site too.
But does this mean that all existing (or even new) users must do this?




Even if all users save their settings for notifications, still they don't get ANY post notice.


Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2010-11-23T18:34:27Z
I'm starting to believe it might not be so much an issue with YAF as the .NET SMTP client's unique behavior.

If you have control, I recommend upgrading to .NET v4 which fixes some big issues with .NET SMTP client.
cagliostro
2010-11-23T18:38:46Z
Originally Posted by: Jaben 

I'm starting to believe it might not be so much an issue with YAF as the .NET SMTP client's unique behavior.

If you have control, I recommend upgrading to .NET v4 which fixes some big issues with .NET SMTP client.




In my case (DNN) all email works very well (blog module and other modules of DNN), including YAF PM, just the notifications stopped with 1.9.5.

Personally i have NET 4 but i can't switch yet due to some major incompatibilities of DNN for the moment.

Seems strange still to be a problem of what you say ....




Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2010-11-23T18:43:45Z
Originally Posted by: cagliostro 

Originally Posted by: Jaben 

I'm starting to believe it might not be so much an issue with YAF as the .NET SMTP client's unique behavior.

If you have control, I recommend upgrading to .NET v4 which fixes some big issues with .NET SMTP client.




In my case (DNN) all email works very well (blog module and other modules of DNN), including YAF PM, just the notifications stopped with 1.9.5.

Personally i have NET 4 but i can't switch yet due to some major incompatibilities of DNN for the moment.

Seems strange still to be a problem of what you say ....



You've looked in the Admin->Event Logs... have you seen any email errors?

cagliostro
2010-11-23T18:45:00Z
Originally Posted by: Jaben 



You've looked in the Admin->Event Logs... have you seen any email errors?




No errors related to smtp anywhere.


cagliostro
2010-11-23T18:47:21Z
Does YAF for DNN relies to DNN for email (smto) sending ?


Underground
2010-11-23T21:25:20Z
Originally Posted by: Underground 

I will test it on our test site too.


I am sorry to say that it doesn't work on my test site.

It is not related to .NET 3.5 SP1, because both, real and test sites, are running on the same machine.
The error log does not say anything about email.
PM notifications are sent, so no issue with SMTP.

Frustrating I know...
Also, I got 2 notifications for this thread, but it stopped working (and yes, I did check this thread while signed in, but with no post after I viewed the thread I got a message)
Something is seriously wrong with the post message notification.

My site containing the YAF forum: Globalcaching.eu 
cagliostro
2010-11-23T21:33:19Z
I'm installing a backup of my DNN / YAF site and i will test with Net4, as Jaben suggested.

I will know in an hour or so.


About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved