tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-07-21T05:38:27Z
I've recently upgraded to YAF 2.31.7 from 2.31.5. Now, if we open any post with attachments, we see the following error message:

Quote:

Forum Error
There has been a serious error loading the forum. No further information is available.
Please contact the administrator if this message persists.



The corresponding record in the event log shows the following exception and stack trace:

Exception at URL: https://example.com/forum/Default.aspx?g=posts&t=337& (URL:'https://example.com/forum/Default.aspx?g=posts&t=337&')
System.Web.HttpException (0x80004005): Could not load type 'YAF.Web.BBCodes.Attach'.
   at System.Web.Compilation.BuildManager.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase)
   at YAF.Web.Controls.MessageBase.<>c__DisplayClass3_0.<RenderModulesInBBCode>b__0(KeyValuePair`2 keyPair)
   at System.Collections.Generic.List`1.ForEach(Action`1 action)
   at YAF.Types.Extensions.EnumerableExtensions.ForEach[T](IEnumerable`1 list, Action`1 action)
   at YAF.Web.Controls.MessageBase.RenderModulesInBBCode(HtmlTextWriter writer, String message, MessageFlags theseFlags, Nullable`1 displayUserId, Nullable`1 messageId)
   at YAF.Web.Controls.MessagePostData.RenderMessage(HtmlTextWriter writer)
   at YAF.Web.Controls.MessagePost.Render(HtmlTextWriter writer)
   at System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter)
   at System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter)
   at System.Web.UI.Control.RenderControl(HtmlTextWriter writer)
   at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children)
   at System.Web.UI.Control.RenderChildren(HtmlTextWriter writer)
   at System.Web.UI.WebControls.WebControl.RenderContents(HtmlTextWriter writer)


Please, fix this as soon as possible!
Sponsor
tha_watcha
2020-07-21T09:38:31Z
Go to Admin > Settings > BB Code Extensions > Click on Attach Edit > and under Module Class Name change it to..

YAF.Modules.BBCode.Attach

UserPostedImage
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-07-22T11:37:23Z
I hope this will be a built-in fix in the next update, v2.31.8?

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved