tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-07-14T14:19:47Z
I downloaded the source code of the latest release of YAF (2.31.7) and tried to do my traditional manipulations with fonts and colors in the source code to get bootstrap-forum.min.css for the public forum. One of the manipulations I do after every upgrade is the following:

http://yetanotherforum.n...-theme-font-size-in-v2-3 

However, I couldn't recompile bootstrap-forum.scss this time. I got the following error:

Description = Plugin Error: Cannot find module 'autoprefixer'
File = bootstrap-forum.scss
Line = 0

Any idea how to fix this problem?
Sponsor
tha_watcha
2020-07-15T01:04:05Z
Originally Posted by: tecman 

I downloaded the source code of the latest release of YAF (2.31.7) and tried to do my traditional manipulations with fonts and colors in the source code to get bootstrap-forum.min.css for the public forum. One of the manipulations I do after every upgrade is the following:

http://yetanotherforum.n...-theme-font-size-in-v2-3 

However, I couldn't recompile bootstrap-forum.scss this time. I got the following error:

Description = Plugin Error: Cannot find module 'autoprefixer'
File = bootstrap-forum.scss
Line = 0

Any idea how to fix this problem?



No. Maybe re-installing the webcompiler would help?
UserPostedImage
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-07-15T14:55:55Z
This does not help.
Reinstalling Node.JS also does not help.
Your PowerShell script for caniuse-lite does not help too.
tha_watcha
2020-07-15T16:09:22Z
try to update autprefixer with my updates powershell script

## Remove current version of caniuse-lite & browserlist
rm -r -fo $Home\AppData\Local\Temp\WebCompiler*\node_modules\caniuse-lite\
rm -r -fo $Home\AppData\Local\Temp\WebCompiler*\node_modules\browserlist\

## Install caniuse-lite and browserlist new versions in proper directory
cd $Home\AppData\Local\Temp\WebCompiler*
npm i caniuse-lite browserlist autoprefixer

## Popup to confirm installation completed
$wshell = New-Object -ComObject Wscript.Shell
$wshell.Popup("caniuse-lite & browserlist have been updated",0,"NPM Install Complete",0x0 + 0x40 + 0x1000)

UserPostedImage
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-07-15T16:51:22Z
I mentioned exactly this script in my previous post :)

It seems, updating Node to the latest version (v12.18.2) helped to solve the problem. But I am not sure as I tried different things in different combinations.

In any case, the problem has been solved.
tha_watcha
2020-07-15T17:30:33Z
I mentioned exactly this script in my previous post :)

Yes but I updated the script to include autoprefixer. You didn't mention that 😉
UserPostedImage
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-07-16T05:16:04Z
Did mention :)
Originally Posted by: tecman 

Your PowerShell script for caniuse-lite does not help too.



About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved