tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-03-03T15:27:51Z
I see the constantly increasing number of server errors 5xx in Google Search Console after switching to YAF 2.3. They all similar and are related to ScriptResource.axd and WebResource.axd, for example:

https://forum.example.com/ScriptResource.axd?d=0tikUa4IUuZJsJTN_KUca21uDswypknbd98mq6SEtak_Ys2ffanI1exrCxTmpPeVj_BrPzm-_g6F9dSqlQJ9ht64M6AOdBSynrjjfMc_dsB3ONosiyjFYQtd8v5BbhH2TDoVvZfDQpTzJ-Alytaf4V_lve_oWca59QizWNS7Wo04qZErFh45_jNiMBT9g4v40&t=545ba255


When I open such a link, I get the following:


Server Error in '/forum' Application.
Runtime Error
Description: An exception occurred while processing your request. Additionally, another exception occurred while executing the custom error page for the first exception. The request has been terminated. 


Is there a way to get rid of this problem?
Sponsor
tha_watcha
2020-03-05T07:38:20Z
Is this still an issue? I dont see this issue anymore on your site
UserPostedImage
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-03-05T14:42:06Z
If I open that link after replacing forum.example.com with the URL to our forum, yes, I get the same error.

Perhaps, you need to specify 'noindex' for crawlers for ScriptResource.axd and WebResource.axd on your side or something like that to avoid this problem.

And I even do not understand when and how Google's bot found those strange URLs. Any ideas?
tha_watcha
2020-03-05T15:16:28Z
Yes of course it throws an error because the url is outdated.

As a workaround create a robots.txt

User-agent: Googlebot
Disallow: /*.axd

UserPostedImage
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-03-05T16:38:05Z
We do have robots.txt on our website but Google doesn't like it. It prefers the noindex meta-tag.
tha_watcha
2020-03-05T17:33:49Z
Script tags doesn't have no follow tags! The only way is the robots.txt! That even suggest by Google. Why should Google habe a problem with the robots file?
UserPostedImage
Ulvis.net
2020-03-06T03:05:19Z
I have same problem but better is block in htacess and forward to home page? 🤔

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved