fseries
  •  fseries
  • 53.6% (Neutral)
  • YAF Forumling Topic Starter
2009-01-11T17:46:12Z
My forum is in a sub folder (forum). You can get to the forum but when you click on anything it is cutting off the "/forum" on all the urls. For instance if you click on "Test Forum" you get the following link: http://www.mylapbandexpe...lt.aspx?g=topics&f=1  which is missing the /forum/.

I do have:
<add key="root" value="/forum"/> in the app.config file.

http://www.mylapbandexperience.com/forum/ 

Sponsor
Mek
  •  Mek
  • 100% (Exalted)
  • YAF Developer
2009-01-11T23:03:24Z
try ~/forum/

UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )
fseries
  •  fseries
  • 53.6% (Neutral)
  • YAF Forumling Topic Starter
2009-01-17T16:04:46Z
I tried that and it did not work. I put part of the app.config file below. Any other ideas? Or something I might have missed?

Quote:


......
<!--
******************************************************************
** Optional Root Key ** Defaults to: "~/" **

If YAF forum files are not located in the Application Root (~/)
of your web site you need to specify the additional url
in this root key. Example: Application Root is "www.mysite.com/"
You want your forum at "www.mysite.com/forum". You need to specify
"/forum" in your root key below.

PLEASE NOTE:

YAF .dll files (from the \bin directory in the zip) AND ALL files
in the \App_Code directory MUST be located in the Application Root.
-->
<add key="root" value="~/forum"/>

<!--
******************************************************************
** Optional Base URL ** Defaults to: "~/" **

If YAF forum URL is different than the Application Root,
you will need to specify the BaseURL here of the forum.

e.g. ~/forum

If you use the BaseUrlOverrideDomain key, you can also include
the complete URL for the forum even if the domain is different
than the domain the web server registers. (Domain masking)

e.g. https://www.myforumdomain.com/forum 
e.g. http://www.myforumdomain.net 
-->
<add key="BaseUrl" value="~/forum" />

<!--
******************************************************************
** Optional Base URL Override Domain ** Defaults to: "false" **

Use this key with the BaseURL key above to specify a domain
mask for your YAF forum.
-->
<add key="BaseUrlOverrideDomain" value="false" />
</appSettings>

Mek
  •  Mek
  • 100% (Exalted)
  • YAF Developer
2009-01-18T01:01:21Z
Change baseurl back to ~/ and see what happens. Keep root as ~/forum/ though.


UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )
gfrancher
2009-01-22T14:27:38Z
I was having the same problem with links missing the forum subfolder name.

These are the key settings that worked for me:

<add key="root" value="~/forum" />
<add key="BaseUrl" value="~/forum" />
<add key="BaseUrlOverrideDomain" value="true" />
Users browsing this topic

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved